LinHES Forums

does not even get to bootloader
Page 2 of 3

Author:  mjl [ Tue May 16, 2006 5:46 am ]
Post subject: 


Author:  DyDx [ Tue May 16, 2006 6:10 am ]
Post subject: 

The drive is a Maxtor jumpered as Master (I will check this to be 100% sure but I would be extremely surprised if it was CS -- I never use CS).

Also, the OC isn't going to effect anything. It was achieved at default RAM timings and voltages (Barton 2500+'s are excellent overclockers)-- it has been OC'ed like this for literally 2 years straight without nary a hiccup, in various distributions of Linux and Windows. Nor is the RAM cheap (Kingston -- not expensive but still good ram).

The tuner card is a PVR150 but that doesn't matter until I can actually get into MythTV since no tuner setup is done until then (I could be wrong since I haven't gotten that far yet).

Author:  DyDx [ Fri May 19, 2006 11:14 am ]
Post subject: 

Still had no luck, and I will have to wait until early July to try again -- don't have access to my desktop until then.

Thanks for all of the help so far.

Author:  mjl [ Fri May 19, 2006 7:25 pm ]
Post subject: 

Hi DyDx,

There is something that is being overlooked along the way.. Since you won't have "hands on" for a few days, make a check list of all the suggestions and ideas.. then when you have the oppertunity, double check the machine settings, cables, extra cards, everything & anything - do a memtest to be safe.

Alternate plan would be to install ubuntu and see if that allows happiness as it uses grub as a loader. If so, try for a triple install, M$-hda1(first), Ubuntu -hda2, swap hda3, KM hda5 & hda6. Oh, you can use Ubunto to make the KM partions also.

Enjoy the two weeks away :)

Author:  walle76 [ Tue May 23, 2006 6:08 am ]
Post subject:  Yes there is a lilo/boot problem with R5C7

Yesterday I did the long overdue myth install of R5C7.
My previous install was somewhere in the R3 or R4's. But I also bumped into the no booting after installation problem. I also first thought hmmm I got a bigger hd now 300 gig maybe that's the problem.

Turns out, just do a rescue boot, mount and chroot to the correct hd and do a
nano /etc/lilo.conf

In mine there was on the second line something containing
'part ...' which gives an error when you run lilo. Comment this line out (it seems it is actually something which is supposed to be in comments). And rerun lilo. The MBR is now installed and it booted fine, no probs.

Also the installation for belgian tv guides has been greatly improved and I enjoyed the new 'burn tv shows to dvd' feature. Thanks guys, keep up the great work but yes I do think there will be a R5D7 or R5C8 comming out soon with the lilo.conf problem patched...

Author:  mjl [ Tue May 23, 2006 6:36 am ]
Post subject: 


As a tip, if you are recycling an old windows drive, make a boot floppy with fdisk on it. Boot up the floppy, run fdisk /mbr before your install. Otherwise, KM will think there is a windows system and seems to make that part:.. addition to the lilo.conf.

Happy to hear you are running :)

Author:  Maresian [ Sat Jun 03, 2006 4:39 pm ]
Post subject: 

Well, I had the same problem, and it was resolved as soon as I did a fdisk /mbr. I got the same error, and I did have to play around with the jumper settings a bit too.

I had it as slave on the primary channel, which I think is hdb, but Knoppix saw it as hda, which I think was causing a problem too(not sure about this, not very knowledgeable about linux and such)

It did resolve the lilo issue though... Watching it boot up now. :D

Author:  bill_01_01 [ Tue Jun 06, 2006 8:54 am ]
Post subject:  suggestions from this topic and a couple others helped

I did an autoinstall of R5C7 and had the same problem with an invalid lilo.conf file. The suggestion to comment out the second line beginning with 'part' and rerunning lilo solved my problem.

My disk configuration consists of hda where I wished to install KnoppMyth and hdd, an old disk on which I had some version of windows, probably Windows 2000.

Thanks and cheers!
Bill Lin

Author:  unkyjoe [ Fri Jun 09, 2006 11:43 am ]
Post subject: 

For what it is worth I ran into this same problem using an ASUS A7N8X MB, I got around it by making sure my SATA drives were unplugged from the MB.

I installed to an IDE drive, rebooted, shutdown, hooked back up the SATA drives and then booted back up. It runs fine after that.

Hope this helps some of you.

Author:  duplexemotions [ Mon Jun 12, 2006 7:01 pm ]
Post subject: 

I had this exact problem on the following hardware:

MSI K8N SLI-F motherboard
Athlon 64 3700 sandiego
1GB Mushkin Level 2 PC3500 @ 2-3-3-6
Western Digital 120GB hard drive (8mb buffer) <--Knoppmyth
Western Digital 120GM hard drive (2mb buffer) <--WinXP
eVGA GeForce 7600GT video card
Audigy sound card
MSI TV@nywhere Master tv tuner

The problem was easily fixed by editing lilo.conf (removing the "part" line at the top) and remembering (after two tries) to actually run lilo afterwards.

Author:  KlickSuperfly [ Tue Jun 20, 2006 11:09 pm ]
Post subject:  Still no luck here...

Hello everyone,

Great thread: I've followed along and tried to do what was suggested but I'm still getting one of the following three results:

1. No response - System POSTS and then sits there after displaying CMOS info
2. Message "Invalid Operating System" right after CMOS display
3. Message "partition signature !=55AA" (new this evening after yet another fdisk /mbr)

I'm kind of a Linux newbie so I muddled my way through booting up the KnoppMyth CD and using it to mount and chroot my hda1 (allowing me to comment out the "part..." line). Tried booting: no good.

Booted up using one of my favourite rescue CDs that has a DOS option. Tried fdisk /mbr, rebooted: no good.

As I said, I'm a newbie but I've been reading my docs and trying my damnedest to figure this out. I'm probably just missing one small piece of the pie...

My system:
Dual P3 1000MHz
Matrox Millenium P750 "triple head" video card
Firewire Card
USB 2.0 Card
Linksys Wireless NIC
Linksys Gigabit NIC
Soundblaster Live! Platinum
(no TV card yet - going with a Hauppauge 350 or similar satellite card)

unkyjoe: What do you mean by
...and remembering (after two tries) to actually run lilo afterwards.

Any help or suggestions would be greatly appreciated. :wink:

Author:  mjl [ Wed Jun 21, 2006 6:48 am ]
Post subject: 

Hi KlickSuperfly,

If you aren't up and running then we have missed something along the way. Starting from step two (step 1 being turn on computer), Did you do a manual install, auto install? Check the hard drive jumpers to be on master and ide1 connector? Just go through and double check.

When you ran the partition setup, did you make the root partition bootable?

I have had maybe 1 or 2 drives over the past year that were really stupid and mixed up. Had M$ something on it and would not boot anything. Solution for me was to use a dos floppy and run the fdisk /mbr then I ran fdisk deleting everything it could. Created a large partition (2 gig was limit :), made it bootable.

Auto installed KM without problems on the reboot.

The dos bootable floppy with a couple of basic tools may become a collectors item. I always keep one handy in the quiver with fdisk, sys, & format loaded at least. Also a simple terminal program as Procomm or simular has come in handy.

I think 2 gig may be a little over kill on the memory, at least for a normal basic KM box. I find no issues with 256 ~ 512meg not that it will cause harm, just an observation.

Have a great day!

Author:  KlickSuperfly [ Wed Jun 21, 2006 8:11 am ]
Post subject:  More to go on

Hi Mike,

Thanks for the reply. I've checked and checked again on the IDE setup and I just realized that I missed the HDD area of my system details:

2x Maxtor 7200 RPM 160 GB (not RAID, just standard IDE)

My installation went like this: I burnt the latest iso to CD with a different machine, placed it in the drive and booted the system. When the first prompt comes up I simply pressed enter and moved on to the KM install where I chose the auto install option. I then set the timezone details, entered my username, password, and root password, and left the rest of the details on default. I didn't see options to make the drive bootable.

One concern I have is that the drives may have had the Maxtor bootloader installed on them at one point to make XP boot. Since the mobo is PIII vintage I can't recall if it will recognize the 160GB drives, however when I view the partitions using Partition Magic I see that the partitions have been properly allocated (3 partitions; KM, swap, and storage I believe -forgive me if I'm wrong, I'm going from memory).

To further simplify the troubleshooting, I've removed the cable from the slave drive. Both drives were connected (primary/slave) to IDE0 on the motherboard. This system used to be used for graphic design and had Windows XP on it so that explains the high amount of RAM (then I discovered Mac OS X for design work).

Thanks again,

Author:  electrohacker [ Wed Jun 21, 2006 9:02 am ]
Post subject: 

mine said some BS about operating system errors and would load knoppmyth but had all sorts of issues. oddly enough it was reporting a CPU speed of 1005 when it was only a 950 duron (can easily do 1266, but 1005 isnt even mathematically sound)

I had to reset the bios to failsafe and then edit it to have correct time boot order and turn on built on devices.

FIXED IT EASILY... :twisted:

just to add to the topic :wink:

Author:  KlickSuperfly [ Wed Jun 21, 2006 12:26 pm ]
Post subject:  Next step

Yeah, my next step (if someone doesn't have a better idea) was to strip the system down to bare bones, reset the BIOS to defaults, and try reinstalling once again.

It seems to me that the problem doesn't lie within the other peripherials... this seems like I'm missing some small thing relating to booting the OS partition on the hard drive.

Page 2 of 3 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group