LinHES Forums

does not even get to bootloader
Page 3 of 3

Author:  mjl [ Wed Jun 21, 2006 4:25 pm ]
Post subject: 


Boot up with the cd or a dos fdisk floppy. If you use the cd, I think you can quit and get to a prompt. Run cfdisk and you be able to see if hda1 is set to be bootable.

A dsl would even work to give you cfdisk.. Very handy tool.


Author:  KlickSuperfly [ Wed Jun 21, 2006 10:51 pm ]
Post subject: 

I checked the MBR with cfdisk and there it was: no boot flag! I set the flag, wrote the flag (cfdisk told me that the write was successful, however it couldn't read the information stored in the partition tables), and rebooted: the system stuck in the same place after displaying all of the CMOS information.

I did, however, notice something while banging my head on my workbench... CMOS is showing my drive as "Pri. Master Disk: 8455MB, UDMA 5" when in fact it is a 160GB drive... This lead me to believe that I must have installed MaxBlast to make my big drives work with an older system. (If I had a smaller drive around here I would gladly try installing KM on it to test that theory but I think that I let my son take apart all the old drives.)

To make this long story longer than it already is, I grabbed a copy of a Maxtor utility and ran the diagnostics on the primary master. All tests passed except the Partition Information test: ABSENT. This ties back to cfdisk telling me that it couldn't read the partition tables after I tried to write the boot flag.

Now I'm really stumped. Out of desperation I've decided to run Maxtor's full diagnostic suite (which include a low-level format). I'll look at this poor, cursed box again tomorrow with some fresh eyes.

Thanks for the help Mike (and everyone else reading along). It's good to know that there are some people out there that aren't too good to help Linux newbies like myself with issues like this.

Author:  mjl [ Wed Jun 21, 2006 11:04 pm ]
Post subject: 

Hi KlickSuperfly,

The MaxBlaster can throw a curve to the picture every time. Very difficult to remove if I recall correctly. The MaxBlaster has a tool to undo the "magic" loader? I am not sure if the old dos fdisk will restore things.

Anyway, sounds like the path may have a few bumps but passible.

Keep us posted for future reference.

Author:  KlickSuperfly [ Thu Jun 22, 2006 10:31 pm ]
Post subject:  Success

Up and running.

Yes, after many hours of messing around I gave in and walked through a manual install where I selected that lilo be loaded to the MBR and.... JOY.

I'm sure that killing off Maxblast was part of it because I tried it before and had no luck. I'm up and running and in need of that Hauppage 350 and a decent video card... but that's another fourm topic.

Thanks Mike for your patience and assistance.

Author:  mjl [ Thu Jun 22, 2006 11:01 pm ]
Post subject: 

Hi KlickSuperfly,

Nice to hear good news :) If you are planning to get a 350 card and use it to do tv out, then I am not sure if there are benifits to a fancy video card.

Also, a heads up when you do the 350 card, don't select bootsplash unless you are ready to edit the /etc/X11/XF86Config-4 file.

Enjoy the fruits of your work!

Author:  electrohacker [ Fri Jun 23, 2006 6:05 am ]
Post subject: 

yes, boot splash bad.

Author:  smope [ Tue Jul 18, 2006 1:23 am ]
Post subject: 

i had this same problem.

first drive WD 250gb. Nothing listed here fixed it.
Maybe it was an old xbox drive?
It did have the no boot flag set issue.

switched to another drive. still the same no boot flag on hda1 issue. set boot flag, no more problems.

Author:  rattyrat [ Fri Jul 21, 2006 2:48 am ]
Post subject: 

OK, there are several 'here`s what I did to fix this' replies, I`ll add mine while it is still fresh.

Initially I did an auto install to hda.
HINT: I strongly recommend you set up your system as follows, if possible:-
1 Hard Drive + 1 CD ROM only
Hard Drive is Master on primary channel ON END CABLE CONNECTOR
CD ROM is Slave on Primary Channel ON MIDDLE CABLE CONNECTOR

Install went OK but after re-boot it stopped before booting.
Here are the steps I used to fix the problem:
1) Re-booted with the install CD, went to Manual install just as far as the 'Partition' option - noticed hda1 (/root) was not set to bootable, corrected this and re-wrote the partition table, REBOOT.(still no joy)
2) Botted the install CD again, this time did ALT-CTRL-F2 at the menu and Followed mjl`s instructions for re-installing lilo:
# mount -o rw,dev /dev/hda1
# chroot /mnt/hda1
# lilo -v

, this gave errors.
3) Edited /etc/lilo.conf:
vi /etc/lilo.conf

and removed all lines referring to other drives (I have a raid setup for my whine-doze, so there were several sda/sdb references). Saved the file
4) Followed mjl`s instructions again, no errors this time.
5) Re-booted and - OH JOY - It Works! :D

I hope this helps anyone else who is getting this problem.


Author:  rogo [ Mon Aug 14, 2006 10:45 pm ]
Post subject: 

Hi mjl,

Mike, thanks for your assistance, was having the same problem getting my install to boot properly. followed your steps from a much earlier post,

# mount -o rw,dev /dev/hda1
# chroot /mnt/hda1
# lilo -v

and am now happily configuring my new knoppmyth system. still got a long way to go but with the help of this forum will get there.


Author:  mjl [ Mon Aug 14, 2006 11:05 pm ]
Post subject: 


Good to hear you are on a roll! Go careful and enjoy as it is an awesome package with a lot to learn about howto make it roll over and do tricks for you :)


Page 3 of 3 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group