View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 9 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Jun 03, 2006 3:47 am 
Offline
Joined: Sat Jun 03, 2006 1:34 am
Posts: 4
Caveat: I have never used linux before. I have searched the forums and read the wiki. Sorry if this is a repeat.

I'm trying to install Knoppmyth on a system. Aside from some initial problems with having to manually set which partition to boot from, the installation seems to work ok until the system starts X for the first time.

The nvidia splash screen is displayed and it is VERY DARK. So is the rest of X. To be more precise, the colors are not only very dark but they also looked distorted. My LCD monitor's auto-adjust says it can't adjust it at all. If I alt+ctrl+F1 to get a terminal, this is also very dark. When I try to install nvidia driver 7174 using the shell script, it says it's already installed. Is there some way I can get my screen working properly before my eyes fall out from strain?

Do I need to edit xorg.conf? If so, is there some way that I could make it more visible to do so?

System Info:
Sharp 17" LCD (nvidia-settings says CRT0 for display devices...is this right?)
Gigabyte Geforce 6200
ECS N2U400A mobo
Hauppauge PVR 250
Airstar HD5000

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 4:13 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
I don't use an LCD screen, so I'm working in the dark a bit here too!!!!
But I am almost certain that your XF86Config-4 file should reflect you are using a LCD screen and not be recognised as a CRT.

If you have a look within the X11 folder, along with the current XF86Config-4 file there are a number of examplar XF86Config-4 files, one of which (if memory serves) is for LCD screens. So you will need to change your current XF86Config-4 to that one or take the relevent bits and transpose them to you current one and restart the GDM.

I guess you have read about the dark colour problems with GeForce 6200 and above cards. I use a 5200 so again no experience of this. I'll leave that to people with far more experience to comment on that.

Can't be more help I'm afraid. Good luck


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 12:31 pm 
Offline
Joined: Sat Jun 03, 2006 1:34 am
Posts: 4
There are a number of XF86Conf-4 files, but none of them appears to talk about LCD panels. There's one for pvr350 output, one for epia, and one for nvidia tv-out.

Under the monitor section in XF86Conf-4, I have tried chanring the VertRefresh to 60, but on next boot the screen is still dark/barely readable. BTW, this is KnoppmythR5C7. Is another version more stable?

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 1:10 pm 
Offline
Joined: Sat Jun 03, 2006 1:34 am
Posts: 4
Regarding this topic: http://mysettopbox.tv/phpBB2/viewtopic.php?t=10339

my card only has a dvi out, and I'm using an analog monitor with the dvi-vga adapter that came with the card. Is this problematic?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 7:57 pm 
Offline
Joined: Sun Jun 12, 2005 10:55 pm
Posts: 3161
Location: Warwick, RI
Hi,
I too have a very dark screen on my lcd monitor however it is because one of the lamps is dead. (but it is only on the left side :)

Anyway, have you tried using a crt monitor to see if there is a simular result with the dark display? If you have access to a different nvidia card, try that also.. it could be defective.

A very good tool for doing simple equipment testing is a live cd from ubuntu.com, latest release is just fresh out also. Just burn it & boot it for test and check.

Mike


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 04, 2006 7:13 pm 
Offline
Joined: Sat Jun 03, 2006 1:34 am
Posts: 4
Just before installing Knoppmyth I had installed Windows XP. It went without a hitch, full wonderful graphics at 1280x1024, 24 bit colors. Also, the installation works with full brightness until X starts. I do not have access to a CRT to try it.

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 04, 2006 7:59 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
There's a recently posted work around for using a 6200 based card with an analog connection to the display and getting a very dark display. I added it to the bottom of the http://www.knoppmythwiki.org/index.php?page=BlackScreenAfterInstall page on the wiki. Here is the original post - http://mysettopbox.tv/phpBB2/viewtopic.php?p=60434

If you have the hardware mentioned this would let you keep using the 7174 release of the nvidia drivers. Otherwise your best bet is probably to upgrade to one of the 8xxx series drivers. There are also some recent posts about how to do that, it's actually quite painless if you make sure the kernel source has been unpacked first.


Last edited by tjc on Sun Jun 04, 2006 8:19 pm, edited 2 times in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 04, 2006 8:10 pm 
Offline
Joined: Sun Jun 12, 2005 10:55 pm
Posts: 3161
Location: Warwick, RI
Hi rgann,

If tjc's pointer doesn't help, you could try the generic "vesa" as a driver for the xserver. It isn't as good but may at least help get things setup and running while you are doing further research for the proper driver.

Mike


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 07, 2006 12:01 pm 
Offline
Joined: Sat May 20, 2006 5:09 pm
Posts: 43
Location: Spokane, WA
I just wanted to say thank you for this fix- I've spent many hours searching, before finally finding this post. Can't wait to get home to try it now.

I'm running a new 6200 board on analog out, and get a hard freze when X starts after install. My previous installs on on other hardware had the issue with a dark screen, but the Wiki gave me answers to both issues.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu