View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Dec 25, 2006 6:53 pm 
Joined: Tue Apr 12, 2005 7:29 am
Posts: 41
Location: Goettingen, Germany
Hi all.

I tried installing the newest version to a Raid5 array attached to a Promise SX4060 controller. The array (3x400GB) is set up (not formated yet), but the installation can't find the disk. I think there might be a driver missing to access the controller, but I only found drivers for RH8/9 and SUSE8/9. When I try to load a driver (FastTrak.o) with insmod it tells me "invalid module format"...
When I looked around forums and faqs I came across 'dmraid' and the 'sata_sx4' driver, but I couldn't find information about support for the SX4060 and couldn't find find libata with apt to download it...
There is in fact a source driver for the TX4000 and S150 TX4 existing at the promise website. Those are SATA controller, I know...

What can I do except reverting to using the onboard controller?

EDIT: I can set up the the array with fdisk from a DOS bootdisk (at least ~512GB of it, FDISK can't see more than this...) but linux (e.g. cfdisk) won't find it...

I'm sorry if I'm acting noobie here. In fact I am :-/
And: YES, I've read the pamphlet and related stuff...

Hints welcome


 Post subject:
PostPosted: Fri Jan 05, 2007 11:20 pm 
Joined: Thu Dec 29, 2005 1:45 am
Posts: 7
I have been having problems with drivers too.
I have looking at ane using several linux systems that run from cd.
The one that will help is Gentoo 2006, In the boot options is nodmraid which means dmraid is on by defalt
I have used dmraid on a nforce2 board (Silicon Image Medley) (debian testing) and it works but the are no advantages over linux's software raid, both use the cpu to do the work. Unless you have a dual boot with windows on the aray. (Windows must be installed first!)

look here

The following ATARAID types are supported:

Adaptec HostRAID ASR
Highpoint HPT37X
Highpoint HPT45X
Intel Software RAID
JMicron JMB36x
LSI Logic MegaRAID
NVidia NForce
Promise FastTrack
Silicon Image Medley
VIA Software RAID

This is were I started and I know there has been serval updaates, and it says ata but I was runing sata raid0.

 Post subject:
PostPosted: Sat Jan 06, 2007 4:56 am 
Joined: Tue Apr 12, 2005 7:29 am
Posts: 41
Location: Goettingen, Germany
Thanks for the answer. I tried dmraid too but wasn't successful with that...
There are in fact some drivers flaoting around for this thing and the 2.6 kernel, but they're beta an use precompiled libraries. The SX4060 something in between hardware and software-raid, as it takes some work off the CPU (e.g. XOR for Raid5). The beta driver can be found here
I have yet to check if it works for me. The support from promise was good for the 2.4 kernels, that was why I bought this thing cheap on ebay...

And offtopic: I dreamt last night I had everything working, really :) That was for sure strange...


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu