View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Mar 01, 2008 12:38 am 
Joined: Sun Sep 25, 2005 3:50 pm
Posts: 1013
Location: Los Angeles
This is a continuation of a discussion started here. Instructions were also posted to the KnoppMyth Wiki.

I had the chance to try this method out on a spare hard drive this evening. Although I was able to install KM using the instructions provided on the wiki, there were some issues.

First, let me say I was trying to install to a frontend only machine. No tuner cards were installed. I did not test MythTV functionality, only the install process. Here's what I found:

I plugged in the USB drive and powerd on the machine. In my motherboard's BIOS (Abit AN-M2HD) I selected USB-ZIP/LS as my boot device (my other options were USB-FDD or USB-CDROM. USB-FDD failed, did not test USB-CDROM).

KnoppMyth installer boot prompt came up (quite fast, I might add). At the boot prompt I entered
 boot:  knoppmyth testcd

Things seemed to carry on normally until it tried to test the cd files. The files to check were not found because the test program was looking for them under boot/isolinux, but we had changed that to boot/syslinux earlier.

The install seemed to go normally. A bit faster than the CD-ROM-based install, but I was not timing it, so that was merely my perception.

Before the 1st reboot and "ejection" of the CD, quite a few errors broke through the blue screen, but they were much too fast for me to catch any of it. I selected OK to reboot.

After the 1st reboot the liloboot menu appeared (to my surprise) with a 15 second timeout. the choices were:

I let it timeout and it booted Linux as expected.

As it continued to boot there were some problems:
udev requires mounted procfs, not started...failed!
setting kernel variables...failed!
...mount point /proc/bus/usb does not exist failed!
starting hardware abstraction layer failed, /sysfs not mounted.

I plugged another usb stick into the computer and nothing happened to confirm there was a problem.
# ls /proc/bus
input pci

On to configuration...

aplay: devicelist_205: no soundcard found
was repeated 3 or 4 times. I think this is specific to my hardware, not the USB stick install, but I thought I'd mention it.

My StreamZap was not detected by the lirc scripts due to the usb issues I mentioned.

Everything else seemed to be fine. We'll need a lot more testing on this. If you have time, please post your experiences and please detail any fixes or changes you made to get something to work.

My Hardware Profile

PostPosted: Sat Mar 01, 2008 11:32 am 
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Yeah, these are the same issues that came up with the "drunk monkey" instructions for doing this that I was working on last weekend and published privately. I should probably make them available despite the known issues as they're more detailed than the ones that alien posted. Since I don't have time to reformat them for the wiki right now I'll repost them here. My ultimate goal was to reduce these to a completely automated script, that you would feed the location of the ISO and the device name, and have it do all the work. (OBTW - The boot and install from a USB stick _is_ substantially faster as you noted.)

Please note that these instructions show the same issues described above.


I had to do parts of this on my Fedora WS for some reason. The KM box didn't seem to produce a working USB image. It would boot to point, but then it dropped me to a limited shell. I'm still trying to sort out the details. Possibly failure to sync the first couple attempts or different versions of some utility... I've also still got an issue with the checksums. The files on the key are OK, but despite my tweaking it doesn't seem to find all of them...

0) Make sure you have mtools installed. All the usual apt-get safety caveats apply. Be ready to say NO if it wants to replace a bunch of stuff or drag along dependencies.
apt-get update
apt-get install mtools

1) Insert the USB drive and determine it's device name.
dmesg | tail -20

2) Set these variables appropriately

3) Format the USB drive
cfdisk ${USB_DEVICE}
 d - Delete
 n - New
  p - Primary
  (accept the size)
 b - Bootable
 t - Type
  6 - FAT16
 W - Write
 q - Quit

mkdosfs ${USB_DEVICE}1

lilo -M ${USB_DEVICE}

When you're done the partiton table should look something like this:
root@black2:~# cfdisk -Ps ${USB_DEVICE}
Partition Table for /dev/sdb

               First       Last
 # Type       Sector      Sector   Offset    Length   Filesystem Type (ID) Flag
-- ------- ----------- ----------- ------ ----------- -------------------- ----
 1 Primary           0     2001887     63     2001888 FAT16 (06)           Boot

4) Create a modified version of the KM ISO image
mkdir km_iso km_mod km_usb

mount -o loop $KM_ISO_LOCATION km_iso

# On Fedora i had to use: cp -dpPR km_iso/* km_mod
# Frelling selinux is a real PITA sometimes.
cp -a km_iso/* km_mod

umount km_iso

cd km_mod

mv boot/isolinux/* ./
rm -rf ./boot

mv isolinux.bin syslinux.bin
mv isolinux.cfg syslinux.cfg

chmod +w ./KNOPPIX/md5sums

sed -e 's@boot/isolinux@@' \
    -e 's@isolinux.bin@syslinux.bin@' \
    -e 's@isolinux.cfg@syslinux.cfg@' \
    --in-place ./KNOPPIX/md5sums

chmod -w ./KNOPPIX/md5sums

cd ..

5) Copy that onto the USB drive and finalize the setup
mount -t vfat ${USB_DEVICE}1 km_usb

cp -a km_mod/* km_usb


umount km_usb

syslinux ${USB_DEVICE}1

sync;sync  # Give it some time to settle too :-/ ...

6) Boot with it. You usually need to add USB HDD to your BIOS boot list.

 Post subject:
PostPosted: Sat Apr 05, 2008 2:28 am 
Joined: Mon Jun 21, 2004 5:28 am
Posts: 700
Location: Germany
I've tried this on two different ISOs now and neither worked.

Both seemed to install fine, but after selecting the remote during the setup questions, it would lock the computer when starting lircd. I tried by-passing this step, but it would also lockup somewhere later.

Since this happened both times the same way and it happened during the config after the install (which went smoothly), I suspect it is a problem with the moved files. testcd showed no errors. Installing from the CD worked fine.

I moved /boot/isolinux to /boot/syslinux. Both isolinux and syslinux will work from /boot. I suspect it might help things if the original iso had everything in /boot instead of /boot/isolinux. Then there would be no need to move files around.

ASUS AT3N7A-I (Atom 330)
TBS 8922 PCI (DVB-S2)


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu