View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Jan 30, 2010 7:11 pm 
Offline
Joined: Sun Jul 18, 2004 6:24 pm
Posts: 84
Location: Medford, Massachusetts
I upgraded from R5.5 to R6 and mistakenly choose Standalone instead of MBE. I am now trying to remedy that to restore peace in our house as my wife can no longer watch her shows from her computer.

I have (actually it has been this way for a while) configured the IP address to be 192.168.1.4 and set a security PIN.

When I try connecting from a remote frontend, it finds the backend, prompts me for the security pin, which I enter, then offers to save the databbase or backend settings (or not). Whatever I try I get the error

Code:
Cannot login to database?


I suspect it is something in the mysql setup, but under R6 I'm not sure where to find it since /etc/mysql doesn't exist.

What do I need to do to fix this and restore harmony in the home?

Thanks,
Jon

p.s. I'm loving the peformance and stability of R6 (LinHES) on my main machine/TV. I can once again watch live HD TV and HD recordings reliably.

_________________
AMD Athlon 64 3000+ on MSI K8T Neo
FX5200
pcHD3000
Firewire to Comcast cable box
PVR-250
R6


Top
 Profile  
 
 Post subject: Found my.cnf in /etc
PostPosted: Sat Jan 30, 2010 8:12 pm 
Offline
Joined: Sun Jul 18, 2004 6:24 pm
Posts: 84
Location: Medford, Massachusetts
I commented out the skip-networking line in the /etc/my.cnf file and rebooted, since I couldn't figure out how to restart mysql since /etc/init.d/mysql restart doesn't work on R6.

_________________
AMD Athlon 64 3000+ on MSI K8T Neo
FX5200
pcHD3000
Firewire to Comcast cable box
PVR-250
R6


Top
 Profile  
 
 Post subject: Re: Found my.cnf in /etc
PostPosted: Sun Jan 31, 2010 4:35 am 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
jmhunt wrote:
I couldn't figure out how to restart mysql since /etc/init.d/mysql restart doesn't work on R6.


As root:

Code:
sv restart mysql


Regarding the problem, I added a remote frontend later on. What you need to do is to enable login as mysql user remotely. At the moment the entry (first few columns anyway) in the DB mysql -> user for mysql is:
Quote:
| localhost | mythtv | *CC8F35F587CA5A556B4132C2407E556D92172FFC


Now, what you should do here is to change localhost here to your FE host (either IP or hostname in /etc/hosts or nameserver). If this fails you can use '%' as the hostname (a wild card), thusly:

Code:
echo 'UPDATE user SET Host="%" WHERE Host="localhost" and User="mysql"'|mysql -u root mysql


Test the connection on the FE machine by manually attempting to connect to the BE's mythconverg db via the mysql client.

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu