View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Jul 10, 2005 9:15 am 
Offline
Joined: Sat Jul 02, 2005 10:13 am
Posts: 11
I have been able to auto-install, but had to keep doing it until the system finally installed LILO properly, and then everything seemed to work.

Then I tried a manual install, still keeping knoppmyth on hda1. Again, I had issues with LILO, but by searching the forum I found some lines to remove from /etc/lilo.conf and it worked.

I'm a linux newb, so I was both practicing and making sure the system worked at least with a "traditional" setup before complicating things. Of course, I have to complicate things!

Here is my partition setup:
hda1 primary NTFS
hda2 primary knoppmyth
hda5 logical swap
hda6 logical cache
hda7 logical myth

Now, I could be wrong, but the I somehow have a feeling that knoppmyth only likes being on hda1, and that is somehow related to my troubles.

Anyway, I installed knoppmyth using the manual install, everything seems fine.

I go to boot from the hard drive, and I get:
Error loading operating system

No bootloader. I had this same error previously, and so I boot from the CD, exit to command prompt, and put in:
mount /dev/hda1 /mnt/hda1
chroot /mnt/hda1
nano /etc/lilo.conf

Made necessary changes to LILO, save them, then lilo -v, reboot, and it worked.

Only THIS time... I'm on hda2. So I enter:
mount /dev/hda2 /mnt/hda2
chroot /mnt/hda2
nano /ect/lilo.conf

Only lilo.conf is empty! Lilo -v generates this error:
/etc/lilo.conf: no such file or directory

So I figure LILO isn't being installed. I try to install it myself:
apt-get install lilo
and I'm told I already have the latest version. Searched around the web, and decided to try liloconfig.
At this point, I get a lengthy reply, but here is what I think is most relevant:
Either your /etc/fstab configuration file is missing, or it doesn't contain a valid entry for the root filesystem!

I'm in over my head on that! I don't even know what fstab is (stop laughing).


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 10, 2005 11:11 am 
Offline
Joined: Sat Jul 02, 2005 10:13 am
Posts: 11
I tried re-ordering some things and it still didn't work:

hda2 primary NTFS
hda1 primary linux
hda5 logical swap
hda6 logical cache
hda7 logical myth

Nothing too fancy here... just a bit of partition juggling to make the second one show up as hda1... Create a partition (hda1), then a very small partition (hda2). Now delete hda1. Create a new hda1 AFTER hda2. Now you can delete hda2, and recreate it to take up all the space before hda1.

Same problem as noted above... No lilo, and running liloconfig tells me something is wrong with /etc/fstub

I tried to run nano on /etc/fstub but it was empty.

I know that with Windows, installing beyond the first partition requires a FAT partition in front (at least a small one). Could something similar be holding me back here?

You probably can see that I'm trying to dual boot here. I have installed windows and knoppmyth on this system probably 20 times now. Time, time, time... What's a bit more?

I'll try installing Windows 2000 on a FAT32 partition, then ANOTHER manual install of knoppmyth.

Also, I've been attempting to install LILO to the MBR. Isn't this right? The other option is to the root partition. Would that help?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 10, 2005 4:51 pm 
Offline
Joined: Sat Jul 02, 2005 10:13 am
Posts: 11
Unreal...

I have no idea what I did to make it work. I just kept running the manual install, then trying to edit the lilo.conf file.

If it was not there, I just installed again.

Eventually, it WAS there. I was able to comment out the first couple of lines and upon rebooting was greeted with the LILO boot screen.

I am dual booting. Yay. I think it's very frustrating mostly because I didn't really *do* anything to fix it... Just install, install, install...

I did the manual install of knoppmyth 5-7 times today, and it finally just worked.

For anyone with similar goals, note:
1. My first partition is seen as hda2, thanks to the "juggling" I outlined above.
2. Knoppmyth is installed on hda1.
3. hda2 is a FAT32 partition. I don't know why it should matter, but I couldn't make it work with NTFS.
4. Doesn't seem to matter if you install Windows before or after knoppmyth. If you install it after, it will make the windows partition active (bootable), and you must use a partition utility (such as Ranish partition manager, or the one included with knoppmyth that you can access via the manual install script) to make the linux partition active again.
5. Boot off the knoppmyth CD, and exit the menu as soon as it loads.
mount /dev/hda1 /mnt/hda1
chroot /mnt/hda1
(this brings up a different looking command prompt)
nano /etc/lilo.conf

If it's empty, try re-installing knoppmyth (I swear I did it 5-7 times before it worked). If it's not empty, you'll see two lines near the top, something like:
VGA: <some number>
PART: blah blah blah
Just put a # in front of those two lines (which means the system will ignore them), hit control-o to save, and then control x to exit nano.

The next command is:
lilo -v
I think this makes the changes in /etc/lilo.conf take effect.

type exit again to go back to the original command prompt, then put in:
shutdown -r now
to reboot....

6. Enjoy.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 11, 2006 11:37 pm 
Offline
Joined: Thu May 11, 2006 11:14 pm
Posts: 10
I'm having the same basic problem.

I have KnoppMyth installed on /dev/hda2. Lilo did not configure correctly (or at all) so I loaded from the CD, as you did, and made sure that /dev/hda2 was mounting as the root file system (/) in fstab (which is actually located in /mnt/hda2/etc/ when booting from the CD). I then ran liloconfig but it gives me some error about the system being read only:

"Fatal: creat /boot/map~"... plus a bit more that I think is relatively unimportant.

The reason for this is easy to see: liloconfig is trying to create a file in a read-only directory when I actually want the file created in /mnt/hda2/boot, whic his not read-only.

I checked and the fstab and lilo.conf all makes sense to me, and everything that I would think needs to be in /boot appears to be there.

I am pretty sure I am just missing one or two things but I can't determine what yet.

Can anyone offer some advice?


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 12, 2006 7:24 pm 
Offline
Joined: Sun Jun 12, 2005 10:55 pm
Posts: 3161
Location: Warwick, RI
Hi scarceas,

There is considerable help available here on the forum, to narrow the results a little, search for stuff by author tjc, Xsecrets, myself (and many others) for some tips and also follow some of the threads. You will get the hang of it.

As a new person, starting off for a dual boot adds a level of complexity. Fortunetly you are using ide as sata adds a bigger lump in the road.

I can boot to 5 different situations so it can be done and I am far from being anywhere close to the upper levels of skill in Linux. Above the 2 nd boot, I have to use grub as a loader.

Basic rules:
You can only have 4 primary partitions
You can have 3 primary and several logical partitions
NTFS file system is not supported very well in Linux, so read only.
Recommendation:
You should have a fairly large drive, suggest 80 gig or > (40 gig min)
Should have 400mhz or > and 256 ~ 386 meg mem (analog tv)
and (again famous last words) it should work

Others may not agree, that's ok but here is what I would do.
hda1 Make your windows partition ~ 5-6 gig
hda2 Make a ~2 gig partition, format it for fat32 (common storage point between windows & KnoppMyth)
hda3 512 meg swap
hda5 logical ~5 gig for / KnoppMyth
hda6 logical remainder for /myth storage

You should be able to repartition the windows without having to reinstall, turn off virtual mem and then defrag before partitioning.
after the partitoning boot back into windows and format d: as fat32
manually install myth R5B7, in the partition menu setup as suggested earlier and be sure to mark the types. install KM onto hda5. When done it will drop you back to a prompt. Here is where & when you fix lilo so you can boot.
#mount -o rw,dev /dev/hda5
#chroot /mnt/hda5
#cd /etc
#nano lilo.conf
remove or use # to block the line(s) that say #part: /dev/hda1, typ: 12
scroll down and check for root=/dev/hda5
scroll down and change the 150 timeout=1200 (2 minutes to choose)
save and exit ctl x yes
do lilo -v and see if it is happy, if so now edit fstab
#nano fstab
check for
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
be sure you have this entry
/dev/hda3 none swap defaults 0 0

change
/dev/hda6 /mnt/hda5 ext3 noauto,users,exec 0 0
to look like this
/dev/hda6 /myth ext3 auto,users,exec 0 0

save & exit
Refer to the "pamphlet" and follow the procedure to format hda6
# mke2fs -j -O sparse_super -m0 -i8000000 -L myth -M /myth /dev/hda6
format the swap (check pamphlet to besure of the syntax)
#mkswap -a /dev/hda3
turn it on
#swapon

At this point you should be good to finish, do a couple of ctl d to log out to where you started and the enter reboot.

Here is what my fstab looks like just for reference, again not saying this is ideal, just works.
# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/sda1 /stick vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/sda1 /e-root ext3 auto,users,exec 0 0
/dev/sda4 /e-myth ext3 auto,users,exec 0 0
# Added by KNOPPIX
/dev/hda1 /windows vfat noauto,users,exec,umask=000 0 0
# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda3 /edubuntu auto noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda6 /mnt/hda6 ext3 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda7 /mnt/hda7 auto noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda8 /myth ext3 auto,users,exec 0 0
Filesystem Size Used Avail Use% Mounted on
/dev/hda5 4.6G 2.4G 2.0G 55% /
/dev/hda8 79G 70G 8.6G 90% /myth

Tip, in the future when doing a manual upgrade, the steps are different. For an upgrade, install lilo to a partition (I don't reinstall lilo mbr unless the kernel changes) and just reboot. After it reboots and before you can finish the upgrade, you will only have to fix the fstab and then mount the /myth
Mike


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu