View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Mar 18, 2006 11:24 pm 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
Aww buggers. :) I did the upgrade to R5B7 and everything went fairly smooth. I accidentally chose the wrong IP and subnet during the setup, but mythfrontend came up ok anyway. I went into /etc/network/interfaces and made the change to the correct the IP info, I then changed /etc/mythtv/mysql.txt so that DBHostName=192.168.2.11 (my internal IP), and I ran mythtv-setup and told it that 192.168.2.11 was my database location. Now (after reboot) the database isnt coming up. Running mythfilldatabase nets this error:

root@mythtv:/etc/mythtv# mythfilldatabase
2006-03-19 00:15:19.620 Using runtime prefix = /usr
2006-03-19 00:15:19.653 New DB connection, total: 1
2006-03-19 00:15:19.656 Unable to connect to database!
2006-03-19 00:15:19.656 Driver error was [1/2003]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to MySQL server on '192.168.2.11' (111)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2006-03-19 00:15:19.711 DB Error (KickDatabase):
Query was:
SELECT NULL;
No error type from QSqlError? Strange...
2006-03-19 00:15:19.764 Failed to init MythContext, exiting.


tail /var/log/mythtv/mythbackend.log gives:


2006-03-19 00:00:37.318 Using runtime prefix = /usr
2006-03-19 00:00:37.525 New DB connection, total: 1
2006-03-19 00:00:37.550 Unable to connect to database!
2006-03-19 00:00:37.553 Driver error was [1/2003]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to MySQL server on '192.168.2.11' (111)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2006-03-19 00:00:37.648 DB Error (KickDatabase):
Query was:
SELECT NULL;
No error type from QSqlError? Strange...
2006-03-19 00:00:37.702 Failed to init MythContext, exiting.


Netstat -an gives:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp6 0 0 :::22 :::* LISTEN
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 192.168.2.11:123 0.0.0.0:*
udp 0 0 127.0.0.1:123 0.0.0.0:*
udp 0 0 0.0.0.0:123 0.0.0.0:*


Mysql is running as I can issue a "mysql" then issue "use mythconverge". But thats about it.


Help! :D

EtherNut


Last edited by ethernut on Sun Mar 19, 2006 1:54 am, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 19, 2006 1:52 am 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
Ok, I feel like a moron. Problem Solved..

I had to comment out the "skip-networking" line in /etc/mysql/my.cnf

Duh :lol:


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu