View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 10 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Sep 27, 2007 12:56 am 
Offline
Joined: Sun Jun 13, 2004 5:51 am
Posts: 15
I have used Mythtv with this exact video card for 4-years. It always worked fine with
the TV out on this card. I only wanted to upgrade my Mythtv because I need the cable
listing data that is now only available from Schedules Direct. The older version of Mythtv
that I was using 0.18 was working great until Zap2It quit distributing the cable data for
free.

I selected KnoppMyth because I thought it would be a quick way to get the new Mythtv
which would allow me to regain access to cable listing data through my new account at
Schedules Direct. That was the plan.

My video card is an Nvidia GeForce-4 MX-440-AGP-8X card, a very popular video card
the lspci line looks like this:
0000:01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)

I read every reference I could find on this forum, and all over the internet on how to solve
the TV-OUT black problem, and I tried hundreds of combonations of xorg.conf file
settings.
I tried all of the versions of the nvidia drivers that are shipped with knoppmyth including
71xx 96xx the 1.0.8776, and of course the latest one the 1.0.9755 driver, and the same
problem occurs with each of them.

I really like this video card, because it has a large heatsink and requires no fan.
Inside of a mythtv box which runs continuously for years at a time the video cards with
fans are not much good. If the fan on a video card gets too slow or stops then the
video card burns up with no warning. If a cpu fan quits, the cpu temperature safety
system will halt the computer, and you can fix the fan with no costly burnouts.
I can get a newer nvidia card (GeForce FX 5500) to work with tv out and the default
drivers, but this card has a pesky fan and I really want the card that was working before
to work again so I don't have to replace the card in 6-months when the fan burns it out.
Has anyone found a way to get the tv-out working on an nvidia driver since the
Debian ETCH release broke the compatibility with the nvidia installer .run system?

Ever since linux kernel 2.6.16 in the etch (not sarge backkernel) source tree there
has been an incompatibility between the nvidia installer .run programs and the
kernel source headers. When you try to compile an nvidia kernel module you get
an error message that says error: structure has no member named `rlim'.

Apparently when ETCH was made they reconfigured the kernel scheduler and
consolidated one sructure into another so that the rlim element is no longer visible
from the outside of the external structure. NVIDIA wants to access this element
of the scheduler for some kind of purpose, so the kernel interface module is broken.

A few versions of the nvidia driver have been modified to handle this new design,
but whatever they did to accomodate the new kernel design, broke the TV-OUT
for my card! Becase even the so-called LEGACY drivers don't work!
Does anyone have any Ideas on how this can be fixed,

Or does anyone know of any video card that works and does not have a fan?
I need to buy 2 of them for my 2 mythtv systems!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 27, 2007 1:26 am 
Offline
Joined: Mon May 10, 2004 8:08 pm
Posts: 1891
Location: Adelaide, Australia
I cant help you, but others that can will probably want to see details from your Xorg log file in /var/log so you might as well post them now.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 27, 2007 2:12 am 
Offline
Joined: Sun Jun 12, 2005 2:39 pm
Posts: 464
Location: UK
Do you just have a tv plugged in, or do you have a tv + monitor?

I've got an nforce2 chipset motherboard with onboard geforce 4 mx and had no problem with tv out using the provided sample xorg.conf. Both the 7xxx & 8xxx drivers worked fine with it. I've also had no problems downloading and compiling the nvidia drivers from the nvidia site! (i've always found the 7174 drivers worked best with it)


Top
 Profile  
 
 Post subject: More info
PostPosted: Thu Sep 27, 2007 10:06 pm 
Offline
Joined: Sun Jun 13, 2004 5:51 am
Posts: 15
This is a copy of my Xorg.0.log file and my xorg.conf file for your consideration.
As you can see there are no significant problesm with the loading of X . the int10
error has always been there for this card even in older linux versions.
X thinks it is running just fine!

About the connected monitor. I have done it both ways. When this list was made
the tv was the only thing connected to the video card. But when the monitor is connected. I get the same result, both screens go black.

How do you paste files so they show up as a little blue clicker item?
-----------------Xorg.0.log-----------------------------------
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux proto 2.6.18-chw-13 #1 SMP PREEMPT Sat Jun 2 21:06:06 PDT 2007 i686
Build Date: 04 April 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 27 20:46:15 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "NVIDIA GeForce4MX440-8x"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) FontPath set to:
/usr/share/fonts/X11/misc:unscaled,
/usr/share/fonts/X11/75dpi:unscaled,
/usr/share/fonts/X11/100dpi:unscaled,
/usr/share/fonts/X11/Type1
(**) RgbPath set to "/usr/share/X11/rgb"
(**) ModulePath set to "/usr/lib/xorg/modules"
(**) Option "BlankTime" "0"
(**) Option "StandbyTime" "0"
(**) Option "SuspendTime" "0"
(**) Option "OffTime" "0"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 1.0
X.Org XInput driver : 0.6
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Video Driver, version 1.0
(--) using VT number 2

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3189 card 1043,807f rev 80 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b198 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:0e:0: chip 4444,0016 card 0070,4009 rev 01 class 04,00,00 hdr 00
(II) PCI: 00:10:0: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:1: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:2: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:3: chip 1106,3104 card 1043,80a1 rev 82 class 0c,03,20 hdr 00
(II) PCI: 00:11:0: chip 1106,3177 card 1043,80a1 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1043,80a1 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:5: chip 1106,3059 card 1043,80a1 rev 50 class 04,01,00 hdr 00
(II) PCI: 00:12:0: chip 1106,3065 card 1043,80a1 rev 74 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0181 card 0000,0000 rev c1 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xeff00000 - 0xf7ffffff (0x8100000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI: (0:14:0) unknown vendor (0x4444) unknown chipset (0x0016) rev 1, Mem @ 0xe8000000/26
(--) PCI:*(1:0:0) nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] rev 193, Mem @ 0xe7000000/24, 0xf0000000/27, BIOS @ 0xeffe0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xf8000000 from 0xfbffffff to 0xf7ffffff
(II) Active PCI resource ranges:
[0] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[1] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[2] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[3] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[4] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[6] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[7] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[8] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[9] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[10] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[11] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[12] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[1] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[2] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[3] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[4] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[6] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[7] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[8] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[9] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[10] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[11] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[12] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[5] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[6] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[7] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[8] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[9] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[10] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[14] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[15] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[16] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[17] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[18] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.9631
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "xtrap"
(II) Loading /usr/lib/xorg/modules/extensions/libxtrap.so
(II) Module xtrap: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DEC-XTRAP
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 7.1.1, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.9631
Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(II) NVIDIA dlloader X Driver 1.0-9631 Thu Nov 9 17:39:58 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/xorg/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 0.1.0
ABI class: X.Org Video Driver, version 1.0
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[5] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[6] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[7] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[8] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[9] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[10] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[14] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[15] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[16] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[17] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[18] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) resource ranges after probing:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[5] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[6] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[7] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[8] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[9] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[10] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[11] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[12] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[13] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[16] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[17] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[18] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[19] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[20] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[21] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[22] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[23] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "TV"
(**) NVIDIA(0): Option "TVStandard" "NTSC-M"
(**) NVIDIA(0): Option "TVOutFormat" "AUTOSELECT"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TV output format is auto selected
(**) NVIDIA(0): TV Standard string: "NTSC-M"
(**) NVIDIA(0): ConnectedMonitor string: "TV"
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 with AGP8X at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.18.20.38.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 with AGP8X at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA
(II) NVIDIA(0): Assigned Display Device: TV-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Video Driver, version 1.0
(WW) NVIDIA(0): Unable to load "xf86ExecX86int10".
(EE) NVIDIA(0): Unable to initialize the X Int10 module; the console may not
(EE) NVIDIA(0): be restored correctly on your TV.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B]
[1] 0 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B]
[2] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[3] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[4] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[5] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[6] -1 0 0xe6000000 - 0xe60000ff (0x100) MX[B]
[7] -1 0 0xe6800000 - 0xe68000ff (0x100) MX[B]
[8] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[9] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[10] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[11] -1 0 0xe7000000 - 0xe7ffffff (0x1000000) MX[B](B)
[12] -1 0 0xe8000000 - 0xebffffff (0x4000000) MX[B](B)
[13] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
[14] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
[15] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[18] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[19] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[20] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[21] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[22] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[23] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[24] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
[25] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) NVIDIA(0): Setting mode "800x600"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms" "true"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Damage Notification Manager" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Kernel RC Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc105)+us" };
xkb_geometry { include "pc(pc105)" };
(II) Mouse0: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/X11/misc:unscaled" refcount is 2, should be 1; fixing.
-----------------------------------end of Xorg.0.log -----------------------------------------
----------------------------------xorg.conf------------------------------------------------------
--Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc:unscaled"
FontPath "/usr/share/fonts/X11/75dpi:unscaled"
FontPath "/usr/share/fonts/X11/100dpi:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
# Additional fonts: Locale, Gimp, TTF...
# FontPath "/usr/share/fonts/X11/latin2/75dpi"
# FontPath "/usr/share/fonts/X11/latin2/100dpi"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "extmod"
Load "dbe"
# Load "dri"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
#DisplaySize 330 240 # mm
Identifier "Monitor0"
VendorName "MAGNIVOX"
ModelName "MAGNIVOX-TV"
Option "TVStandard" "NTSC-M"
Option "ConnectedMonitor" "TV"
Option "TVOutFormat" "AUTOSELECT"
Option "DPMS" "true"
HorizSync 30.0 - 50.0
VertRefresh 60.0
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "DigitalVibrance" # <i>
#Option "NoFlip" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "NoLogo" # [<bool>]
#Option "UBB" # [<bool>]
#Option "Stereo" # <i>
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "VideoKey" # <i>
#Option "NvAGP" # <i>
#Option "IgnoreEDID" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ConnectedMonitor" # <str>
#Option "ConnectedMonitors" # <str>
#Option "TVStandard" # <str>
#Option "TVOutFormat" # <str>
#Option "RenderAccel" # [<bool>]
#Option "CursorShadow" # [<bool>]
#Option "CursorShadowAlpha" # <i>
#Option "CursorShadowXOffset" # <i>
#Option "CursorShadowYOffset" # <i>
#Option "UseEdidFreqs" # [<bool>]
#Option "FlatPanelProperties" # <str>
#Option "TwinView" # [<bool>]
#Option "TwinViewOrientation" # <str>
#Option "SecondMonitorHorizSync" # <str>
#Option "SecondMonitorVertRefresh" # <str>
#Option "MetaModes" # <str>
#Option "UseInt10Module" # [<bool>]
#Option "NoTwinViewXineramaInfo" # [<bool>]
#Option "NoRenderExtension" # [<bool>]
#Option "Overlay" # [<bool>]
#Option "CIOverlay" # [<bool>]
#Option "ForceEmulatedOverlay" # [<bool>]
#Option "TransparentIndex" # <i>
#Option "OverlayDefaultVisual" # [<bool>]
#Option "NvEmulate" # <i>
#Option "NoBandWidthTest" # [<bool>]
#Option "CustomEDID-CRT-0" # <str>
#Option "CustomEDID-CRT-1" # <str>
#Option "CustomEDID-DFP-0" # <str>
#Option "CustomEDID-DFP-1" # <str>
#Option "CustomEDID-TV-0" # <str>
#Option "CustomEDID-TV-1" # <str>
#Option "TVOverScan" # <f>
#Option "IgnoreDisplayDevices" # <str>
#Option "MultisampleCompatibility" # [<bool>]
#Option "RegistryDwords" # <str>
#Option "RegistryBinary" # <str>
#Option "NoPowerConnectorCheck" # [<bool>]
#Option "AllowDFPStereo" # [<bool>]
#Option "XvMCUsesTextures" # [<bool>]
#Option "HorizSync" # <str>
#Option "VertRefresh" # <str>
#Option "AllowGLXWithComposite" # [<bool>]
Identifier "NVIDIA GeForce4MX440-8x"
Driver "nvidia"
VideoRam 65536
VendorName "nVidia Corporation"
# Option "NoLogo" "1"
BoardName "NV18 [GeForce4 MX 440 AGP 8x]"
BusID "PCI:1:0:0"
EndSection

Section "ServerFlags"
# Option "AllowMouseOpenFail" "yes"
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device "NVIDIA GeForce4MX440-8x"
Monitor "Monitor0"
SubSection "Display"
Depth 1
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection
--------------------------------- end of xorg.conf------------------------------------------------------

[/list]


Top
 Profile  
 
 Post subject: Re: More info
PostPosted: Fri Sep 28, 2007 12:11 am 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
I'm pretty sure the mx440 isn't supported by the latest driver. You can check this yourself by reading the README file. Someone else has had the exact same problem. Have a look at latest posts.

You can probably install an old version of the nvidia driver, but it may be preferable to buy a newer graphic card.

Good luck

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 
PostPosted: Fri Sep 28, 2007 12:20 am 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
There have actually been quite a lot of posts about the 440 not working with the latest nvidia driver.

I'd prefer to find an fx5200 (some are passively cooled) rather than recompile anything or go backwards with drivers. Depends on what you prefer to fiddle with, but I'd see it as pointless to spend time on hardware that's no longer supported. The fx5200 is also pretty old now, but you can get them with no fan and they're AGP.

Best of luck.

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 28, 2007 5:06 pm 
Offline
Joined: Tue Mar 22, 2005 9:18 pm
Posts: 1371
Location: Brisbane, Queensland, Australia
Have you looked through this KnoppMyth wiki article: http://www.knoppmythwiki.org/index.php?page=BlackScreenAfterInstall

I would suggest using the oldest driver and use the command line option /force to ensure that you "force" the install. From memory the 7 series driver was the last supported version for this card.

_________________
Girkers


Top
 Profile  
 
 Post subject: More Info
PostPosted: Sat Sep 29, 2007 12:28 am 
Offline
Joined: Sun Jun 13, 2004 5:51 am
Posts: 15
Thanks for the tip on the FX-5200 I may order a couple of these after I have exhausted
my options for getting the old card working (including other versions of knoppmyth, or
possibly other mythv installation disks.

Yes I did see the Black Screen Wiki post and tried all of the possible permutations of the
suggested xorg options from that post. They made no difference, except that when I
tried the Option "TVStandard" "HD480i" the Xorg.0.log reported that it could not
find any video modes that were valid using this card. Without this option it found both
the 800x600 and 640x480 modes to be valid for this card. When the card was working
with the old MythTv installation, it used the 800x600 mode and ran perfectly. At that
time I was using the NVIDIA driver version 7667, But alas that version was not patched
for compatibility with the new kernel. Even though I can still download the .run file for
that version from the NVIDIA site, it is useless to me for KnoppMyth R5F27 because
the kernel incompatibility will not allow it to compile the module.

I have a question:

Which previous version of KnoppMyth was the last to allow compiling of NVIDIA drivers
using the .run scripts? Was it R5E50, or R5F1? Does anyone know? If I downgrade
to that version of KnoppMyth then I can compile the correct version of the Nvidia driver
and everything should work as before.

It was probably the last version to use the sarge backported kernel, if that helps.

Also has anyone here tried the Mythbuntu or MythDora installations, specifically related
to the compatibility of the NVIDIA drivers? (Sorry if this question bruses any egos)


Top
 Profile  
 
 Post subject:
PostPosted: Sat Sep 29, 2007 8:30 am 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Have you tried this? http://www.knoppmythwiki.org/index.php?page=NVidiaDriversR5F27

I've also updated the BlackScreenAfterInstall page to point to that.


Top
 Profile  
 
 Post subject: Tried This?
PostPosted: Sat Sep 29, 2007 4:22 pm 
Offline
Joined: Sun Jun 13, 2004 5:51 am
Posts: 15
Yes I tried this suggestion, and not it does not work either. In fact the R5F1 driver
will not even modprobe properly into memory. The modprobe shows no error, but
when you try to startx, it complains that the nvidia driver was not loaded properly.

I also read on an ubuntu forum that NVIDIA released a new driver numbered:
NVIDIA-Linux-x86-96.43.01-pkg1 that is reported to fix the tv-out problem for
MX 4 type gpu's but it also will not compile with the same error
struct 'task_struct has no element 'rlim'

So I guess I will have to order the FX-5200 cards. I found a pretty good one without
a heat sink from newegg for about $49 that has a built in mpeg-2 decoder that might
lighten up the load on the CPU if I ever convert this to a HI-DEF mythtv system in
the future! So I think I will close my participation in this thread and order two of those
cards for my two mythtv systems.

Thanks All for the great tips and helpful advice, I enjoyed testing all of them and it was
fun learning about all the knoppmyth experience. It sure saves time over the old
way of installing everything manually! I can install a whole new system and test a
whole new concept in only 20-minutes! It used to take days to do the same thing.

Have fun you all!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu