View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Oct 23, 2009 7:30 am 
Joined: Fri Mar 31, 2006 2:06 am
Posts: 25

I was tampering with some custom-builds of lcdproc and mythlcdserver and during this I installed som qt3/4 packages and updated some stuff. Clumsy as I am I missed the part where apt-get told me that it was going to upgrade Samba too.
So it installed a 3.4.2 of samba which I could not get working. It wouldnt recognize any of my old users and I could not seem to add them again to smbpasswd in any way.
According to various posts this new version has some changes relating to password-handling and reading of the smbpasswd-file (im no expert though, but you could check this out for furter reference: Redhat and trouble with samba after update and this: Read the 3.4.0-part about new smbpasswd-handling)

I gave up trying to get it working and since then I've downloaded various versions of Samba and build them from scratch. My biggest hope is a 3.2.5 that builds succesfully and I even persuaded it to install the system-binaries in /usr/bin instead of /usr/sbin with the --exec-prefix flag.

Now, Im on thin ice here as Im not quite sure what Im doing :roll:
I have removed 3.4.2 with "apt-get remove samba" but I cant make the 3.2.5 "fit" my system. I had some trouble where it could not find but an "export LD_LIBRARY_PATH=/usr/local/samba/lib" fixed that problem. At least for that session. But I suspect that this is "not the way to do it properly" ;)
Then whenever I "sudo smbd" it just runs once and exits. No error-messages. I also tried "sudo smbd -F -d 10" and so on, but not a sound from it. It just seems to start and then return to commandline. "ps ax |grep smb" reveals nothing.

My question is, is there a nice way to do downgrade via apt-get so that I avoid all this "trial-and-error" hacking. And if so, how ?
I tried messing with "apt-get install samba=3.2.4" and different variations but none seem to work.
I also tried getting one of those .deb packages but Im uncertain about how to make apt-get or dpkg install it.
Another headache is how to make the /etc/init.d/samba script to work with the installation that i hopefully get working with some help from you guys.

EDIT: Sorry guys, I feel kinda stupid because most of the above must be complete nonsense :cry:
I got it working by "apt-get install reinstall" all-the-samba-stuff and one of my problems, a missing smbpasswd-executable got solved when reinstalling samba-common-bin. It appears that I messed up and only upgraded the samba-package and missed upgrading all the tools in my previous attempts.
I did have to create new passwords for my users again even though I had the smbpasswd-file from the previous install.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: Google [Bot] and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu