View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Dec 31, 2010 9:16 pm 
Joined: Fri Dec 31, 2010 9:43 am
Posts: 14
I had a heck of a time getting my IR transmitter working in 6.0.3.

I felt like I should have gone back to ancient distros on this project. NONE of the latest worked with Lirc. Not Mythbuntu, not Mythdora and not LinHES.

I never got Mythbuntu to work. After a lot of BS, Mythdora was fixed with a file name change to alter the module load order.

Thankfully, Mythdora gave me a clue to fix my problem.

I put the following into rc.local and I assume that loading lirc_serial first was the key to making everything work.

echo $(date) - rc.local has been started >>/var/log/rc.local.log
echo $(date) -      begin downing lircd >>/var/log/rc.local.log
/sbin/sv down lircd
echo $(date) -      sleeping for 3 seconds to let lircd exit. >>/var/log/rc.local.log
echo Sleeping for 3 seconds to allow lircd to close.
/bin/sleep 3s
/sbin/modprobe -r lirc_serial
/sbin/modprobe -r lirc_i2c
/sbin/modprobe -r lirc_dev
echo $(date) -      begin bringing up lircd >>/var/log/rc.local.log
/sbin/modprobe lirc_dev
/sbin/modprobe lirc_serial
/sbin/modprobe lirc_i2c
/sbin/sv up lircd
echo $(date) -      run nvidia-settings >>/var/log/rc.local.log
nvidia-settings -l -c 0:0 --config /home/mythtv/.nvidia-settings-rc
echo $(date) - rc.local has been completed >>/var/log/rc.local.log

It worked at the command line, but rc.local is not running on startup. As you see, I put in lines to make my own rc.local.log file. It never ran and the problem remained. I put the rc.local into the MythTV GUI to run on startup and that fixed it. NOTE: The sleep command helps to give time for the lircd to unload. Otherwise, I would get reports that the modules were busy and could not unload.

Why is rc.local failing to run?

Is the lirc move into the kernel the reason why all the distros are messed up?

BTW, the last lines are for getting the nvidia settings to run so overscan would be fixed. If there is a better place, let me know. They did not seem to take in the xinit.rc. Using the terminal sudo nvidia-settings ran fine and the config file used was created by it. Good news is the nvidia-settings actually work in this distro and do not bomb out.

I am sure the learning curve from the other distros helped with solving this faster than with other systems, but should I move away from homebrew transmitters? I hope I will not have to. I built the Enrique circuit and it works pretty nice. I love the dual IR LED out and the standard led indicator to help diagnose issues.

For others with a homebrew serial transmitter, set up the serial port you have it on with setserial as a normal port and cat a small file to it. You can test your circuit that way. If yours does not have an indicator, use a video camera to view the IR LEDs. Be sure to use the "uart none" setting when you are done. The other way is to download WinLirc and test it on a Windows PC to insure your transmitter is functional. That actually works out of the box! I hate to push, but damn, it failed everywhere I tried it.

Other than that, I found the simplicity of LinHES nice to work with. I do miss the VNC Desktop to configure the GUI from a desk instead of in front of the TV, but so far it has not crashed. Mythbuntu was stable, but I never got the IR working and Mythdora was working, but MythTV would bomb out changing channels or running DVDs. So far, I have had NO CRASHES with LinHES, so this may be the Mythbox for me. Lirc needs some work though.

One final note, while going through the files tracing through the 328 issue, my system seemed to have all the fixes in. However, in the file, two lines had this

/sbin/modprobe lirc_serial $FLAGS 2>/dev/nulla

I assume that it should have been

/sbin/modprobe lirc_serial $FLAGS 2>/dev/null

My system is an Athlon XP 3100+, 1GB RAM, Nvidia 5700LE , Onboard VIA Audio (82xxx) and a Hauppauge PVR-350 tuner. I am using S-Video out from the Nvidia card.

I installed on a 20gb drive, but will be cloning it to a 160gb soon. I just did not want to wipe my Mythdora until I had a working system.

Sorry about the length of this post, but having gotten it to work I wanted to debrief myself into the community before I forget everthing.

I hope this helps others. Thank you to everyone who codes or posts their experiences. It helped me a lot to have a chance of a great DVR!



Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu