View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 13 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: LinHES 6.03 Install
PostPosted: Sun Jul 17, 2011 9:35 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
I'm trying to install LinHES on a new computer and it works until the reboot and then my keyboard and mouse become dead and I can't access them. I'm installing LinHES 6.03. I've used several of the 5.X versions and 6.02 without any problems. If anyone could offer some advice I would greatly appreciate it.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 17, 2011 9:54 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
USB keyboard and mouse? Sometimes they will come back to life if you unplug and replug them. Otherwise it's probably a problem with your xorg.conf, for that try logging in remotely and checking the /var/log/Xorg.0.log to see if it is finding a valid keyboard device. Look for messages like this:
Code:
[root@black3 ~]# grep -i keyboard /var/log/Xorg.0.log
(**) |-->Input Device "Keyboard0"
(II) Initializing built-in extension XKEYBOARD
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Keyboard0: Protocol: standard
(**) Keyboard0: XkbRules: "xorg"
(**) Keyboard0: XkbModel: "pc105"
(**) Keyboard0: XkbLayout: "us"
(**) Keyboard0: CustomKeycodes disabled
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
[root@black3 ~]# grep -i mouse /var/log/Xorg.0.log
(**) |-->Input Device "Mouse0"
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
(==) NVIDIA(0): Silken mouse enabled
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(**) Mouse0: Device: "/dev/psaux"
(**) Mouse0: Protocol: "auto"
(**) Mouse0: always reports core events
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) config/hal: Adding input device Macintosh mouse button emulation


Last edited by tjc on Sun Jul 17, 2011 9:54 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 17, 2011 9:54 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1190
Location: Orlando FL
tell us more about your rig? what kind of keyboard and mouse?

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 19, 2011 8:32 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
My system is a non MCE Hauppauge 150 with IR blaster dog bone, Intel 4 at 3 GHz, 2 GB, 120 GB HD, Radeon HD 4550. The keyboard is a generic inland USB keyboard and the mouse is a usb logitech. They are both ran through a KVM. I've removed the KVM and it doesn't make a difference. I can SSH into the box as well as switch to a different console locally. Any help would be appreciated.

Code:
grep -i keyboard /var/log/Xorg.0.log
(**) |-->Input Device "Keyboard0"
(WW) Disabling Keyboard0
(II) Initializing built-in extension XKEYBOARD
grep -i mouse /var/log/Xorg.0.log
(**) |-->Input Device "Mouse0"
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Mouse0
(==) RADEONHD(0): Silken mouse enabled


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 19, 2011 9:14 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1190
Location: Orlando FL
I had trouble installing 6.03 I installed 6.02 and upgraded up.

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 19, 2011 9:20 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
If you can switch consoles then your keyboard is working as far as the OS is concerned, so it's got to be an X configuration problem.

Those (WW) warning lines where it's disabling the keyboard and mouse are your smoking gun. Post your X config and we can try to debug it.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 19, 2011 10:15 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
Here is the output of my xorg.conf file:

Code:
cat /etc/X11/xorg.conf
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/100dpi:unscaled"
   FontPath     "/usr/share/fonts/75dpi:unscaled"
   FontPath     "/usr/share/fonts/TTF"
   FontPath     "/usr/share/fonts/Type1"
EndSection

Section "Module"
   Load  "dbe"
   Load  "dri"
   Load  "extmod"
   Load  "glx"
   Load  "xtrap"
   Load  "freetype"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # [<str>]
        #Option     "offscreensize"         # [<str>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "ignoreconnector"       # [<str>]
        #Option     "forcereduced"          # [<bool>]
        #Option     "forcedpi"              # <i>
        #Option     "useconfiguredmonitor"    # [<bool>]
        #Option     "HPD"                   # <str>
        #Option     "NoRandr"               # [<bool>]
        #Option     "RROutputOrder"         # [<str>]
        #Option     "DRI"                   # [<bool>]
        #Option     "TVMode"                # [<str>]
        #Option     "ScaleType"             # [<str>]
        #Option     "UseAtomBIOS"           # [<bool>]
        #Option     "AtomBIOS"              # [<str>]
        #Option     "UnverifiedFeatures"    # [<bool>]
        #Option     "Audio"                 # [<bool>]
        #Option     "HDMI"                  # [<str>]
        #Option     "COHERENT"              # [<str>]
   Identifier  "Card0"
   Driver      "radeonhd"
   VendorName  "ATI Technologies Inc"
   BoardName   "RV710 [Radeon HD 4350]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
    Modes "800x600"
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
    Modes "800x600"
   EndSubSection
EndSection


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 20, 2011 8:58 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Try changing the "kbd" driver to "keyboard".

Is that xorg.conf one that was restored from a previous version? It looks a little out of date overall (e.g. mine no longer has anything in the "Files" section and the "Module" section is also sparser.) but that is an issue that can be dealt with later...


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 24, 2011 6:49 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
I've been away for a few days I've tried changing the driver to "keyboard" and it didn't work. When I installed I installed from a install CD over an old version of Ubuntu.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jul 25, 2011 6:27 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
You did restart the X server after making the change right?

Does it still give that error about disabling the keyboard in the logs?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jul 25, 2011 8:17 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
I rebooted the machine after I made the change. The logs showed no difference:
Code:
grep -i keyboard /var/log/Xorg.0.log
(**) |-->Input Device "Keyboard0"
(WW) Disabling Keyboard0
(II) Initializing built-in extension XKEYBOARD
grep -i mouse /var/log/Xorg.0.log
(**) |-->Input Device "Mouse0"
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Mouse0
(==) RADEONHD(0): Silken mouse enabled


I also modified my xorg.conf to include:
Code:
Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"


and that didn't work either. It doesn't work going through the KVM or PC, but I noticed when it's plugged into the PC every time I hit a key a few seconds later numlock, scrolllock, and capslock all light up at the same time.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 26, 2011 7:58 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
What is that funky character in your xorg.conf name?

Googling a couple of the error messages came up with this suggestion, try adding it to you xorg.conf file.
Code:
Section "ServerFlags"
Option "AllowEmptyInput" "off"
EndSection

There are suggestions that the problem ultimately track back to a HAL issue, but no solution along those lines


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 28, 2011 10:36 pm 
Offline
Joined: Thu Jan 11, 2007 10:20 pm
Posts: 10
There is no funky character in the xorg.conf name. It just pasted funny. Your suggestion worked! Thanks! Prior to that I narrowed it down to the graphics card. If I have it out when I boot up then I don't have a problem. If I booted with nothing plugged into it and connected the monitor afterwards it worked fine.

The only two things I notice now are that the volume comes out almost muted and I cannot get video out of the S-video port. I suspect the sound problem may be related to ALSA or asound.conf needs tweaked. As for the S-video I'm thinking I may need to set an option in xorg.conf or change the driver to catalyst. Anyone have any thoughts or suggestions on the sound or video?


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu