LinHES Forums

"Scan for games" not working
Page 1 of 1

Author:  poflynn [ Sat Jul 23, 2011 12:11 pm ]
Post subject:  "Scan for games" not working

I have configured this to the best of my ability. In fact, sdlmame works fine from the cmd line, it's just the MythGame UI I can't get to work. When I scan for games all I get is frozen bubble.

Under Mythsetup -> Media Settings -> Game Settings -> General Settings I have set the 3 directories to /myth/games/screenshots etc (not that it matters much I'd say, those dirs are empty).

Under Game Players -> SDLMame I have set its ROM dir to /myth/games/xmame/roms and in there I have two rom files. When I run SDLmame on the cmd line it finds both of these and prompts me to select one but when I do a 'Scan for Games' in MythGame it never finds anything. There are no msgs in the frontend log. Permsissions look fine and the fact that it all works from the cmd line under mythtv user tells me they are ok.

Any other ideas? I'm running R6.02. TIA.

Author:  poflynn [ Sat Jul 23, 2011 6:14 pm ]
Post subject: 

One more item - how do I get audio working? Googling this brings me surprisingly few answers other than -da alsa to use alsa (how do I specify which alsa device?)


Author:  mattbatt [ Sat Jul 23, 2011 11:23 pm ]
Post subject: 

start here
alsaconf is one way
What options do you get when you go in to Service Menu -> LinHES-> audio ? and then go to Service Menu -> MythTV-> General Settings -> 3rd page should be audio setup.

Author:  poflynn [ Sun Jul 24, 2011 9:23 am ]
Post subject: 

Maybe I should have been clearer - how do I get audio in sdlmame working. Audio in Myth is working fine. I am using Alsa with a USB soundcard outputting old fashioned analog stereo.


Author:  tjc [ Sun Jul 24, 2011 5:25 pm ]
Post subject: 

Is that audio output set up as the default in /etc/asound.conf?

Author:  poflynn [ Wed Aug 17, 2011 9:37 pm ]
Post subject: 

I came back here to report that I fixed the scanning issue - or more precisely my 9 yr old did! There's a field for 'rom extensions that are compatible with this player' or something to that effect under the emulator player settings screen. If left blank, it supposedly picks up all files in the rom directory you specified in a prior setting. My son suggested I put the zip file extension in there, so I did, sans dot (ie just "zip"). To my surprise it worked! Must be a bug in the game scanner code.

tjc: I somehow missed your response. I checked now & I do not have any /etc/asound.conf file, only an /etc/asound.state file. There's none anywhere in the system except under the tweaker directory which I presume is a template only. Maybe I should create one? What does yours look like?


Author:  tjc [ Thu Aug 18, 2011 8:06 pm ]
Post subject: 

For 6.04 with an updated ALSA driver and audio output via HDMI:
[root@black3 ~]# cat /etc/asound.conf
pcm.!default {
    type plug
    slave {
        pcm "hdmi:CARD=NVidia,DEV=1"

For other outputs just use aplay -L to get your device names and use the appropriate one. These long names tend to me more stable than the card and device numbers which aplay -l show.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group