View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 7 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Oct 07, 2007 6:29 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
I posted on this over a year ago, but have yet to find something that actually works without coming on mplayer playback.

The xscreensaver described on this KM wiki article works (don't install it via apt-get though) and it is smart such that when you're using the mythtv player, it doesn't come on -- it even knows when its paused and does come on in that case.

Now if there were only some way to get it to work with mplayer such that it would know when it is paused. It currently doesn't come on unless paused. From there the only key on my gray remote that will take it out of screensaver is the exit key which also kills mplayer.

What are you guys doing out there in this regard if anything?

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 07, 2007 8:43 pm 
Offline
Joined: Mon Mar 13, 2006 2:28 am
Posts: 143
Location: Brisbane, Australia
Howdy,

Try adding this to your command line;

Code:
mplayer --stop-xscreensaver


Or add this to your ~/.mplayer/config file

Code:
stop-xscreensaver = 1


And for xine modify your ~/.xine/config file and uncomment this;

Code:
gui.screensaver_timeout:10


Regards,
Kirk.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 08, 2007 1:41 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Kirk wrote:
Howdy,

Try adding this to your command line;

Code:
mplayer --stop-xscreensaver


Or add this to your ~/.mplayer/config file

Code:
stop-xscreensaver = 1


Hi Kirk - I should have mentioned I'm doing that as-per the wiki article. On my system, the addition of the
Code:
stop-xscreensaver = 1
line to my ~/.mplayer/config does indeed keep xscreensaver from starting if mplayer is playing back a file, but if I pause mplayer, xscreensaver will turn on (which is what I want) but it WON'T turn off by any key on my grey remote (hauppauge) except for the "exit" key which also has the effect of stopping the playback of mplayer.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 08, 2007 1:56 am 
Offline
Joined: Mon Mar 13, 2006 2:28 am
Posts: 143
Location: Brisbane, Australia
Ah, I see. Should have read your links ;)

How about adding an mplayer line to your lircrc config and setting it to do something useless, but that which is enough to bring your display out of screensaver mode. Dunno if it would work or not, just a thought. Checkout;

Code:
mplayer -input cmdlist


it might give you some ideas.. get_time_pos or something like that might work?

On second though, you might need to make that an xscreensaver line to bring you out of that program..


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 08, 2007 12:51 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Thanks for the suggestions. I have no idea why any button on the remote doesn't work to bring it out of screensaver mode. Must be something to do with mplayer and how it handles the output from lirc. It's as if mplayer is "in front" of xscreensaver in this regard -- taking the output while xscreensaver runs but doesn't listen for events from lirc. I can actually pause, unpause, FF, REV, etc. with mplayer while the screensaver is active.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 08, 2007 5:40 pm 
Offline
Joined: Mon Mar 13, 2006 2:28 am
Posts: 143
Location: Brisbane, Australia
Another idea. I know you want the screensaver to come on if paused, but if you could live without that you could make a wrapper script that kills xscreensaver before starting mplayer, then restarts it when mplayer exits.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 12, 2007 3:41 am 
Offline
Joined: Sat Apr 08, 2006 7:27 am
Posts: 125
if you upgrade to the most recent mplayer, that option is enabled by default. but then upgrading mplayer might break something... so adding stop-xscreensaver = 1 to the mplayer config file is probably a better idea.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu