View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 10 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Nov 13, 2009 10:42 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
Hi to all !
This is my first post.
I installed Knoppmyth a few months ago (I waited because I had problems to have a good signal) but am still struggling to make it work. In particular for DTV which is the main usage I want to do from my machine. :(
Here is what lspci says:
Code:
00:00.0 Host bridge: Intel Corporation 82810E DC-133 GMCH [Graphics Memory Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 02)
01:03.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
01:04.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:04.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
01:04.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)

My DVB-T card is a Hauppauge WinTV Nova-T that works fine. I tried it with Kubuntu (Kaffeine) and even managed to make it work on my Knoppmyth install with MPlayer or VLC (can't remember).
I also managed to configure channels (I hope I did it well) by searching through frequencies. So MythTV seems to use my DVB-T card correctly, at least for this purpose. :)
But when I start my computer and want to watch DTV, MythTV crashes. :( The messages end by the following:
Code:
mythfrontend: symbol lookup error: /usr/lib/mythtv-0.21.so.0: undefined symbol: glXGetProcAddress

If I load MythTV again with the mythfrontend command, it crashes the same way when I try to watch at DTV.
But if I become super user or load MythTV with putting the messages in a file, I don't have the same behaviour. Then MythTV doesn't crash but I have a black screen for about ten seconds and then MythTV returns to the main page. :?
Here is the mythbackend log after trying to watch at DTV:
Code:
Starting up as the master server.
2009-11-13 08:20:41.892 New DB connection, total: 3
2009-11-13 08:20:41.896 Connected to database 'mythconverg' at host: localhost
2009-11-13 08:20:42.136 New DB scheduler connection
2009-11-13 08:20:42.140 Connected to database 'mythconverg' at host: localhost
2009-11-13 08:20:42.260 MediaServer:: Loopback address specified - 127.0.0.1. Disabling UPnP
2009-11-13 08:20:42.264 Main::Registering HttpStatus Extension
2009-11-13 08:20:42.272 mythbackend version: 0.21.20080304-1 www.mythtv.org
2009-11-13 08:20:42.277 Enabled verbose msgs:  important general
2009-11-13 08:20:42.333 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2009-11-13 08:20:45.265 Reschedule requested for id -1.
2009-11-13 08:20:45.381 Scheduled 0 items in 0.1 = 0.03 match + 0.09 place
2009-11-13 08:20:45.408 Seem to be woken up by USER
2009-11-13 08:21:14.848 MainServer::HandleAnnounce Monitor
2009-11-13 08:21:14.852 adding: mythtv as a client (events: 0)
2009-11-13 08:21:14.857 MainServer::HandleAnnounce Monitor
2009-11-13 08:21:14.859 adding: mythtv as a client (events: 1)
2009-11-13 08:21:14.897 MainServer::HandleAnnounce Playback
2009-11-13 08:21:14.904 adding: mythtv as a client (events: 0)
2009-11-13 08:21:14.943 TVRec(5): Changing from None to WatchingLiveTV
2009-11-13 08:21:14.975 TVRec(5): HW Tuner: 5->5
2009-11-13 08:21:16.566 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2009-11-13 08:21:17.171 Finished recording Inconnu: channel 1002
2009-11-13 08:21:18.452 Finished recording Inconnu: channel 1002
2009-11-13 08:21:18.663 TVRec(5): Changing from WatchingLiveTV to None
2009-11-13 08:21:18.767 DevRdB(0) Error: Stop(): Not running.
2009-11-13 08:21:19.571 Using runtime prefix = /usr
2009-11-13 08:21:19.578 Empty LocalHostName.
2009-11-13 08:21:19.580 Using localhost value of mythtv
2009-11-13 08:21:19.676 New DB connection, total: 1
2009-11-13 08:21:19.699 Connected to database 'mythconverg' at host: localhost
2009-11-13 08:21:19.720 Closing DB connection named 'DBManager0'
2009-11-13 08:21:19.724 Connected to database 'mythconverg' at host: localhost
2009-11-13 08:21:19.735 New DB connection, total: 2
2009-11-13 08:21:19.753 Connected to database 'mythconverg' at host: localhost
2009-11-13 08:21:19.771 Current Schema Version: 1214
2009-11-13 08:21:19.843 Preview Error: Previewer file '/home/mythtv/1002_20091113082115.mpg' is not valid.
2009-11-13 08:21:19.851 Preview Error: Run() file not local: '/home/mythtv/1002_20091113082115.mpg'
2009-11-13 08:21:19.902 Preview Error: Preview process not ok.
         fileinfo(/home/mythtv/1002_20091113082115.mpg.png) exists: 0 readable: 0 size: 0
2009-11-13 08:22:02.166 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2009-11-13 08:22:02.183 Expiring 0 MBytes for 1002 @ Fri Nov 13 07:39:37 2009 => Inconnu
2009-11-13 08:22:02.202 Expiring 0 MBytes for 1002 @ Fri Nov 13 07:40:36 2009 => Inconnu

Then the mythfrontend log (which is curious with the dates):
Code:
2009-07-13 08:24:32.109 New DB connection, total: 2
2009-07-13 08:24:32.111 Connected to database 'mythconverg' at host: localhost
2009-07-13 08:24:32.122 mythfrontend version: 0.21.20080304-1 www.mythtv.org
2009-07-13 08:24:32.123 Enabled verbose msgs:  important general
2009-07-13 08:24:33.766 Unable to parse themeinfo.xml for glass-wide
2009-07-13 08:24:33.767 The theme (glass-wide) is missing a themeinfo.xml file
2009-07-13 08:24:35.234 Unable to parse themeinfo.xml for glass-wide
2009-07-13 08:24:35.235 The theme (glass-wide) is missing a themeinfo.xml file
2009-07-13 08:24:36.830 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-07-13 08:24:36.836 Primary screen 0.
2009-07-13 08:24:36.841 Using screen 0, 1024x768 at 0,0
2009-07-13 08:24:36.845 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-07-13 08:24:36.850 Switching to square mode (Iulius)
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
2009-07-13 08:24:36.912 Using the Qt painter
mythtv: could not connect to socket
mythtv: No such file or directory
2009-07-13 08:24:36.914 lirc_init failed for mythtv, see preceding messages
2009-07-13 08:24:36.928 JoystickMenuClient Error: Joystick disabled - Failed to open device /dev/input/js0
Xlib:  extension "GLX" missing on display ":0.0".
2009-07-13 08:24:41.534 Loading from: /usr/share/mythtv/themes/Iulius/base.xml
2009-07-13 08:24:41.991 Loading from: /usr/share/mythtv/themes/default/base.xml
2009-07-13 08:24:42.136 Updating description...
2009-07-13 08:24:42.282 Updating description...
2009-07-13 08:24:42.715 Updating description...
2009-07-13 08:24:42.917 Registering Internal as a media playback plugin.
2009-07-13 08:24:43.640 Updating description...
2009-07-13 08:24:43.928 MonitorRegisterExtensions(0x100, gif,jpg,png)
2009-07-13 08:24:44.064 Setting Up MythMovies Database Tables
2009-07-13 08:24:44.106 MythMovies Database Setup Complete
2009-07-13 08:24:46.544 Failed to run 'cdrecord --scanbus -dev=ATA'
2009-07-13 08:24:48.069 Failed to run 'cdrecord --scanbus -dev=ATAPI'
2009-07-13 08:24:48.462 Updating description...
2009-07-13 08:24:48.470 Updating description...
2009-07-13 08:24:48.474 Key > is bound to multiple actions in context Music.
2009-07-13 08:24:48.477 Updating description...
2009-07-13 08:24:48.484 Updating description...
2009-07-13 08:24:48.585 MonitorRegisterExtensions(0x40, ogg,mp3,aac,flac)
SIP: Creating autogen directory entry for this host
Failed to find network interface eth0
SIP listening on IP Address :5060 NAT address
SIP: Cannot register; proxy, username or password not set
Destroying SipFsm object
2009-07-13 08:24:49.483 Updating description...
2009-07-13 08:24:49.509 Updating description...
2009-07-13 08:24:49.516 Updating description...
2009-07-13 08:24:49.523 Updating description...
2009-07-13 08:24:49.537 Updating description...
2009-07-13 08:24:50.449 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-07-13 08:25:14.015 New DB connection, total: 3
2009-07-13 08:25:14.017 Connected to database 'mythconverg' at host: localhost
2009-07-13 08:25:14.129 MythMusic hasn't found any tracks! That's ok with me if it's ok with you.
2009-07-13 08:25:14.336 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/music-ui.xml
2009-07-13 08:25:43.808 MythMusic hasn't found any tracks! That's ok with me if it's ok with you.
2009-07-13 08:25:43.981 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/music-ui.xml
2009-07-13 08:28:39.190 XMLParse::LoadTheme using /usr/share/mythtv/themes/Iulius/ui.xml
2009-07-13 08:28:40.119 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2009-07-13 08:28:40.126 Using protocol version 40
2009-07-13 08:28:40.206 DB Error (Get program recording priorities query):
Query was:
SELECT recordid, title, chanid, starttime, startdate, type, inactive, last_record, avg_delay FROM record;
No error type from QSqlError?  Strange...
2009-07-13 08:28:49.086 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/game-ui.xml
MythThemedDialog.o: something is requesting a screen update of zero size. A widget probably has not done a calculateScreeArea(). Will redraw the whole screen (inefficient!).
2009-07-13 08:29:00.987 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/phone-ui.xml
mythphone: Nothing in your Call History -- ok?
2009-07-13 08:29:02.993 No theme dir: /home/mythtv/.mythtv/themes/default
Couldn't open camera /dev/video
Can't close a camera that isn't open
2009-07-13 08:29:21.332 MythMusic hasn't found any tracks! That's ok with me if it's ok with you.
2009-07-13 08:29:26.286 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/music-ui.xml
2009-07-13 08:29:39.699 Loading from: /usr/share/mythtv/themes/default/controls-ui.xml
2009-07-13 08:29:53.518 Received a remote 'Clear Cache' request
2009-07-13 08:29:57.212 Loading from: /usr/share/mythtv/themes/default/appear-ui.xml
2009-07-13 08:30:13.173 Failed to run 'cdrecord --scanbus -dev=ATA'
2009-07-13 08:30:14.690 Failed to run 'cdrecord --scanbus -dev=ATAPI'
2009-07-13 08:32:26.125 Unable to parse themeinfo.xml for glass-wide
2009-07-13 08:32:26.126 The theme (glass-wide) is missing a themeinfo.xml file
2009-07-13 08:32:45.011 Received a remote 'Clear Cache' request
2009-07-13 08:32:45.026 Primary screen 0.
2009-07-13 08:32:45.030 Using screen 0, 1024x768 at 0,0
2009-07-13 08:32:45.038 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-07-13 08:32:45.043 Switching to square mode (Iulius)
2009-07-13 08:32:49.477 Loading from: /usr/share/mythtv/themes/Iulius/base.xml
2009-07-13 08:32:49.932 Loading from: /usr/share/mythtv/themes/default/base.xml
2009-07-13 08:39:22.322 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/status-ui.xml
QDateTime::fromString: Parameter out of range
QDateTime::fromString: Parameter out of range
2009-07-13 08:39:52.237 Connecting to zm server: localhost:6548 (try 1 of 10)
2009-07-13 08:39:52.738 Connecting to zm server: localhost:6548 (try 2 of 10)
2009-07-13 08:39:53.239 Connecting to zm server: localhost:6548 (try 3 of 10)
2009-07-13 08:39:53.740 Connecting to zm server: localhost:6548 (try 4 of 10)
2009-07-13 08:39:54.242 Connecting to zm server: localhost:6548 (try 5 of 10)
2009-07-13 08:39:54.743 Connecting to zm server: localhost:6548 (try 6 of 10)
2009-07-13 08:39:55.244 Connecting to zm server: localhost:6548 (try 7 of 10)
2009-07-13 08:39:55.745 Connecting to zm server: localhost:6548 (try 8 of 10)
2009-07-13 08:39:56.246 Connecting to zm server: localhost:6548 (try 9 of 10)
2009-07-13 08:39:56.748 Connecting to zm server: localhost:6548 (try 10 of 10)
2009-07-13 08:42:03.406 Received a remote 'Clear Cache' request
2009-07-13 08:42:30.554 Received a remote 'Clear Cache' request
2009-07-13 08:43:45.300 Received a remote 'Clear Cache' request
2009-07-13 08:43:52.666 Deleting UPnP client...
2009-07-13 08:43:52.669 QMulticastSocket: setsockopt - IP_ADD_MEMBERSHIP Error
2009-08-30 12:06:14.176 New DB connection, total: 2
2009-08-30 12:06:14.193 Connected to database 'mythconverg' at host: localhost
2009-08-30 12:06:14.205 mythfrontend version: 0.21.20080304-1 www.mythtv.org
2009-08-30 12:06:14.207 Enabled verbose msgs:  important general
2009-08-30 12:06:15.382 Unable to parse themeinfo.xml for glass-wide
2009-08-30 12:06:15.383 The theme (glass-wide) is missing a themeinfo.xml file
2009-08-30 12:06:17.120 Unable to parse themeinfo.xml for glass-wide
2009-08-30 12:06:17.121 The theme (glass-wide) is missing a themeinfo.xml file
2009-08-30 12:06:19.154 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-08-30 12:06:19.169 Primary screen 0.
2009-08-30 12:06:19.172 Using screen 0, 1024x768 at 0,0
2009-08-30 12:06:19.181 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-08-30 12:06:19.185 Switching to square mode (Iulius)
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
2009-08-30 12:06:19.281 Using the Qt painter
mythtv: could not connect to socket
mythtv: No such file or directory
2009-08-30 12:06:19.284 lirc_init failed for mythtv, see preceding messages
2009-08-30 12:06:19.299 JoystickMenuClient: Initialization of /dev/input/js0 succeeded using config file /home/mythtv/.mythtv/joystickmenurc
Xlib:  extension "GLX" missing on display ":0.0".
2009-08-30 12:06:27.962 Loading from: /usr/share/mythtv/themes/Iulius/base.xml
2009-08-30 12:06:28.791 Loading from: /usr/share/mythtv/themes/default/base.xml
2009-08-30 12:06:29.823 Registering Internal as a media playback plugin.
2009-08-30 12:06:30.666 MonitorRegisterExtensions(0x100, gif,jpg,png)
2009-08-30 12:06:33.401 Failed to run 'cdrecord --scanbus -dev=ATA'
2009-08-30 12:06:34.933 Failed to run 'cdrecord --scanbus -dev=ATAPI'
2009-08-30 12:06:35.270 Key > is bound to multiple actions in context Music.
2009-08-30 12:06:35.404 MonitorRegisterExtensions(0x40, ogg,mp3,aac,flac)
Failed to find network interface eth0
SIP listening on IP Address :5060 NAT address
SIP: Cannot register; proxy, username or password not set
Destroying SipFsm object
2009-08-30 12:06:37.438 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-08-30 12:08:59.463 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2009-08-30 12:08:59.471 Using protocol version 40
2009-08-30 12:08:59.490 Received a remote 'Clear Cache' request
2009-08-30 12:09:19.099 XMLParse::LoadTheme using /usr/share/mythtv/themes/default/video-ui.xml
2009-08-30 12:09:21.257 videolist.cpp: getVideoListMetadata: index out of bounds: 0
2009-08-30 12:09:21.261 videolist.cpp: getVideoListMetadata: index out of bounds: 0
2009-08-30 12:09:38.494 Received a remote 'Clear Cache' request
2009-08-30 12:10:10.723 No theme dir: /home/mythtv/.mythtv/themes/Iulius
2009-08-30 12:10:39.398 Received a remote 'Clear Cache' request
2009-08-30 12:10:54.489 Event socket closed. No connection to the backend.

To have more details about my configuration, here is my xorg.conf:
Code:
Section "ServerLayout"
   Identifier     "XFree86 Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
# Serial Mouse not detected
        InputDevice    "USB Mouse" "CorePointer"
EndSection

Section "ServerFlags"
   Option "AllowMouseOpenFail"  "true"
   
EndSection

Section "Files"
   RgbPath      "/usr/share/X11/rgb"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi:unscaled"
   FontPath     "/usr/share/fonts/X11/100dpi:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/Speedo"
   FontPath     "/usr/share/fonts/X11/PEX"
# Additional fonts: Locale, Gimp, TTF...
   FontPath     "/usr/share/fonts/X11/cyrillic"
#   FontPath     "/usr/share/fonts/X11/latin2/75dpi"
#   FontPath     "/usr/share/fonts/X11/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath     "/usr/share/fonts/truetype"
   FontPath     "/usr/share/fonts/latex-ttf-fonts"
EndSection

Section "Module"
# Comments: see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=346408
   Load  "dbe" # Double Buffering Extension, very important.
#   Load  "dri" # This shouldn't be available choice if user has selected driver vga, vesa or nv.
   Load  "glx" # GLX Extension.
   Load  "freetype" # Freetype fonts.
   Load  "type1"  # Type 1 fonts
   Load  "record" # Developer extension, usually not needed
#   Load  "extmod" # This is okay, but if you look into "man xorg.conf" you'll find option NOT to include DGA extension with extmod, and for a good reason.. DGA causes instability as it access videoram without consulting X about it.
   SubSection      "extmod"
      Option          "omit xfree86-dga"
   EndSubSection
#   Load  "speedo" # Speedo fonts, this module doesn't exist in Xorg 7.0.17
# The following are deprecated/unstable/unneeded in Xorg 7.0
#       Load  "ddc"  # ddc probing of monitor, this should be never present, as it gets automatically loaded.
#   Load  "GLcore" # This should be never present, as it gets automatically loaded.
#       Load  "bitmap" # Should be never present, as it gets automatically loaded. This is a font module, and loading it in xorg.conf makes X try to load it twice.
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option      "CoreKeyboard"
   Option "XkbRules" "xorg"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "fr"

EndSection

Section "InputDevice"
   Identifier  "Serial Mouse"
   Driver      "mouse"
   Option      "Protocol" "Microsoft"
   Option      "Device" "/dev/ttyS0"
   Option      "Emulate3Buttons" "true"
   Option      "Emulate3Timeout" "70"
   Option       "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
   Identifier  "PS/2 Mouse"
   Driver      "mouse"
   Option      "Protocol" "auto"
Option          "ZAxisMapping"          "4 5"
   Option      "Device" "/dev/psaux"
   Option      "Emulate3Buttons" "true"
   Option      "Emulate3Timeout" "70"
   Option       "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
   Option      "SendCoreEvents"   "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

# Auto-generated by KNOPPIX mkxf86config

Section "Monitor"
   Identifier   "Monitor0"
   Option   "DPMS"   "true"
   Option "UseEdidDpi" "FALSE"
   Option "DPI" "100 x 100"
   VendorName   "SAM"
   ModelName   "SAM1058"
   HorizSync 30 - 70 # DDC-probed
   VertRefresh 50 - 160 # DDC-probed
   # These are the DDC-probed settings reported by your monitor.
   # 1280x1024, 75.0Hz; hfreq=79.98, vfreq=75.03
   ModeLine "1280x1024"   135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
   # 1024x768, 85.0Hz; hfreq=68.68, vfreq=85.00
   ModeLine "1024x768"    94.50 1024 1072 1168 1376  768  769  772  808 +hsync +vsync
   # 1024x768, 75.0Hz; hfreq=60.02, vfreq=75.03
   ModeLine "1024x768"    78.75 1024 1040 1136 1312  768  769  772  800 +hsync +vsync
   # 1024x768, 70.0Hz; hfreq=56.48, vfreq=70.07
   ModeLine "1024x768"    75.00 1024 1048 1184 1328  768  771  777  806 -hsync -vsync
   # 1024x768, 60.0Hz; hfreq=48.36, vfreq=60.00
   ModeLine "1024x768"    65.00 1024 1048 1184 1344  768  771  777  806 -hsync -vsync
   # 800x600, 85.0Hz; hfreq=53.67, vfreq=85.06
   ModeLine "800x600"    56.25  800  832  896 1048  600  601  604  631 +hsync +vsync
   # 800x600, 75.0Hz; hfreq=46.88, vfreq=75.00
   ModeLine "800x600"    49.50  800  816  896 1056  600  601  604  625 +hsync +vsync
   # 800x600, 60.0Hz; hfreq=37.88, vfreq=60.32
   ModeLine "800x600"    40.00  800  840  968 1056  600  601  605  628 +hsync +vsync
   # 800x600, 56.0Hz; hfreq=35.16, vfreq=56.25
   ModeLine "800x600"    36.00  800  824  896 1024  600  601  603  625 +hsync +vsync
   # 640x480, 85.0Hz; hfreq=43.27, vfreq=85.01
   ModeLine "640x480"    36.00  640  696  752  832  480  481  484  509 -hsync -vsync
   # 640x480, 75.0Hz; hfreq=37.50, vfreq=75.00
   ModeLine "640x480"    31.50  640  656  720  840  480  481  484  500 -hsync -vsync
   # 640x480, 72.0Hz; hfreq=37.86, vfreq=72.81
   ModeLine "640x480"    31.50  640  656  696  816  480  481  484  504 -hsync -vsync
   # 640x480, 60.0Hz; hfreq=31.47, vfreq=59.94
   ModeLine "640x480"    25.17  640  648  744  784  480  482  484  509 -hsync -vsync
   # Extended modelines with GTF timings
   # 640x480 @ 100.00 Hz (GTF) hsync: 50.90 kHz; pclk: 43.16 MHz
   ModeLine "640x480"  43.16  640 680 744 848  480 481 484 509  -HSync +Vsync
   # 768x576 @ 60.00 Hz (GTF) hsync: 35.82 kHz; pclk: 34.96 MHz
   ModeLine "768x576"  34.96  768 792 872 976  576 577 580 597  -HSync +Vsync
   # 768x576 @ 72.00 Hz (GTF) hsync: 43.27 kHz; pclk: 42.93 MHz
   ModeLine "768x576"  42.93  768 800 880 992  576 577 580 601  -HSync +Vsync
   # 768x576 @ 75.00 Hz (GTF) hsync: 45.15 kHz; pclk: 45.51 MHz
   ModeLine "768x576"  45.51  768 808 888 1008  576 577 580 602  -HSync +Vsync
   # 768x576 @ 85.00 Hz (GTF) hsync: 51.42 kHz; pclk: 51.84 MHz
   ModeLine "768x576"  51.84  768 808 888 1008  576 577 580 605  -HSync +Vsync
   # 768x576 @ 100.00 Hz (GTF) hsync: 61.10 kHz; pclk: 62.57 MHz
   ModeLine "768x576"  62.57  768 816 896 1024  576 577 580 611  -HSync +Vsync
   # 800x600 @ 100.00 Hz (GTF) hsync: 63.60 kHz; pclk: 68.18 MHz
   ModeLine "800x600"  68.18  800 848 936 1072  600 601 604 636  -HSync +Vsync
   # 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
   ModeLine "1024x768"  113.31  1024 1096 1208 1392  768 769 772 814  -HSync +Vsync
   # 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
   ModeLine "1152x864"  81.62  1152 1216 1336 1520  864 865 868 895  -HSync +Vsync
   # 1152x864 @ 85.00 Hz (GTF) hsync: 77.10 kHz; pclk: 119.65 MHz
   ModeLine "1152x864"  119.65  1152 1224 1352 1552  864 865 868 907  -HSync +Vsync
   # 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
   ModeLine "1152x864"  143.47  1152 1232 1360 1568  864 865 868 915  -HSync +Vsync
   # 1280x960 @ 72.00 Hz (GTF) hsync: 72.07 kHz; pclk: 124.54 MHz
   ModeLine "1280x960"  124.54  1280 1368 1504 1728  960 961 964 1001  -HSync +Vsync
   # 1280x960 @ 75.00 Hz (GTF) hsync: 75.15 kHz; pclk: 129.86 MHz
   ModeLine "1280x960"  129.86  1280 1368 1504 1728  960 961 964 1002  -HSync +Vsync
   # 1280x960 @ 100.00 Hz (GTF) hsync: 101.70 kHz; pclk: 178.99 MHz
   ModeLine "1280x960"  178.99  1280 1376 1520 1760  960 961 964 1017  -HSync +Vsync
   # 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
   ModeLine "1280x1024"  190.96  1280 1376 1520 1760  1024 1025 1028 1085  -HSync +Vsync
   # 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
   ModeLine "1400x1050"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync +Vsync
   # 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
   ModeLine "1400x1050"  149.34  1400 1496 1648 1896  1050 1051 1054 1094  -HSync +Vsync
   # 1400x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 155.85 MHz
   ModeLine "1400x1050"  155.85  1400 1496 1648 1896  1050 1051 1054 1096  -HSync +Vsync
   # 1400x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 179.26 MHz
   ModeLine "1400x1050"  179.26  1400 1504 1656 1912  1050 1051 1054 1103  -HSync +Vsync
   # 1400x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 214.39 MHz
   ModeLine "1400x1050"  214.39  1400 1512 1664 1928  1050 1051 1054 1112  -HSync +Vsync
   # 1600x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 280.64 MHz
   ModeLine "1600x1200"  280.64  1600 1728 1904 2208  1200 1201 1204 1271  -HSync +Vsync
   # 1680x1050 (Notebook)
   ModeLine "1680x1050" 154.2 1680 1712 2296 2328   1050 1071 1081 1103
   # 1920x1200 @ 60.00 Hz (GTF)  hsync: 74.52; pclk: 193.16 MHz
   ModeLine "1920x1200" 193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +HSync
EndSection

Section "Device"
   ### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
        #Option     "sw_cursor"
        #Option     "hw_cursor"
        #Option     "NoAccel"
        #Option     "ShowCache"
        #Option     "ShadowFB"
        #Option     "UseFBDev"
        #Option     "Rotate"
   Identifier  "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
   Driver      "i810"
   Option "XvmcUsesTextures" "false"
   Option "UseEvents" "true"
   VendorName  "All"
   BoardName   "All"
#   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultColorDepth 24
   SubSection "Display"
      Depth     1
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     32
      Modes "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "DRI"
   Mode 0666
EndSection

So, what is the problem with my configuration? What should I do to make it work? Don't hesitate to ask me fore more details. :wink:

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 18, 2009 6:26 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
Nobody has any idea?

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 20, 2009 5:34 am 
Offline
Joined: Wed Mar 03, 2004 7:43 pm
Posts: 743
Location: Sydney, Australia
This looks like a video card driver issue. It isn't DVB specific. You would probably get the same crash or black screen if you played a DVD.

A post in one of the other sections of the forum may get more attention, but you could try documenting the video card (or motherboard if inbuilt), the Xlog, and the video renderer (e.g. xv-blit, opengl, xlib, xshm).

Changing the renderer may get you working.

_________________
| Nigel Pearson, nigel@ind.tansu.com.au
| Telstra BID, Sydney, Australia
|
|"Things you own end up owning you" - Tyler, Fight Club


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 20, 2009 6:39 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
I was eventually thinking the same way. My video card is inbuilt. I wanted to try DVB before buying a card with a TV-out. But I Have decided to buy a used one (a GeForce with XvMC support). In between, I'll try to change the video renderer.
Thank you for your reply and sorry not to have posted in the most appropriate section (it's not easy when you don't exacltly know where your problem comes from).

Edit: How do you change the video renderer for DTV?

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 21, 2009 1:17 pm 
Offline
Joined: Wed Mar 03, 2004 7:43 pm
Posts: 743
Location: Sydney, Australia
Setup -> TV Settings -> Playback

and go to the third page, where there are a number of rules. Each one has an edit button which will bring up a page which has a video renderer.

The trick is finding out which of these rules (if any) is being used.

_________________
| Nigel Pearson, nigel@ind.tansu.com.au
| Telstra BID, Sydney, Australia
|
|"Things you own end up owning you" - Tyler, Fight Club


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 23, 2009 6:25 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
I have tried all possible renderers (except those for Windows and Mac OS). But no one works. I have this error:
Code:
TV error: Failed to get recording show list

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 23, 2009 5:52 pm 
Offline
Joined: Wed Mar 03, 2004 7:43 pm
Posts: 743
Location: Sydney, Australia
That seems like a different error - maybe something strange happened to the backend.

To eliminate that part of the fault, play something from a local file (e.g. a non region encoded DVD, a video file, et c) while changing the renderer.

_________________
| Nigel Pearson, nigel@ind.tansu.com.au
| Telstra BID, Sydney, Australia
|
|"Things you own end up owning you" - Tyler, Fight Club


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 24, 2009 6:54 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
I have managed to play a video (a record of DVB-T) successfully with the default settings. These settings don't work for viewing live TV. I can't try playing a DVD because I haven't installed a DVD player yet (I want to check if DTV works before).

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 27, 2009 5:49 pm 
Offline
Joined: Wed Mar 03, 2004 7:43 pm
Posts: 743
Location: Sydney, Australia
OK. That's a start. Can I get you to look at what was being used to play back this file? (I can't remember if "internal" or mplayer/Xine is the default player). The easiest way is to press I (for Info) when it is playing. If a progress bar slides in from the bottom, it is internal. If there is some text that appears in the top right hand corner, it is mplayer. (cant remember what Xine does)


The only real difference between MythVideo using internal, and MythTV, is the OSD (on screen display) that usually pops up first thing in TV playback, so this eliminates the only thing I can think of that would be causing the glXGetProcAddress library error.

_________________
| Nigel Pearson, nigel@ind.tansu.com.au
| Telstra BID, Sydney, Australia
|
|"Things you own end up owning you" - Tyler, Fight Club


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 28, 2009 5:43 am 
Offline
Joined: Fri Nov 13, 2009 10:08 am
Posts: 6
Location: Tréglamus
Thank you for your reply.
But I eventually uninstalled Knoppmyth and replaced it by Mythbuntu, which works great (except in the first seconds for DTV but my hardware is not good and I have to buy a real graphics card with XvMC support).
But your advice might help me if I return to Knoppmyth, that I still think being quicker. Also, using a new graphics chipset may help resolve the problem.

_________________
Member of the April (www.april.org)
Watch at your CPU usage and think to BOINC


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu