View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Oct 09, 2008 9:49 am 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
When I check the backend status in MythWeb I'm seeing a bunch of red Transcodes with their status set to Errored in the job queue section. I found the following lines in /var/log/mythbackend.log but I'm not sure what to do next.
Code:
mythtranscode: motion_est_template.c:1065: epzs_motion_search_internal: Assertion `(P[3][0]>>shift) <= xmax' failed.
2008-10-09 10:58:02.929 JobQueue: Transcode Errored: Dancing With the Stars: Autodetect (exit status 0, job status was "Running")

There was also the following error a little farther up in the same file that I'm not sure about.
Code:
2008-10-09 10:28:57.728 Copying Audio while transcoding Video
strange error flushing buffer ...

I'm guessing I've changed something since transcoding was working fine. I'm just not sure what I've changed. It doesn't seem to error on all recordings. If there's any other info I need to provide just let me know.

Thanks


Last edited by chunter2 on Fri Oct 17, 2008 8:13 am, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 09, 2008 1:18 pm 
Offline
Joined: Sat Dec 24, 2005 11:33 am
Posts: 400
Location: Kitsap Peninsula, Wa., United States
Might want to include Knoppmyth version and what transcoding you are running.

I have noticed something similar although mine do not fail.

I am running KM 5.5 and this is doing an Autodetect Transcode

From /var/log/mythtv/mythbackend.log
Code:
2008-10-03 06:41:14.471 JobQueue: Transcode Starting for Knight Rider "Journey to the End of the Knight": Autodetect (1.1 GB)
2008-10-03 06:41:16.314 transcode: Transcode Starting: Knight Rider "Journey to the End of the Knight": Autodetect (1.1 GB)
2008-10-03 06:41:17.032 Using runtime prefix = /usr
2008-10-03 06:41:17.285 Empty LocalHostName.
2008-10-03 06:41:17.593 Using localhost value of mythtv
2008-10-03 06:41:33.529 New DB connection, total: 1
2008-10-03 06:41:33.797 Connected to database 'mythconverg' at host: localhost
2008-10-03 06:41:33.975 Closing DB connection named 'DBManager0'
2008-10-03 06:41:34.179 Connected to database 'mythconverg' at host: localhost
2008-10-03 06:41:34.271 Enabled verbose msgs: important
2008-10-03 06:41:34.291 New DB connection, total: 2
2008-10-03 06:41:34.343 Connected to database 'mythconverg' at host: localhost
2008-10-03 06:41:34.404 Transcoding from /myth/tv/65007_20081001175900.mpg to /myth/tv/65007_20081001175900.mpg.tmp
2008-10-03 06:41:35.531 Connecting to backend server: 192.168.123.98:6543 (try 1 of 5)
2008-10-03 06:41:35.615 Using protocol version 40
2008-10-03 06:41:35.888 MainServer::HandleAnnounce Monitor
2008-10-03 06:41:35.944 adding: mythtv as a client (events: 0)
2008-10-03 06:41:36.232 MainServer::HandleAnnounce Monitor
2008-10-03 06:41:36.254 adding: mythtv as a client (events: 1)
2008-10-03 06:41:36.452 DB Error (SetInUse):
Query was:
INSERT INTO inuseprograms  (chanid, starttime, recusage, hostname, lastupdatetime,  rechost, recdir )  VALUES  ('65007', '2008-10-01T17:59:00', 'transcoder', 'mythtv', '2008-10-03T06:41:36',  'mythtv_sbe', NULL);
Driver error was [2/1048]:
QMYSQL3: Unable to execute query
Database error was:
Column 'recdir' cannot be null

2008-10-03 06:41:36.656 AFD: Opened codec 0x81ee3c0, id(MPEG2VIDEO) type(Video)
2008-10-03 06:41:36.675 AFD: codec MP2 has 2 channels
2008-10-03 06:41:36.803 AFD: Opened codec 0x81ee810, id(MP2) type(Audio)
2008-10-03 06:41:36.935 Honoring the cutlist while transcoding
2008-10-03 06:41:36.972 Cutlist        : 0-1411,18331-22876,34666-41386,58336-64126,78316-85501,92626-98746,108451-112440
2008-10-03 06:41:37.008 Original Length: 112440 frames
2008-10-03 06:41:37.093 New Length     : 76680 frames
2008-10-03 06:41:37.224 Transcode: Looking for autodetect profile: Autodetect from 480i
2008-10-03 06:41:37.338 New DB connection, total: 3
2008-10-03 06:41:37.436 Connected to database 'mythconverg' at host: localhost
2008-10-03 06:41:37.485 Transcode: Using autodetect profile: MPEG2
2008-10-03 06:41:37.588 Switching to MPEG-2 transcoder.
2008-10-03 06:41:37.643 Opening /myth/tv/65007_20081001175900.mpg
2008-10-03 06:41:37.671 Input #0, mpeg, from '/myth/tv/65007_20081001175900.mpg':
2008-10-03 06:41:37.760   Duration: 01:02:31.4, start: 0.189289, bitrate: 2466 kb/s
2008-10-03 06:41:37.786     Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480 [PAR 8:9 DAR 4:3], 8000 kb/s, 29.97 tb(r)
2008-10-03 06:41:37.864     Stream #0.1[0x1c0]: Audio: mp2, 48000 Hz, stereo, 192 kb/s
2008-10-03 06:41:37.951 #0 PTS:00:00:00.400 Delta: 0.0ms queue: 26
2008-10-03 06:41:37.977 #1 PTS:00:00:00.381 Delta: 19.1444ms queue: 2
2008-10-03 06:41:39.742 Converting frame #0 from B to I
2008-10-03 06:41:40.102 Converting frame #1 from B to I
Mux rate: 8.33 Mbit/s
2008-10-03 06:42:18.687 Converting frame #0 from B to I
2008-10-03 06:42:18.722 Converting frame #1 from B to I
2008-10-03 06:42:29.022 Converting frame #0 from B to I
2008-10-03 06:42:29.161 Converting frame #1 from B to I
2008-10-03 06:42:57.619 Converting frame #0 from B to I
2008-10-03 06:42:57.912 Converting frame #1 from B to I
2008-10-03 06:43:11.524 Converting frame #0 from B to I
2008-10-03 06:43:11.671 Converting frame #1 from B to I
2008-10-03 06:43:53.643 Converting frame #0 from B to I
2008-10-03 06:43:53.727 Converting frame #1 from B to I
2008-10-03 06:43:55.921 mythbackend: Running housekeeping thread
2008-10-03 06:43:56.159 mythfilldatabase still running, skipping checks.
2008-10-03 06:44:06.160 Converting frame #0 from B to I
2008-10-03 06:44:06.231 Converting frame #1 from B to I
2008-10-03 06:44:40.297 Converting frame #0 from B to I
2008-10-03 06:44:40.456 Converting frame #1 from B to I
2008-10-03 06:44:56.601 Converting frame #0 from B to I
2008-10-03 06:44:56.635 Converting frame #1 from B to I
2008-10-03 06:45:17.518 Converting frame #0 from B to I
2008-10-03 06:45:17.687 Converting frame #1 from B to I
2008-10-03 06:45:30.989 Converting frame #0 from B to I
2008-10-03 06:45:31.131 Converting frame #1 from B to I
2008-10-03 06:45:54.664 Converting frame #0 from B to I
2008-10-03 06:45:54.792 Converting frame #1 from B to I
2008-10-03 06:46:01.365 Generating Keyframe Index
2008-10-03 06:46:01.538 Opening /myth/tv/65007_20081001175900.mpg.tmp
2008-10-03 06:46:01.764 Input #0, mpeg, from '/myth/tv/65007_20081001175900.mpg.tmp':
2008-10-03 06:46:01.907   Duration: 00:42:38.7, start: 0.312411, bitrate: 2234 kb/s
2008-10-03 06:46:02.033     Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480 [PAR 8:9 DAR 4:3], 8000 kb/s, 29.97 tb(r)
2008-10-03 06:46:02.142     Stream #0.1[0x1c0]: Audio: mp2, 48000 Hz, stereo, 192 kb/s
2008-10-03 06:47:55.667 Transcode Completed
2008-10-03 06:47:57.462 UPnpMedia: BuildMediaMap VIDEO scan starting in :/myth/video:
2008-10-03 06:47:58.745 Transcoding /myth/tv/65007_20081001175900.mpg done
2008-10-03 06:47:58.883 UPnpMedia: BuildMediaMap Done. Found 2 objects
2008-10-03 06:48:02.145 transcode: Transcode Finished: Knight Rider "Journey to the End of the Knight": Autodetect (681.5 MB)
2008-10-03 06:48:02.581 JobQueue: Transcode Finished: Knight Rider "Journey to the End of the Knight": Autodetect (681.5 MB)
2008-10-03 06:48:56.282 mythfilldatabase still running, skipping checks.


It completes and everything runs fine even the file is complete and works.

Thoughts?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 09, 2008 2:00 pm 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
bigbro wrote:
Might want to include Knoppmyth version and what transcoding you are running.

I'm running R5.5 and auto transcoding from mpeg2 to mpeg4.
MythWeb also says the following in the comment of the failed job.
Code:
exit status 0, job status was "Running"

I know mine doesn't complete because the file size of the recording doesn't change. I can still watch the original mpeg2 so I'm not losing recordings.

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 09, 2008 2:15 pm 
Offline
Joined: Sat Dec 24, 2005 11:33 am
Posts: 400
Location: Kitsap Peninsula, Wa., United States
what kind of settings are you using for the type of transcode?

I noticed in your log it says Autodetect. That implies it is using what ever transcoding profile you set as the "default" for your recording rule for that show.

My example was using "lossless' transcoding. it only removes my commercial cut list.

The settings you need to look at are Screen resolution of the file.
both what you capture and what you are changing it to. Also Bitrate etc.

I have had similar errors to yours in the past when I was trying to transcode something that was a lower screen setting than my transcode rule.

hth.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Oct 11, 2008 7:18 am 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
bigbro wrote:
what kind of settings are you using for the type of transcode?

I noticed in your log it says Autodetect. That implies it is using what ever transcoding profile you set as the "default" for your recording rule for that show.

I'm using transcoding to save space. My 2.2 GB mpeg2 files per hour turn into about 800 KB mpeg4 files. I'm not using loseless. I haven't touched anything in the transcoding section of myth for quite some time now. I think maybe since R5F1. Like I said before not all of them are failing. I can go into Recorded Programs in MythWeb, select a recording and click the transcode button and sometimes it will transcode properly, even ones that failed transcoding multiple times. Has anyone actually gotten the exit status 0, job status was "Running" error?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 12, 2008 4:41 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 396
Location: Fargo, ND, USA
I have for the last three years had about one show a week that can not be transcoded. They usually fail with a 0 or 235 error code. All of my failed transcodes are on ABC. I can't ever remember havening one on any other network. I haven't paid attention in 5.5 but in 27 when a transcode fails the created (error) file remains on the hard drive taking up space and has to be manually deleted. After about ten orphaned 5GB files it really starts to raise havoc on a 120GB drive. I have searched a couple of different times for transcode error code descriptions but always have come up empty. if anyone finds them point me to them.

Transcode has a wiki http://www.transcoding.org/cgi-bin/transcode

R5.5
Code:
>transcode -v
transcode v1.0.2

It appears that the latest stable release is v1.0.6 so we are 4 versions behind. it looks like Debian is the holdup here there latest is v1.0.2 to.

TVBox

_________________
TVBox
LinHES R8.4


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 14, 2008 12:07 pm 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
I did notice left over .tmp files in my /myth/tv directory. I've removed those that failed but I'm still getting errors. My failures aren't linked to a specific channel.

transcode -v gives me 1.0.6 in R5.5 so I'm guessing that's not the issue.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 15, 2008 2:39 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 396
Location: Fargo, ND, USA
chunter2 wrote:
transcode -v gives me 1.0.6 in R5.5 so I'm guessing that's not the issue.

Have you updated transcode? I have two clean auto installs of 5.5 and they both return transcode v1.0.2.

TVBox

_________________
TVBox
LinHES R8.4


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 15, 2008 5:47 am 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
TVBox wrote:
chunter2 wrote:
transcode -v gives me 1.0.6 in R5.5 so I'm guessing that's not the issue.

Have you updated transcode? I have two clean auto installs of 5.5 and they both return transcode v1.0.2.

TVBox


Mine (auto upgraded from R5F27) says this:

Code:
$ transcode -v
transcode v1.0.6rc3 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg, 2004-2008 Transcode Team

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 15, 2008 9:06 am 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
I went and checked some more systems and here's what I found.

My main box that's been upgraded every step from R5C7 to R5.5 shows this.
Code:
transcode v1.0.6 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg, 2004-2008 Transcode Team

My frontend only machine that I think was upgraded from R5F1 straight to R5.5 shows this.
Code:
transcode v1.0.2 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg

A test machine I've been trying out that was auto installed with R5.5 shows this.
Code:
transcode v1.0.2 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg

My parents machine that's been upgraded every step from R5E50 to R5.5 shows this.
Code:
transcode v1.0.6 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg, 2004-2008 Transcode Team

Looks like transcode is in /usr/bin which I don't think gets backed up or restored so it doesn't really make sense why there's different versions when all my boxes are at R5.5.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 15, 2008 9:14 am 
Offline
Joined: Fri Apr 02, 2004 10:08 am
Posts: 1637
Location: Virginia, USA
Interesting. My backend was also a clean auto-install of R5.5 and I also have v1.0.2 not 1.0.6.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 15, 2008 12:30 pm 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
Just tried 1.0.2 instead of 1.0.6 but I still get the same exit status 0 error. I'm assuming mythtranscode just passes things off to transcode. My mythtranscode's are all the same file size and date.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 16, 2008 9:24 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 396
Location: Fargo, ND, USA
What I find that is strange is that the time lines do not correlate. Transcode 1.0.6 was not released until August 11 2008. R27's iso was released Sept. 9 2007. R5.5 came out in July 8, 2008.

transcode-1.0.6 August 11, 2008,
R5.5...................July 8, 2008
transcode-1.0.5 January 27, 2008,
transcode-1.0.4 September 16, 2007
R27....................September 9, 2007
transcode-1.0.3 April 16, 2007
transcode-1.0.2 Nov 5, 2005

I think I would try a recently downloaded version of 1.0.6

TVBox

_________________
TVBox
LinHES R8.4


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 16, 2008 9:53 am 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
TVBox wrote:
I think I would try a recently downloaded version of 1.0.6

Couple questions. I downloaded the 1.0.6 source for transcode but I'm not sure what options to use to compile so that it matches the version used in R5.5.

While I was at the transcode site I noticed that it uses a bunch of libraries. I've done the update to get the flash player working in MythWeb which I think upgraded ffmeg and I've also done the apple trailers update to get that working again. I'm wondering if either of these updates would be the cause of my transcoding errors.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 16, 2008 2:36 pm 
Offline
Joined: Mon May 02, 2005 9:00 am
Posts: 172
I just found this at the bottom of dmesg.
Code:
rrd_Load.pl[4345]: segfault at 0000010c eip b7c5b0a1 esp bfac6d8c error 6
mythtranscode[4234] general protection eip:b71e5802 esp:bf8220f4 error:c35c
mythtranscode[4386] general protection eip:b7217802 esp:bf84c904 error:c35c
mythtranscode[4391] general protection eip:b71aa802 esp:bfaa65a4 error:c35c
mythtranscode[4848] general protection eip:b7181802 esp:bfde50c4 error:c35c

Not sure what it means though.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu