View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Dec 18, 2008 9:23 am 
Offline
Joined: Sun Dec 31, 2006 10:55 am
Posts: 66
Hi all,

I recently migrated from an older backend machine running R5E50 to new hardware running R5.5. My migration had a few rough spots, but I was able to work through them with the help of this forum.

In general, the new system seems to work. However I now have a show that consistently gets recorded badly. There's no preview image from MythWeb. And when I try to play any recording of this show, I get nothing but grey blobs. Often the front end (which I run on a Mac) hangs trying to play these recordings.

Prior to the update to R5.5, the same show recorded fine. Note that I didn't change anything in the recording schedule for this show after the migration.

The first thing I tried was recreating my tuner card definitions and doing a fresh channel scan. My tuner is an HDHomeRun, so I also updated to their latest firmware. But I still get the bad recordings.

I've tried manually going to the same channel via live TV and I don't see a problem. But I haven't tried this at the time of the problematic show because I'm not at home when it records. Note that the show is on sub-channel 1 of our PBS affiliate, which has something like 5 sub-channels.

There are definitely errors in the mythbackend.log that correspond to the recording problem:

Code:
2008-12-16 14:59:41.851 Started recording: The NewsHour With Jim Lehrer: channel 1091 on cardid 1, sourceid 1
2008-12-16 15:08:00.410 MainServer::HandleAnnounce Monitor
2008-12-16 15:08:00.413 adding: mythtv as a client (events: 0)
2008-12-16 15:08:01.302 Using runtime prefix = /usr
2008-12-16 15:08:01.306 Empty LocalHostName.
2008-12-16 15:08:01.314 Using localhost value of mythtv
2008-12-16 15:08:01.357 New DB connection, total: 1
2008-12-16 15:08:01.367 Connected to database 'mythconverg' at host: localhost
2008-12-16 15:08:01.383 Closing DB connection named 'DBManager0'
2008-12-16 15:08:01.384 Connected to database 'mythconverg' at host: localhost
2008-12-16 15:08:01.389 New DB connection, total: 2
2008-12-16 15:08:01.391 Connected to database 'mythconverg' at host: localhost
2008-12-16 15:08:01.397 Current Schema Version: 1214
2008-12-16 15:08:01.491 Tuning to 'MPEG Program 1' pnum: 0x1 without CRC check on PMT
2008-12-16 15:08:01.508 mpegts_read_header: could not find any PMT's
2008-12-16 15:08:01.509 AFD Error: avformat err(-1) on av_open_input_file call.
2008-12-16 15:08:01.510 Couldn't open decoder for: /myth/tv/1091_20081216150000.mpg
2008-12-16 15:08:01.511 NVP, Error: Could not open file for preview.
2008-12-16 15:08:01.516 Preview Error: Run() file not local: '/myth/tv/1091_20081216150000.mpg'
2008-12-16 15:08:01.528 Preview Error: Preview process not ok.
         fileinfo(/myth/tv/1091_20081216150000.mpg.png) exists: 0 readable: 0 size: 0
2008-12-16 15:08:01.531 MainServer: Failed to make preview image.


For comparison, here are the log entries for a successful recording of a different show on a different channel:
Code:
2008-12-16 23:34:41.733 Started recording: Late Show With David Letterman: channel 1051 on cardid 1, sourceid 1
2008-12-16 23:48:11.587 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2008-12-17 00:02:10.382 UPnpMedia: BuildMediaMap VIDEO scan starting in :/myth/video:
2008-12-17 00:02:10.544 UPnpMedia: BuildMediaMap Done. Found 7 objects
2008-12-17 00:03:11.860 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2008-12-17 00:17:03.015 MainServer::HandleAnnounce Monitor
2008-12-17 00:17:03.029 adding: mythtv as a client (events: 0)
2008-12-17 00:18:11.954 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2008-12-17 00:32:13.596 UPnpMedia: BuildMediaMap VIDEO scan starting in :/myth/video:
2008-12-17 00:32:13.658 UPnpMedia: BuildMediaMap Done. Found 7 objects
2008-12-17 00:33:12.050 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2008-12-17 00:37:20.576 TVRec(1): Changing from RecordingOnly to None
2008-12-17 00:37:20.620 Finished recording Late Show With David Letterman: channel 1051
2008-12-17 00:37:20.675 Reschedule requested for id 0.
2008-12-17 00:37:20.773 Finished recording Late Show With David Letterman: channel 1051


Any thoughts on how to resolve this problem?

_________________
Best,

Allen Cronce


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 18, 2008 2:08 pm 
Offline
Joined: Sun Dec 31, 2006 10:55 am
Posts: 66
I guess I should have done a broader search. Looks like this is a known problem:

http://www.gossamer-threads.com/lists/m ... its/346930

Sure enough, I'm also trying to record from KQED 9.1 when I see the problem.

_________________
Best,

Allen Cronce


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu