View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 4 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Dec 14, 2009 7:27 am 
Offline
Joined: Fri Mar 31, 2006 2:06 am
Posts: 25
Hello,

Trying to get a HD-channel to work on my R5.5 I decided to fetch the latest v4l-dvb, build it and install it. Afterwards my Technotrend C-1501 is not recognized by any of the modules that loads.

The card can be seen with lspci so its not dead (and it worked before the v4l-update).

My trouble is that I cannot figure out exactly which modules to load and the correct order of loading the modules.

As a result the card is not recognized and there are no /dev/dvb devices.

I've built V4l with support for saa7146 and most of the Philips SAA/TDA-components.

I get lots of "unknown symbol" in messages/dmesg when trying to load the newly build modules but I dont know what to look for in order to fix this.
Googling taught me that "unknown symbol" might be because I've somehow mixed old and new drivers, but how do I resort this ? Is it necessary to delete all the drivers from the kernels driver-path ?
Or is there some other way to "start over" from scratch (besides reinstalling the whole thing).

I also tried "apt-get install --reinstall v4l-dvb" but it did not make any difference (probably because of mismatch between my own v4l-build-experiments and the apt-version).

Any input on this would be highly appreciated ! :)

Maybe I can make the R5.5 rescan and recognize my card with some "stock"-drivers from R5.5 ?


Last edited by unkle on Fri Dec 18, 2009 12:55 pm, edited 2 times in total.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 14, 2009 11:12 am 
Offline
Joined: Thu Sep 07, 2006 11:20 am
Posts: 389
My R5.5 HOWTO for the HD-PVR covers building v4l-dvb and may be of some help. However, it sounds like you have succeeded in building v4l, but have configuration troubles.

http://www.psicat.com/Nathan/KnoppMyth_HDPVR.html


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 14, 2009 8:28 pm 
Offline
Joined: Fri Mar 31, 2006 2:06 am
Posts: 25
nharris wrote:
My R5.5 HOWTO for the HD-PVR covers building v4l-dvb and may be of some help. However, it sounds like you have succeeded in building v4l, but have configuration troubles.
http://www.psicat.com/Nathan/KnoppMyth_HDPVR.html


Yes, I've build v4l succesfully but thankyou for the excellent guide (and the references at the bottom is a great feature) :)

I lost track of where I were so I logged into the box today and did a "make" on v4l-dvb without making clean first. Now this was output:
Code:
Kernel build directory is /lib/modules/2.6.23-chw-4/build
make -C /lib/modules/2.6.23-chw-4/build SUBDIRS=/home/dte/v4l-dvb/v4l  modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.23-chw-4'
  Building modules, stage 2.
  MODPOST 96 modules
WARNING: "ir_input_register" [/home/dte/v4l-dvb/v4l/saa7134.ko] undefined!
WARNING: "ir_input_unregister" [/home/dte/v4l-dvb/v4l/saa7134.ko] undefined!
WARNING: "ir_input_register" [/home/dte/v4l-dvb/v4l/ir-kbd-i2c.ko] undefined!
WARNING: "ir_input_unregister" [/home/dte/v4l-dvb/v4l/ir-kbd-i2c.ko] undefined!
WARNING: "ir_core_debug" [/home/dte/v4l-dvb/v4l/ir-common.ko] undefined!
WARNING: "ir_g_keycode_from_table" [/home/dte/v4l-dvb/v4l/ir-common.ko] undefined!
WARNING: "ir_input_register" [/home/dte/v4l-dvb/v4l/budget-ci.ko] undefined!
WARNING: "ir_input_unregister" [/home/dte/v4l-dvb/v4l/budget-ci.ko] undefined!
WARNING: "ir_input_register" [/home/dte/v4l-dvb/v4l/bttv.ko] undefined!
WARNING: "ir_input_unregister" [/home/dte/v4l-dvb/v4l/bttv.ko] undefined!
make[2]: Leaving directory `/usr/src/linux-headers-2.6.23-chw-4'
./scripts/rmmod.pl check
found 96 modules
make[1]: Leaving directory `/home/dte/v4l-dvb/v4l'


Some warnings relating to the reg. and unreg. of the modules I guess.

Although it builds and it is "just" warnings, not errors, it made me curious.
I remember at one attempt the modprobe coughed upon the IR-common module not being able to load. I really dont know much about modules and builds but I think this might have to do with the modules' dependencies on other modules (?) And so the functionality of saa7146 and possibly other modules as well might fail because there is no IR-common. Maybe ?
(this might just be fixed with a make clean && make, I will try that)

If someone would give me some pointers on how to clean up this mess I've made of the drivers/modules I think I would be able to restore the system. But it might be a fat chance avoiding complete reinstall ;)

I've got a bad feeling about just deleting files from
../kernel/drivers/media/dvb/ttpci/
and
../kernel/drivers/media/common/

So how to clean up ?
And / or
How can I figure out exactly which modules are needed ? (is this even possible for someone who is not familiar with this architecture?)

Maybe someone with a similar capture-card would be kind and send me the binaries for the different "original" .ko's from a R5.5 ? (bttv, saa7146, budget, ir-common, etc)

Thanks for listening :D


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 18, 2009 12:52 pm 
Offline
Joined: Fri Mar 31, 2006 2:06 am
Posts: 25
I should probably have thought of this before (but the architecture is still a bit confusing to me).

I found a copy of the source in:
/usr/src/v4l
which had some of the file-dates for the modules that matched "last known working state" so to speak.

I cd'ed to /usr/src/v4l/v4l-dvb/ and did a make and make install and then reboot with this beloved result from dmesg:
Code:
saa7146: register extension 'budget_ci dvb'.
saa7146: found saa7146 @ mem f8c9e000 (revision 1, irq 10) (0x13c2,0x101a).
saa7146 (0): dma buffer size 192512
DVB: registering new adapter (TT-Budget C-1501 PCI)
input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input5
DVB: registering adapter 0 frontend 0 (Philips TDA10023 DVB-C)...


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Baidu [Spider] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu