View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 4 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Jan 10, 2010 11:54 am 
Joined: Wed Mar 02, 2005 1:34 pm
Posts: 106
Location: London, UK
Just upgraded to R 6.01 and added a new Cyberlink USB remote.

The directional buttons and the OK button on the remote work but none of the other buttons do (my remote is not listed in the options), so I used mceusb from the remotes list.

I have been trying to set teh remote up using the instructions here: (this is for the same remote). I have added my own lircd.conf and lircrc files and linked to them from /etc/lircd.conf and /etc/lircrc, the instructions reference /etc/lirc/hardware.conf but this doesn't seem to exist in R6 any more?

Anyway with the above changes the remote still doesn't work properly I've tried lsmod | grep lirc and it doesn't list anything which is making me think lirc isn't running.
sv restart lircd
ok: run: lircd: (pid 5071) 0s

which is confusing me even more. Any assistance much appreciated!

 Post subject:
PostPosted: Mon Jan 11, 2010 2:45 am 
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Don't know if this of any use to you, but I was having problems with my remote using the onboard dongle on a Nova-T card. (See here).

There may / may not be of any help within it, however there are a few ideas you might want to look at even if it's just following the link therein to the arch wiki about setting up ir remotes.

Not a solution by any stretch, but hope it helps.


Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)

 Post subject:
PostPosted: Mon Jan 11, 2010 7:06 am 
Joined: Wed Jul 25, 2007 7:56 pm
Posts: 103
Location: Arlington, VA, USA
To make sure I understand, now the directional buttons and OK button no longer work? Do you happen to know what /etc/lircd.conf and /etc/lircrc were pointing to before you changed them to mceusb?

$ lsmod | grep lirc
should definitely give you some output. Does it say anything after you restart the daemon? What about after a reboot?

Also try
$ dmesg | grep lirc
to see any boot messages that are relevant.

Possibly a relevant link:

You may also want to browse around /usr/MythVantage/templates/remotes and see if anything sounds relevant enough to try?

MBE/FE: R6, P4 2.8 GHz/2 GB/2 TB, GeForce 6200 512 MB, PVR-150, Cisco RNG-100 cable box
FE: R6, P4 2.0 GHz/1 GB, GeForce4 MX 420 64 MB, diskless netboot

 Post subject:
PostPosted: Mon Jan 11, 2010 7:09 am 
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
If even one button works on your remote then lirc is running.

messages go from the the input to a driver then to lircd which serves myth and irexec (and others).

Start at the bottom and see if you have the driver working:
turn off lircd:
sv stop lircd

Then use mode2:
you may have to specificy the device such as:
mode2 --device=/dev/lirc0

This will show you all of the raw IR codes coming in through the driver. If you have the right driver AND the remote is sending codes then you will see the IR code for each button press.

If you see everything here then move up to check lircd as follows:
sv start lircd

irw attaches in like mythtv to lircd and will tell you what the remapped key presses are. This mapping is defined in lircd.conf (usually on /etc/lircd.conf or /etc/lirc/lircd.conf) and it takes the raw IR code and gives it a label such as "ChannelUp". If you see some labels are missing vs your mode2 test then the issue lies with the your lircd.conf file.

BTW, what remote are you using.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu