LinHES Forums

No audio playback but hardware seems detected ok
Page 1 of 1

Author:  yaplej [ Sat Jul 10, 2010 3:39 pm ]
Post subject:  No audio playback but hardware seems detected ok

I am running R6.03.00 and I cannot get any audio playback.

I ran alsaconf it detected the correct audio card. Ali M5455 same device is output from lspci.
00:04.0 Multimedia audio controller: ALi Corporation M5455 PCI AC-Link Controller Audio Device (rev 20)

I also see the correct device from aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: M5455 [ALi M5455], device 0: Intel ICH [ALi M5455]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: M5455 [ALi M5455], device 2: Intel ICH - IEC958 [ALi M5455 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I checked alsamixer made sure volume levels were ok. I tried to play a test sound using aplay /usr/shared/sounds/alsa/Front_Center.wav but no sound.


Author:  yaplej [ Sat Jul 10, 2010 3:59 pm ]
Post subject: 

For what its worth I disabled the onboard sound and put in a soundblaster then did those same steps.
aplay /usr/shared/sounds/alsa/Front_Center.wav

It played fine. Then tested TV and DVD both worked. The only issue is I cannot get the alsamixer settings to save after a reboot.

Tried "alsactl store" but it didnt work.

Author:  Girkers [ Sun Jul 11, 2010 7:02 am ]
Post subject: 


I don't mean to insult you, but have you tried the alsactl store as root?

Just a thought

Author:  yaplej [ Sun Jul 11, 2010 7:03 pm ]
Post subject: 

No insult taken but yes I have tried alsactl store as root. Also from an ALT+X shell as the myth user.

I was more interested in why the onboard ALi M5455 audio didnt work. Everything seemed to be detected correctly and setup correctly too. Kind of wishing for a known support issue. If it should work then its going to bug me to no end.

Author:  Girkers [ Mon Jul 12, 2010 1:54 am ]
Post subject: 

Just did a quick google and whilst these are not specific to LinHES, they are to ARCH so hopefully they may help you. Have a look at:

I just thought to look at my system and neither of these post are appropriate. I did find in /etc/rc.d/ a file called alsa which is the script that does the restoration of the sound settings. Acording to functions in the /etc/rc.d/ folder and called during the boot process.

Sorry can't be much help, just really food for thought.

Author:  yaplej [ Fri Jul 16, 2010 4:32 pm ]
Post subject: 

Adding the alsa daemon to /etc/rc.conf did not help.

I added "alsactl restore" to my /etc/rc.local that did not help either. This box is a diskless frontend so I wonder if its not mounting the nfs share quick enough before it tried to run the scripts.

Manually running alsactl restore does work or running the /etc/rc.local script manually works too.

Author:  brfransen [ Sat Jul 17, 2010 7:29 pm ]
Post subject: 

The startup script location and init system that LinHES uses is different than Arch. LinHES uses runit for starting services and /etc/runit/1.local is the equivalent of /etc/rc.local. See this wiki page.

The alsactl restore should be run on boot by runit if the alsa-utils is set to run. To enable it run:
sudo alsa-utils

Author:  yaplej [ Thu Aug 05, 2010 9:15 pm ]
Post subject: 

Thanks so much for that. At least with the soundblaster card I now have sound when the system boots.

Still wondering why it did not work with the original onbard sound but maybe I will have time later to dink with that.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group