View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Apr 11, 2006 4:52 am 
Offline
Joined: Wed May 12, 2004 1:13 am
Posts: 82
Location: Germany
Whats about the ivtv teletext driver?

is there a possibility to import channel information with the pvr card meanwhile?


Last edited by wulf on Mon Nov 08, 2010 3:57 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 11, 2006 6:02 am 
Offline
Joined: Mon Feb 23, 2004 1:08 am
Posts: 91
Location: Switzerland
nxtvepg works with a PVR350

http://nxtvepg.sourceforge.net/

You export to XMLTV and use mythfilldatabase in manual mode to import.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 11, 2006 6:51 am 
Offline
Joined: Wed May 12, 2004 1:13 am
Posts: 82
Location: Germany
Thats great,

thats what i wanted to hear...
do i have to keep an eye on something special?

__________________


So now nextview doesn`t find any provider.
It recognizes the pvr350, than i select tuner0 as the input and he than scans all frequenzies without finding any channel.

What to do now?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 3:57 pm 
Offline
Joined: Wed May 12, 2004 1:13 am
Posts: 82
Location: Germany
this works, but what to do if I want to automate this?

Searched around and found some HowTos.
But it wont do it the way it should!

Here is what I did so far:

I created a script in /home/mythtv/epg that contains the following:

Code:
#!/bin/bash
# Nextview EPG Daten Sammeln

su mythtv -c "/usr/bin/nxtvepgd -dbdir nxtvdb -rcfile /home/mythtv/.nxtvepgrc -daemon -acqonce full -nodetach"
su mythtv -c "/usr/bin/nxtvepgd -dbdir nxtvdb -rcfile /home/mythtv/.nxtvepgrc -dump xml5ltz -prov merged > /home/mythtv/epg/nxtvepg.xml"
su mythtv -c "mythfilldatabase --file 2 /home/mythtv/epg/nxtvepg.xml"


And made the script executable, but if I call the script from the commandline it asks for the myhthv password, but how can I get around that?
When the password is entered everything works.

So the next step would be to autostart this after startup.

I did that by putting it into the /home/mythtv/.fluxbox/apps
by adding the highlighted line:

Code:
[startup]  {/home/mythtv/epg/nxtvepg-aquire}


so it looks like this:

Code:
[startup]  {feh --bg-scale ~/.fluxbox/wallpaper.png}
[startup]  {/usr/LH/bin/LinHES-run}
[startup]  {/home/mythtv/epg/nxtvepg-aquire}
[startup]  {/home/mythtv/bin/pms-linux-beta/PMS.sh}
[app] (name=xterm) (class=XTerm)
  [Alpha]   {248 229}
[end]




But it doesnt start itself.

What did I miss? :?:

_________________
LinHES R6 on:
MSI K8T Neo2-F & Athlon-64 3200 - 4096 MB RAM
GeForce 8600GT
Mystique CaBiX-C2, PVR-350, PVR-250, Terratec CinergyT² & DBOX2


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 9:54 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Just off the top of my head, the environment setup (PATH, etc.) may be different than you're assuming. This is one of the most common reasons for scripts which work when run interactively to not work when run automatically.

Try adding some debugging output to your script. For some ideas see /usr/LH/bin/library.sh. You can also include the following two lines in your script and use it directly:
Code:
DEBUG=log,env,set,trace
. /usr/LH/bin/library.sh


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Baidu [Spider] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu