LinHES Forums

xorg.conf Help
Page 1 of 1

Author:  foner [ Tue Apr 06, 2010 1:22 am ]
Post subject:  xorg.conf Help

I'm setting up a new Myth box using R6 (R6.02.00). The install went through without a hitch on a Mac Mini (Late 2006 model, Intel GMA 950, upgraded to a Core 2 Duo 2 GHz, 2 GB RAM, and 500 GB HD).

I'm connecting it to my CRT HDTV (Sony KV-30HS420) which claims to have 1080i as the native resolution. When I connect the Mac Mini via VGA (DVI out --> DVI to VGA adapter --> VGA to RCA adapter (left over from last box) --> RCA in), it works fine.

When I connect it via DVI (directly via a DVI to HDMI cable), it goes through the bootup process, but once it starts to load X, the screen goes black.

I went in and edited xorg.conf to add the 1080i resolution (1920×1080), but it didn't like it. When I restarted it, it was again fine until loading X. This time the screen came up, but was unreadable. I'm guessing the refresh rate is off or something, as the screen was split weird, was flickering constantly, and generally looked terrible.

After doing some more research, I thought I would try getting the EDID data from the tv. I followed the instructions here ( and ran the following command:

startx -- -logverbose 6

In response, I get the following:

xauth:  creating new authority file /home/carl/.serverauth.14356
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
xinit:  Server error.

I'm not quite sure where to go next. If anyone can help with getting the EDID data or can point me in another direction to go, it would be greatly appreciated.



Author:  foner [ Wed Apr 07, 2010 12:13 am ]
Post subject: 


So I connected another computer to the TV, and it saw it as an external monitor with the following specs: 1280x720 @ 60 Hz.

I found the gtf command and was able to generate the following modeline:

  # 1280x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 74.48 MHz
  Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync

So I added that modeline, but it didn't work. Same issues as before. I tried a few different modelines from the modeline database, but they didn't help either. I had been doing it at a depth of 24, so I tried it at 16. Still no help.

Under 16 depth it has listed "virtual 800 600", so I'm assuming that's the resolution it's picking up. I tried commenting that line out, and sure enough it had the same issues as before.

All this testing was done via the aforementioned VGA connection. Whenever I try the DVI-->HDMI connection, right after it loads GRUB, it gives the following error:

Undefined video mode number 314:

There are some options beneath it. None of them get anywhere. Waiting or pressing space to continue lets it go through the bootup process, but as soon as it tries to load X, the screen goes black. There's also an option for seeing the available video modes. If I choose that, it gets stuck, and I can't choose any of the available options or anything else for that matter.

Any ideas anyone has on making any further progress would be much appreciated.



Author:  uteck [ Wed Apr 07, 2010 5:38 am ]
Post subject: 

Try adding this in the "Screen" section;
Option "TVStandard" "HD1080i"

Author:  foner [ Thu Apr 08, 2010 1:47 am ]
Post subject: 

uteck wrote:
Try adding this in the "Screen" section;
Option "TVStandard" "HD1080i"

Thanks for the suggestion. I tried that, but still same problem as before.

My next idea was that I tried booting up off of the Live CD and went into debug mode. Lo and behold, it managed to show an image over the DVI-HDMI connection. So I copied the xorg.conf file from the Live CD and put it onto the installed system. It works.

The picture looks a lot better, but I'm not sure how to tell what resolution it's picking up.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group