LinHES Forums

Knoppmyth 5.5 > 6.01 experiences and questions
Page 1 of 1

Author:  luxluthor [ Mon Jun 14, 2010 5:40 am ]
Post subject:  Knoppmyth 5.5 > 6.01 experiences and questions

I went from 5.5 to 6.01, and after some fixups, it seems to be working. Also below are some notes of my upgrade experience, possibly helpful to someone else.

The upgrade basically worked, but a few basic things broke, which I pulled my hair out, but then got woking again. I think it will be better next upgrade!

1. Does a pacman -Syu update from the 6.01 to 6.03 ? or just update the 6.01 install? i.e., is there a 6.01 'profile' which knows which versions and updated versions belong to it?

2. pacman -Syu reports errors, what do I do about them? They are:
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
mythtv: /usr/share/mythtv/themes/default/controls-ui.xml exists in filesystem
nvidia-96xx-utils: /usr/lib/ exists in filesystem

Is this a bug that the update wants to overwrite files? pacman says:
/usr/share/mythtv/themes/default/controls-ui.xml is owned by mythcontrols 0.21-4
error: No package owns /usr/lib/

Notes are below.

Installer feedback:
I was using eht1, not eth0, and this confused me and the installer. Eventually got notworking networking working.

My mistakes were:

I almost missed the second place to choose upgrade. I missed the creation of an additional account, besides root and mythtv, so I had to add it later, and restore its files manually.

Do note: SOME THINGS ARE USING TCP WRAPPERS!! Some networks are configured to work, others must be added in Tcp wrappers to get things working, like ssh.

Linhes 6.01 < use 6.01 from Knoppmyth 5.5 as mysql db is the same, so one can go back to 5.5 if problems arise.
download iso; check md5 hash; carefully, slowly, burn iso onto cdrom
optimize check mysql, no corruption please. (Does backup do this?)
purge some files from the save list, like:
The upgrade ... 28Brief.29
Post Upgrade
ip not working; it tried to change ethernet sockets on motherboard
figured I wanted eth1, eth0 does not work
webmyth working!
got webmin working
no ssh, ? using tcpwrappers!!!
no samba
no vlc
some myth modules not working, eg weather,\

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group