View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 47 posts ] 
Go to page 1, 2, 3, 4  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Dec 07, 2009 11:26 am 
Offline
Joined: Thu Sep 07, 2006 11:20 am
Posts: 389
The LinHES testing package repo has moved over to MythTV 0.22-fixes as the standard mythtv package.

Before following the instructions in this post, make sure you are ready to run and test the non-stable development branch of LinHES. If not, stop here and do not continue.

First, you need to make sure your /etc/pacman.conf points to the proper place.

Code:
#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here.
#   - local/custom mirrors can be added here or in separate files
#
#[core]
#Server = http://knoppmyth.net/repo/i686/core

#[extra]
#Server = http://knoppmyth.net/repo/i686/extra


[core-testing]
Server = http://knoppmyth.net/repo/i686/core-testing

[extra-testing]
Server = http://knoppmyth.net/repo/i686/extra-testing


Stop everything:
Code:
sudo sv stop frontend
sudo sv stop mythbackend
sudo killall mythfrontend
sudo killall xinit


Remove old packages:
Code:
sudo pacman -R mythcontrols mythsmolt mythstream mythappletrailers
sudo pacman -R mythtv-svn mythtv-extras-svn
sudo pacman -Rd vdpinfo


Install new packages:
Code:
sudo pacman -Syu
sudo pacman -S mythtv
sudo pacman -S morethemes mytharchive mythbrowser mythflix  mythgallery mythgame mythmovies mythmusic mythnews myththemes mythvideo mythweather mythweb mythzoneminder
sudo pacman -S mythappletrailers
sudo cp /usr/share/mythtv/is.xml /usr/share/mythtv/themes/defaultmenu


If you have an NVIDIA video card:
Code:
sudo pacman -S vdpauinfo


If you have a HD-PVR:
Code:
sudo pacman -Sf v4l-dvb


If this is your first time with 0.22, you need to run mythtv-setup.
Code:
mythtv-setup


Start up everything again.
Code:
sudo sv start mythbackend
sudo sv start frontend


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 1:13 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Great job, nh! Did you guys chose to go with the dummy vdpau package for those of us with out dated nvidia hardware?

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 1:23 pm 
Offline
Joined: Thu Sep 07, 2006 11:20 am
Posts: 389
Yes, but the libvdpau package not a dummy. It's the actual vdpau shared libraries. They have been separated from the NVIDIA drivers.

The 0.22 mythtv package depends on and compiles against libvdpau. Everything should work fine (sans VDPAU acceleration) even if you do not have an NVIDIA graphics card. In theory other graphic card manufacturers could choose to support VDPAU in the future.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 4:53 pm 
Offline
Joined: Fri Apr 02, 2004 10:08 am
Posts: 1637
Location: Virginia, USA
Thanks for the thorough instructions--everything went smoothly.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 5:30 pm 
Offline
Joined: Sun Sep 25, 2005 3:50 pm
Posts: 1013
Location: Los Angeles
The neon-wide theme is causing my frontend to be unhappy...

Code:
2009-12-07 14:46:07.085 Loading window theme from /usr/share/mythtv/themes/neon-wide/menu-ui.xml
2009-12-07 14:46:07.118 Theme error: Unknown tag in font
Type: 'size:small'
Name: ''
Line: 12
2009-12-07 14:46:07.121 Theme error: Unknown widget type
Type: 'color'
Name: ''
Line: 18
2009-12-07 14:46:07.197 Error parsing: /usr/share/mythtv/themes/defaultmenu//mainmenu.xml
at line: 21  column: 50 msg: tag mismatch
2009-12-07 14:46:07.197 Couldn't find mainmenu.xml for theme 'neon-wide'
2009-12-07 14:46:19.384 Overriding broken theme 'neon-wide' with 'Terra'

Removing lines 12,13 & 18 from menu-ui.xml and remove the "junk" characters from /usr/share/mythtv/themes/defaultmenu/mainmenu.xml make it happy again.

_________________
Mike
My Hardware Profile


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 6:13 pm 
Offline
Joined: Sun Sep 25, 2005 3:50 pm
Posts: 1013
Location: Los Angeles
mihanson wrote:
The neon-wide theme is causing my frontend to be unhappy...


Got shot down on mythtv trac as "won't fix" as this theme is currently unsupported.

Nathan: Can you include the "beta" Retro-wide theme?
http://www.gossamer-threads.com/lists/mythtv/users/410271#410271

I just loaded it up and it seems pretty stable.

_________________
Mike
My Hardware Profile


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 07, 2009 6:41 pm 
Offline
Joined: Tue Mar 22, 2005 9:18 pm
Posts: 1392
Location: Brisbane, Queensland, Australia
Just got a couple of faults when installing all the add ons:

Code:
(13/21) installing mythweb                          [##################################################################################################################################################################################] 100%
You must create a symlink from /home/httpd/html/mythweb/video_dir
to your MythTV recordings directory. Don't forget to change the
permissions so that the webserver can read those files and create
thumbnails.
(14/21) installing perl-php-serialization           [##################################################################################################################################################################################] 100%
(15/21) installing perl-unicode-map                 [##################################################################################################################################################################################] 100%
(16/21) installing perl-time-modules                [##################################################################################################################################################################################] 100%
warning: directory permissions differ on usr/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/lib/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/share/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/share/man/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/share/man/man3/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/lib/perl5/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/lib/perl5/site_perl/
filesystem: 755  package: 2755
warning: directory permissions differ on usr/lib/perl5/site_perl/current/
filesystem: 755  package: 2755
(17/21) installing perl-astro-suntime               [##################################################################################################################################################################################] 100%
(18/21) installing perl-device-serialport           [##################################################################################################################################################################################] 100%
(19/21) installing perl-x10                         [##################################################################################################################################################################################] 100%

(20/21) installing zoneminder                       [##################################################################################################################################################################################] 100%
Note:
==> mythtv has been defined in /etc/zm.conf as user and password for
==> The zoneminder (zm) database
==> To initialize the ZoneMinder database run (as root)
==> /usr/lib/zm/bin/zminit

==> To raise the limit on shared memory for zoneminder
==> add these lines to /etc/sysctl.conf
==> kernel.shmall = 134217728
==> kernel.shmmax = 134217728
error: scriptlet failed to execute correctly
(21/21) installing mythzoneminder                   [##################################################################################################################################################################################] 100%


Just thought I would let you know

_________________
Girkers


Top
 Profile  
 
 Post subject:
PostPosted: Tue Dec 08, 2009 7:09 am 
Offline
Joined: Thu Sep 07, 2006 11:20 am
Posts: 389
Girkers,

Nothing too bad there (just warnings). I'm not sure about the "perl-time-modules" package. Maybe Cecil can take a look at that. You need to be willing and able to setup and configure zoneminder by hand if you want to use it. It's not too hard really (but I don't currently use it).

-Nathan


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 09, 2009 10:56 am 
Offline
Joined: Fri Jun 23, 2006 10:57 am
Posts: 106
Just want to report that this update worked fine on my systems that have been running R6/mythtv-svn for several months now. Plus worked fine on a family members new install.

Thanks for all the hard work Nathan.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 10, 2009 12:27 am 
Offline
Joined: Thu Apr 03, 2008 11:42 pm
Posts: 114
Location: Calgary, Canada
Installed it this evening (upgrading from mythtv-svn), seems to be working fine.

Had one minor glitch on the install: During the -Syu I got a bunch of errors about module files owned by both the kernel and v4l-dvb. I removed my existing v4l-dvb (pacman -R v4l-dvb) and retried and then the rest went smoothly.

I shall echo the thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 11, 2009 5:32 pm 
Offline
Joined: Sun Feb 26, 2006 11:46 am
Posts: 67
I gave it a whirl, and it looks pretty good. One big change that'll take some getting used to is when I delete the last recording of a title, it goes clear back to "All Programs" instead of just the next one in the list.


Top
 Profile  
 
 Post subject: Small problem...
PostPosted: Fri Dec 11, 2009 7:34 pm 
Offline
Joined: Thu Nov 10, 2005 8:25 am
Posts: 6
sudo pacman -S vdpauinfo
resolving dependencies...
looking for inter-conflicts...
:: libvdpau conflicts with nvidia-utils. Remove nvidia-utils? [Y/n] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libvdpau: conflicts with nvidia-utils

I'm looking over
http://bbs.archlinux.org/viewtopic.php?id=85427 to see if there is any relevance.

Has anybody else run into this?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 11, 2009 11:23 pm 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
tfm55x, the reason this is happening is because it's conflicting with the newer Nvidia drivers Do a manual uninstall of nvidia nvidia-utils and vdpauinfo

pacman -Rd nvidia nvidia-utils vdpauinfo

do a pacman -Syu (do all the updates)

then manually reinstall nvidia which should pcik up nvidia-utils and vdpauinfo.

Should get you taken care of.

I'm assuming you follwed the instructions about removing the .22 -svn packages (under Remove old packages) already and you are using the testing repositories.

_________________
Knoppmyth 7.02 Kernel 2.6.39-LINHES
[MBE] SilverStone LC-10 HTPC Case, Asus M2NPV-VM, AMD X2 4200+, 1G RAM, Nvidia 9500 PCIe, PVR500 and a HD-PVR - Rockin VDPAU


Top
 Profile  
 
PostPosted: Sun Dec 13, 2009 2:24 pm 
Offline
Joined: Sun Nov 19, 2006 8:15 am
Posts: 5
Location: North Carolina
I started with a clean install from a R6.01 CD. Everything went fine up to:

Code:
sudo pacman -S morethemes mytharchive mythbrowser mythflix  mythgallery mythgame mythmovies mythmusic mythnews myththemes mythvideo mythweather mythweb mythzoneminder


None of the packages installed with the typical error being'

Quote:
morethemes package not found, searching for group...
error: 'morethemes': not found in sync db


mythappletrailers DID install; vdpauinfo did not.

Fearing I was going to have to reinstall anyway, I continued. When I finished, I still had a working FE/BE machine. I'm not sure what it is, though.

Now when I try:
Code:
pacman -Syu


I get:
Quote:
:: Synchronizing package databases...
error: failed retrieving file 'core-testing.db.tar.gz' from knoppmyth.net : Not Found
error: failed to update core-testing (Not Found)
extra-testing is up to date
:: Starting full system upgrade...
warning: gtk2: local (2.16.1-6) is newer than extra-testing (2.14.6-1)
warning: pygobject: local (2.16.0-1) is newer than extra-testing (2.15.4-2)
warning: pygtk: local (2.14.1-1) is newer than extra-testing (2.14.0-1)
local database is up to date


So I really don't know what I have. Since my old FEs can still talk to the database, I suspect it is not 0.22.

Any suggestions?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 13, 2009 2:35 pm 
Offline
Joined: Thu Nov 10, 2005 8:25 am
Posts: 6
barkman, I am upgrading my 2 year-old 0.21 box, and am going through this process as well. One thing I realized I did wrong (from my last post) was that I didn't comment out both the tag and the url for both the [core] and [extras] section of my /etc/pacman.conf:

#[core] <--- I omitted the hash on this line
#Server = http://knoppmyth.net/repo/i686/core

#[extra] <--- I omitted the hash on this line
#Server = http://knoppmyth.net/repo/i686/extra


[core-testing]
Server = http://knoppmyth.net/repo/i686/core-testing

[extra-testing]
Server = http://knoppmyth.net/repo/i686/extra-testing

I was having results similar to what you're experiencing. Just a suggestion, as your mileage may vary.

Also I had a libgl conflict when I tried to install vdpauinfo

Per http://bbs.archlinux.org/viewtopic.php?id=60823 I did a pacman -Rd on libgl, and vdpauinfo installed.

Also, am having to fix my database per :

http://www.mythtv.org/wiki/Fixing_Corru ... ation_file


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 47 posts ] 
Go to page 1, 2, 3, 4  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu