View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 10 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Nov 10, 2014 6:55 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
I have noticed that I am continually getting the following message in both the frontend and backend logs
Code:
C SSDP ssdp.cpp:339 (ProcessData) SSDP Request from WAN IP address (0.0.0.0). Possible SSDP Reflection attempt. Ignoring as security risk.

I'm not familiar with it but I believe it's Simple Service Discovery Protocol
Is anyone familiar with this and know what process is causing the messages and how to stop it? I'm getting about 8 messages every 5 seconds.


Top
 Profile  
 
PostPosted: Tue Nov 11, 2014 10:42 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 690
Probably a mysql misconfiguration make sure you have one config.xml file


Top
 Profile  
 
PostPosted: Tue Nov 11, 2014 11:23 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1189
Location: SC
I am not seeing it here. But it is coming from this change: https://code.mythtv.org/cgit/mythtv/com ... 622695cdeb


Top
 Profile  
 
PostPosted: Tue Nov 11, 2014 10:31 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
I do have a config.xml file but can't seem to find any files related to the change.


Top
 Profile  
 
PostPosted: Wed Nov 12, 2014 11:09 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 690
How about the result from

Code:
ifconfig eth0


Top
 Profile  
 
PostPosted: Wed Nov 12, 2014 1:02 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
Here's the result from ifconfig eth0
Code:
[root@mythtv2 ~]# ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.20.50  netmask 255.255.255.0  broadcast 192.168.20.255
        inet6 fe80::922b:34ff:fee8:7e4d  prefixlen 64  scopeid 0x20<link>
        ether 90:2b:34:e8:7e:4d  txqueuelen 1000  (Ethernet)
        RX packets 12434988  bytes 16521021517 (15.3 GiB)
        RX errors 0  dropped 42  overruns 0  frame 0
        TX packets 1129204  bytes 359955652 (343.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Top
 Profile  
 
PostPosted: Wed Nov 12, 2014 1:39 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 690
Try this to disable multicast and check if it helps

Code:
ifconfig eth0 -multicast


you can turn it back on with

Code:
ifconfig eth0 multicast


Top
 Profile  
 
PostPosted: Wed Nov 12, 2014 5:16 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
Well for some reason the messages quit.

The last one received was yesterday at 2014-11-11T13:05:42.192852-05:00 In the logs it looked like the machine restarted as well. I did not initiate a reboot but from the logs it looks like the backend restarted:
Code:
2014-11-11T13:06:46.168867-05:00 mythbackend[2068]: C thread_unknown mythcommand
lineparser.cpp:2595 (ConfigureLogging) mythbackend version: fixes/0.27 [v0.27.4-
4-gb305eb5] www.mythtv.org
2014-11-11T13:06:46.175152-05:00 mythbackend[2068]: C thread_unknown mythcommand
lineparser.cpp:2597 (ConfigureLogging) Qt version: compile: 4.8.2, runtime: 4.8.
2
2014-11-11T13:06:46.175177-05:00 mythbackend[2068]: N thread_unknown mythcommand
lineparser.cpp:2599 (ConfigureLogging) Enabled verbose msgs:  general
2014-11-11T13:06:46.175449-05:00 mythbackend[2068]: N thread_unknown logging.cpp
:907 (logStart) Setting Log Level to LOG_INFO
2014-11-11T13:06:46.176053-05:00 mythbackend[2068]: I Logger logging.cpp:308 (ru
n) Added logging to the console


Also looks like the frontend restarted as well.

Since then no additional messages have been received.


Top
 Profile  
 
PostPosted: Fri Dec 12, 2014 8:17 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
Well the messages returned and this time killed the backend and hung the whole box. Couldn't ssh into the box either, had to use the rest button.

Messages are being recorded in both the frontend and backend logs. Looks like they shortly after I stopped watching TV last night, and started right after running the weather scripts. Heres the frontend log

Code:
485 (HandleStateChange) TV: Changing from WatchingLiveTV to None
2014-12-12T00:34:00.703912-05:00 mythfrontend[6961]: I CoreContext tv_play.cpp:4
14 (StartTV) TV: Exiting main playback loop.
2014-12-12T00:34:00.803578-05:00 mythfrontend[6961]: N CoreContext mythmainwindo
w.cpp:2742 (PauseIdleTimer) Resuming idle timer
2014-12-12T00:42:02.121280-05:00 mythfrontend[6961]: I CoreContext networkcontro
l.cpp:344 (newConnection) NetworkControl: New connection established.
2014-12-12T00:42:02.121730-05:00 mythfrontend[6961]: I CoreContext networkcontro
l.cpp:309 (deleteClient) NetworkControl: Client Socket disconnected
2014-12-12T00:43:43.522190-05:00 mythfrontend[6961]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2014-12-12T00:48:43.444478-05:00 mythfrontend[6961]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NWS-XML
2014-12-12T00:48:43.546323-05:00 mythfrontend[6961]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2014-12-12T00:48:43.547577-05:00 mythfrontend[6961]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-6_day
2014-12-12T00:53:43.565248-05:00 mythfrontend[6961]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2014-12-12T01:01:55.621274-05:00 mythfrontend[6961]: C SSDP ssdp.cpp:339 (Proces
sData) SSDP Request from WAN IP address (169.254.39.204). Possible SSDP Reflecti
on attempt. Ignoring as security risk.
2014-12-12T01:01:55.623713-05:00 mythfrontend[6961]: C SSDP ssdp.cpp:339 (Proces
sData) SSDP Request from WAN IP address (0.0.0.0). Possible SSDP Reflection atte
mpt. Ignoring as security risk.
2014-12-12T01:01:55.624119-05:00 mythfrontend[6961]: C SSDP ssdp.cpp:339 (Proces
sData) SSDP Request from WAN IP address (0.0.0.0). Possible SSDP Reflection atte
mpt. Ignoring as security risk.
2014-12-12T01:01:55.624490-05:00 mythfrontend[6961]: C SSDP ssdp.cpp:339 (Proces


Top
 Profile  
 
PostPosted: Sun Dec 14, 2014 6:54 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 996
Location: Lexington, Ky
RacerX,

Tried the "ifconfig eth0 -multicast" but didn't make any difference,

Once the messages start they continue until I reboot.

It ran without any errors from Fri Dec 12, 2014 9:17 pm until today at 2014-12-14T16:48:57


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu