View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 18 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Wed Dec 27, 2017 8:17 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
I have posted some information on the following post outlining some of the issues I ran into with upgrading 8.1 to 8.5:
viewtopic.php?f=21&t=24701
but I think that this particular issue deserves its own thread. I have been unable to get ACPI wakeup to work with 8.5. I even reconnected the 8.1 as a USB HDD and booted from it and verified that it is still working with my hardware. However, even though the /proc/driver/rtc looks the same when I set a wakeup time in 8.5, it never wakes up. I am hoping to find some assistance in troubleshooting this since there doesn't seem to be much else that I can find through google. One other oddity that has me scratching my head is that:
Code:
timedatectl
returns:
Code:
Failed to query server: Input/output error

Is this typical? I haven't been able to find much troubleshooting for this on google either.


Top
 Profile  
 
PostPosted: Thu Dec 28, 2017 10:44 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
I have two machines that are currently working correctly with ACPI wakeup and R8.5.1.

timedatectl is a systemd utility. LH doesn't use systemd for booting or service management so it isn't surprising that it doesn't work.

The /var/log/wake_alarm file is just the output of /proc/driver/rtc at the time the alarm was set by the mythwelcome test and set scripts. /proc/driver/rtc alarm time is what the BIOS should be getting.

The only place I see that LH sets the HW clock on shutdown is in the ntpd service. You can try "sudo sv stop ntpd" and then run the mythwelcome test script and shutdown to see if that might be the issue.


Top
 Profile  
 
PostPosted: Thu Dec 28, 2017 9:05 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
Thanks for the reply brfransen. I tested with ntpd stopped and still no joy.

/var/log/ntp.log contains:
Code:
...
28 Dec 19:19:13 ntpd[1071]: ntpd exiting on signal 15
28 Dec 19:19:27 ntpd[28268]: ntpd exiting on signal 15

Why is it exiting twice? Does it automatically restart if shutdown? I ran
Code:
sudo sv stop ntpd
and then
Code:
sudo sv status ntpd
and it showed it was stopped. Then I ran
Code:
suo /usr/LH/bin/mythwelcome-test-wakeup.sh

I selected yes, and it shutdown. But didn't wake up 4 minutes later.
/var/log/wake_alarm contains:
Code:
rtc_time        : 01:19:44
rtc_date        : 2017-12-29
alrm_time       : 01:23:43
alrm_date       : 2017-12-29
alarm_IRQ       : yes
alrm_pending    : no
update IRQ enabled      : no
periodic IRQ enabled    : no
periodic IRQ frequency  : 1024
max user IRQ frequency  : 64
24hr            : yes
periodic_IRQ    : no
update_IRQ      : no
HPET_emulated   : yes
BCD             : yes
DST_enable      : no
periodic_freq   : 1024
batt_status     : dead


ls -l /etc/adjtime
Code:
-rw-r--r-- 1 root root 44 Dec 28 19:19 /etc/adjtime

so it was still updated. It may be a total red herring, though, because the same file on 8.1 appears to have been updated the last time it shutdown. Is there any way that I can create a log file of /proc/driver/rtc right before power is cut to the computer to see if anything changed? Are there any configuration files I could try to bring across from my old setup? I tried /etc/rc.conf already.


Top
 Profile  
 
PostPosted: Thu Dec 28, 2017 9:21 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
ntpd should have started with the reboot.

There hasn't been alot that has changed with boot config between R8.1 and R8.5. And nothing of note to how RTC wakeup work. My guess is there is something with the new kernel that doesn't like your MB. Have looked ad BIOS settings. I know it worked as is with R8.1 but maybe something needs to be tweaked?


Top
 Profile  
 
PostPosted: Thu Dec 28, 2017 10:20 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
Sorry, I meant to ask if ntpd restarts when the service is stopped. I think my next step will be to try to update bios. I looked at settings earlier this week and nothing stood out.


Top
 Profile  
 
PostPosted: Fri Dec 29, 2017 7:35 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
Double checked bios settings again and didn't see anything unusual. I updated bios and did not see any new options and it still did not wake up.
I tried turning RTC on without any luck (I have to set a specific wakeup time in bios when it is on, so I set it a couple days in the future). I turned it back off and turned PME off (I think this is the WOL option) and still no luck. I am not as concerned about WoL working because I rarely used it, but could the alx driver which no longer supports WoL have anything to do with the RTC wakeup? With R8 I had to manually build the driver, but I think it just worked with 8.1. Is there any chance I could try to downgrade it? Do you have any other suggestions? I would prefer to not continue to use 8.1 since it is a couple major revisions of mythtv behind, but if I can't sort out the wakeup issue I am having in 8.5.1, I can't figure out which I will go with.


Top
 Profile  
 
PostPosted: Fri Dec 29, 2017 9:20 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
knappster wrote:
Sorry, I meant to ask if ntpd restarts when the service is stopped.
When you stop a service with sv it will not be restarted until you either start it with sv or reboot the box.

Some BIOS will show the wake time that was set in the OS. On R8.1 can you see if your BIOS did show what the OS set?

I doubt it has to do with the alx driver but who knows.


Top
 Profile  
 
PostPosted: Fri Dec 29, 2017 10:47 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
I'm not sure at this time because rtc was always disabled in bios with 8.1. I will check as soon as I get a chance. In the meantime, I was able to get wol working and will post the steps in the other thread when I get a chance. Unfortunately it did not help rtc wakeup, but I am trying to formulate a workaround to send the wakeup time to a raspberry pi which is on 24/7 and using a raspberry pi to wake-on-lan the 8.5.1 box...


Top
 Profile  
 
PostPosted: Sat Dec 30, 2017 8:11 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
FYI, I was able to add a line to the mythwelcome-set-alarm.sh to run a script and pass the wakeup epoch time. It then ssh's into the raspberry pi and schedules an at command to wakeonlan the LinHES box. Not ideal, but it will keep me running 8.5.1 while I continue to troubleshoot the rtc wakeup issue. I will plan to get the 8.1 bios information this weekend.


Top
 Profile  
 
PostPosted: Sat Dec 30, 2017 10:46 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
Be aware that the next time LinHES-system is updated your change to mythwelcome-set-alarm.sh will be overwritten.

Also I have rebuilt the kernel and applied the patch you linked to above for the WOL alx issue. Would you be willing to test it once I push it to testing?


Top
 Profile  
 
PostPosted: Sat Dec 30, 2017 5:37 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
I would be happy to test it. I will just have to see if I can easily remove the dkms driver and may need some direction on upgrading the kernel from the testing repository when it is ready.


Top
 Profile  
 
PostPosted: Sun Dec 31, 2017 11:08 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
Reverse what you did for the dkms stuff.

In /etc/pacman.conf change [core] and [extra] to [core-testing] & [extra-testing]. Then do a pacman -Syu. You should get linux 4.9.73, ceton and an nvidia driver if that is what video card you have.

Thanks.


Top
 Profile  
 
PostPosted: Sun Dec 31, 2017 3:30 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
I ran
Code:
sudo dkms uninstall alx/4.9.64

then here is the log from the testing upgrade:
[/code]sudo pacman -Syu
:: Synchronizing package databases...
core-testing 180.8 KiB 1390K/s 00:00 [######################] 100%
extra-testing 109.5 KiB 1825K/s 00:00 [######################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

warning: insufficient columns available for table display
Packages (7) ceton_infinitv-2013.0326.2226-24 linhes-theme-8.5.1-2
linux-4.9.73-1 linux-headers-4.9.73-1 mythinstall-8.5.1-2
nano-2.9.1-1 nvidia-304xx-304.137-10

Total Download Size: 76.95 MiB
Total Installed Size: 130.48 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
linux-4.9.73-1-x86_64 59.4 MiB 5.19M/s 00:11 [######################] 100%
ceton_infinitv-2013... 41.6 KiB 0.00B/s 00:00 [######################] 100%
linhes-theme-8.5.1-... 5.1 MiB 7.23M/s 00:01 [######################] 100%
linux-headers-4.9.7... 7.2 MiB 8.04M/s 00:01 [######################] 100%
mythinstall-8.5.1-2... 351.0 KiB 6.86M/s 00:00 [######################] 100%
nano-2.9.1-1-x86_64 396.4 KiB 6.45M/s 00:00 [######################] 100%
nvidia-304xx-304.13... 4.4 MiB 4.52M/s 00:01 [######################] 100%
(7/7) checking keys in keyring [######################] 100%
(7/7) checking package integrity [######################] 100%
(7/7) loading package files [######################] 100%
(7/7) checking for file conflicts [######################] 100%
:: Running pre-transaction hooks...
(1/1) Remove DKMS modules
==> dkms remove alx/4.9.64 -k 4.9.64-1-ARCH
Error! There is no instance of alx 4.9.64
for kernel 4.9.64-1-ARCH (x86_64) located in the DKMS tree.
:: Processing package changes...
(1/7) upgrading linux [######################] 100%
>>> Updating module dependencies. Please wait ...
(2/7) upgrading ceton_infinitv [######################] 100%
rmmod: ERROR: Module ctn91xx is not currently loaded
error: command failed to execute correctly
(3/7) upgrading linhes-theme [######################] 100%
(4/7) upgrading linux-headers [######################] 100%
(5/7) upgrading mythinstall [######################] 100%
(6/7) upgrading nano [######################] 100%
(7/7) upgrading nvidia-304xx [######################] 100%
In order to use nvidia module, reboot the system.
:: Running post-transaction hooks...
(1/2) Install DKMS modules
==> dkms install alx/4.9.64 -k 4.9.73-1-ARCH
(2/2) Updating linux initcpios
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.9.73-1-ARCH
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
-> Running build hook: [v86d]
-> Running build hook: [plymouth]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.9.73-1-ARCH
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [modconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
-> Running build hook: [v86d]
-> Running build hook: [plymouth]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
[/code]

I'm just now realizing that I should have removed dkms completely because I see messages about dkms removing and adding that module during the upgrade. WoL is still working but I don't know who is responsible... Should I switch back to core and extra and perform the same update, then completely uninstall dkms and try again?


Top
 Profile  
 
PostPosted: Sun Dec 31, 2017 3:34 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 459
Also, FYI, I ran rtc wakeup from 8.1 and tested with both cold boot and allowing the rtc wakeup alarm to wake up the box and the bios rtc setting did not change in either circumstance.


Top
 Profile  
 
PostPosted: Sun Dec 31, 2017 5:07 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1096
Location: SC
yes you need to undo all that you did for dkms.

Changing back to the release repos won't do anything except give you a notice that what you have installed is newer than what is in the repo.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu