View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 7 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Mar 20, 2018 7:43 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1241
Location: Orlando FL
So I clicked on "encode to x264 mkv" and a few seconds later when the job started my screen went blank. It's like the video driver just turned off. So I blindly opened the terminal and did a "sudo reboot" and the home screen came up as usual and then 2 seconds later when the transcode started up again everything went black. I was able to VNC into the machine to stop the transcode but it was very sluggish. My screen was still black until I rebooted. I then replicated the problem again with a different video, this time I grabbed a screenshot of Top from my SSH into the machine. To me it looks like "sleep" was called by "myth2mkv" and when I killed "myth2mkv" they both went away but the screen remained black until I rebooted.
I tried wading through the logs but I didn't see anything obvious in the ones I looked at (which probably were the wrong ones).

The obvious solution is "if it hurts, stop poking it" I won't use that transcoder but I thought I should share.


Attachments
topMKV.JPG
topMKV.JPG [ 49.49 KiB | Viewed 205 times ]

_________________
My System
Top
 Profile  
 
PostPosted: Tue Mar 20, 2018 9:33 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1065
Location: SC
Not seeing that here but I did fine another issue with one of the Handbrake options that myth2mkv uses is no longer supported. Will have to fix that.

Sleep is a program that delays for X number of seconds and is used in tons of scripts so I doubt that is causing the issue. Open a term and do sleep 5 to test.

When it dies is the whole X server dying (ps aux | grep Xorg)? Can you VNC in when it dies?


Top
 Profile  
 
PostPosted: Tue Mar 20, 2018 11:25 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1241
Location: Orlando FL
Yes I am able to VNC it just runs really slow.
Code:
mythtv@gimli ~]$ ps aux | grep xorg
root      1795  0.2  0.4 279148 32732 tty4     Ssl+ Mar20   2:01 /usr/lib/xorg-server/Xorg -nolisten tcp :0 -logverbose 6
mythtv   23652  0.0  0.0  12576  2152 pts/2    S+   01:12   0:00 grep xorg


I can't tell if it's making progress transcoding the file it just says "running" but in top the CPU utilization is 0%. Is it possible that there is some hardware acceleration that is causing the crash. My system is linked in my sig but essentially I'm using the integrated graphics in my Intel Core i5-3570.

_________________
My System


Top
 Profile  
 
PostPosted: Wed Mar 21, 2018 7:59 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1065
Location: SC
myth2mkv uses Handbrake to do the transcode. I seem to remember that HB does have some ability to use gnus to do transcoding so that is possible. See if HandBrakeCLI is running (caps are important). Also check /tmp/tox264*. But my guess is HB quit on the same option it choked on for me.


Top
 Profile  
 
PostPosted: Wed Mar 21, 2018 11:03 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1241
Location: Orlando FL
Some more points of interest If I VNC into the machine I can play a recording and the audio shows up without video.
Handbrake CLI is not running when myth2mkv is running.
There Were some log files in /var/log/myhthv/myth2mkv-2993.log
Code:
Wed Mar 21 23:55:12 EDT 2018
File to encode: /data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/2244_20180320163000.ts
    --> Name: Grand Sumo Highlights -
        --> Temporary Files: toX264-2993.*

Encoding Grand Sumo Highlights -  ...

I also found these in the:
/tmp/toX264-2993-hb_return_code
Code:
1

/tmp/toX264-2993-status.log
Code:
[23:55:14] hb_init: starting libhb thread
[23:55:14] thread 7f5b610bb700 started ("libhb")
unknown option (--strict-anamorphic)

/tmp/toX264-2993-id.txt
Code:
MPlayer SVN-r37857 (C) 2000-2016 MPlayer Team
224 audio & 451 video codecs

Playing /data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/2244_20180320163000.ts.
libavformat version 57.56.100 (external)
Mismatching header version 57.25.100
TS file format detected.
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
VIDEO MPEG2(pid=97) AUDIO A52(pid=100) NO SUBS (yet)!  PROGRAM N. 1
ID_VIDEO_ID=97
ID_AUDIO_ID=100
ID_AID_100_LANG=eng
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
VIDEO:  MPEG2  720x480  (aspect 3)  29.970 fps  5000.0 kbps (625.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 57.64.101 (external)
Mismatching header version 57.24.102
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
ID_VIDEO_CODEC=ffmpeg2
Load subtitles in /data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/
ID_FILENAME=/data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/2244_20180320163000.ts
ID_DEMUXER=mpegts
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=5000000
ID_VIDEO_WIDTH=720
ID_VIDEO_HEIGHT=480
ID_VIDEO_FPS=29.970
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
PROGRAM_ID=1 (0x01), PMT_PID: 96(0x60)
ID_START_TIME=66787.01
ID_LENGTH=668.92
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Forced audio codec: hwac3
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
hwac3: switched to AC3, 192000 bps, 48000 Hz

AUDIO: 48000 Hz, 2 ch, ac3be, 192.0 kbit/12.50% (ratio: 24000->192000)
ID_AUDIO_BITRATE=192000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [hwac3] afm: hwac3 (AC3 through S/PDIF)
==========================================================================
AO: [alsa] 48000Hz 2ch ac3be (2 bytes per sample)
ID_AUDIO_CODEC=hwac3
Starting playback...


Exiting... (End of file)
ID_EXIT=EOF

_________________
My System


Top
 Profile  
 
PostPosted: Thu Mar 22, 2018 6:43 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1065
Location: SC
The --strict-anamorphic option that causes HB to quit and myth2mkv doesn't detect that. I have a fix for that.

As for why you are losing video I am not sure. Can you run HB directly from a cmd line and see if it kills video?


Top
 Profile  
 
PostPosted: Fri Mar 23, 2018 9:11 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1241
Location: Orlando FL
Running handbrake with worked fine with some random options I found on the internet "-e x264 -q 20 -B 160" (...Yadda Yadda's substitued to save scrolling)
Code:
[mythtv@gimli ~]$ cd /myth/recordings/TV\ Shows/Grand\ Sumo\ Highlights/
[mythtv@gimli Grand Sumo Highlights]$ HandBrakeCLI -i Grand\ Sumo\ Highlights\ -\ 2018-03-20\ \=\ Untitled.ts -o /myth/video/GrandSumoTest2.mkv -e x264 -q 20 -B 160
...Yadda
...Yadda
Encode done!
HandBrake has exited.


I tried running the myth2mkv script from ssh terminal in the "/myth/recordings/tv/" directory however it failed on the spaces between words so I directly to the recording.
Once I ran it from "/data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/" it immediately caused the TV to black out HOWEVER it did successfully run.
Code:
[mythtv@gimli ~]$ cd /data/storage/WDCWD10JPVX-75JC3T0_WX61A8691H4H/media/tv/
[mythtv@gimli tv]$ myth2mkv 2244_2018032
2244_20180320163000.ts      2244_20180321163000.ts.png  2244_20180322163000.ts
2244_20180320163000.ts.png  2244_20180321223000.ts      2244_20180322163000.ts.png
2244_20180321163000.ts      2244_20180321223000.ts.png
[mythtv@gimli tv]$ myth2mkv 2244_20180320163000.ts
Command line option did not receive value:
    --chanid
mythutil version: fixes/29 [v29.1] www.mythtv.org

MythUtil is a command line utility application for MythTV.

Misc. Options:

...Yadda (removed all options listed for MythUtil)
...Yadda

Pass 1 of 2, 10.44% @ 341.24 fps. ETA 00h02m00s
Pass 1 of 2, 21.60% @ 339.03 fps. ETA 00h01m45s
Pass 1 of 2, 32.76% @ 337.60 fps. ETA 00h01m31s
Pass 1 of 2, 43.79% @ 336.38 fps. ETA 00h01m17s
Pass 1 of 2, 55.19% @ 338.81 fps. ETA 00h01m00s
Pass 1 of 2, 66.50% @ 339.15 fps. ETA 00h00m45s
Pass 1 of 2, 77.76% @ 339.29 fps. ETA 00h00m30s
Pass 1 of 2, 88.24% @ 336.72 fps. ETA 00h00m15s
Pass 2 of 2, 0.00% @  fps.
Pass 2 of 2, 5.38% @ 174.12 fps. ETA 00h04m04s
Pass 2 of 2, 9.55% @ 149.00 fps. ETA 00h04m33s
Pass 2 of 2, 14.38% @ 147.80 fps. ETA 00h04m20s
Pass 2 of 2, 18.83% @ 142.91 fps. ETA 00h04m16s
Pass 2 of 2, 22.96% @ 139.71 fps. ETA 00h04m08s
Pass 2 of 2, 27.67% @ 139.40 fps. ETA 00h03m54s
Pass 2 of 2, 31.73% @ 137.00 fps. ETA 00h03m44s
Pass 2 of 2, 36.33% @ 136.96 fps. ETA 00h03m28s
Pass 2 of 2, 40.82% @ 136.59 fps. ETA 00h03m15s
Pass 2 of 2, 45.37% @ 136.71 fps. ETA 00h03m00s
Pass 2 of 2, 49.92% @ 136.56 fps. ETA 00h02m44s
Pass 2 of 2, 54.46% @ 136.48 fps. ETA 00h02m30s
Pass 2 of 2, 58.96% @ 136.21 fps. ETA 00h02m15s
Pass 2 of 2, 63.94% @ 137.08 fps. ETA 00h01m58s
Pass 2 of 2, 68.16% @ 135.93 fps. ETA 00h01m46s
Pass 2 of 2, 72.28% @ 135.54 fps. ETA 00h01m32s
Pass 2 of 2, 77.00% @ 135.81 fps. ETA 00h01m16s
Pass 2 of 2, 80.67% @ 134.47 fps. ETA 00h01m04s
Pass 2 of 2, 85.19% @ 134.35 fps. ETA 00h00m50s
Pass 2 of 2, 89.46% @ 134.00 fps. ETA 00h00m35s
Pass 2 of 2, 93.45% @ 133.36 fps. ETA 00h00m22s
Pass 2 of 2, 98.19% @ 133.75 fps. ETA 00h00m06s
usage: jobqueue_helper.py [-h] [-cs COMMENT] [-cmds CMD] [-ss STATUS]
                          (-j JOBID | -m MAN_CURSOR | -u)
jobqueue_helper.py: error: argument -j/--jobid: expected one argument
[mythtv@gimli tv]$


I'm assuming that trying to figure out why MythUtils is complaining about "--chanid" is a worthless rabbit hole not related to my current problem?

I found that I could get MythTV back by RTFHM (Reading The Freaking Help Menu) and hitting "alt F" to restart the window manager. So I got that going for me I guess.

_________________
My System


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu