View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Mar 22, 2018 8:17 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 482
There are a couple odd behaviors I have noticed since updating to 8.5.1 and I have just been sort of ignoring them for the past few months. Over the coming weeks I might post some more of these in an effort to determine if they are normal or if there is something that is not behaving optimally. This particular behavior is that top always shows that there is a stopped task and a zombie task. To find the zombie task, I used the command:
Code:
ps aux | grep 'Z'
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root     14624  0.0  0.0      0     0 ?        Z    21:03   0:00 [funcd] <defunct>
mythtv   14805  0.0  0.0  12576  2228 pts/2    S+   21:07   0:00 grep Z


To find the parent I then ran:
Code:
pstree -p -s 14624
runit(1)ââârunsvdir(734)ââârunsv(754)âââfuncd(780)âââfuncd(14624)


These processes appear to change over time, though.

Then there is a stopped process
Code:
ps aux | grep 'T'
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root       167  0.0  0.0  40028  6688 ?        T    06:15   0:01 @usr/sbin/plymouthd --mode=boot --pid-file=/run/plymouth.pid
mythtv   15241  0.0  0.0  12576  2116 pts/2    S+   21:12   0:00 grep T


Is this anything to be concerned about?


Top
 Profile  
 
PostPosted: Fri Mar 23, 2018 6:54 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1119
Location: SC
Both of these have been around for a long time before R8.5.1.

The plymouth one is on purpose: http://linhes.org/issues/891

As for the funcd I have not ever been able to find why one process zombies but there is another that is running just fine.


Top
 Profile  
 
PostPosted: Fri Mar 23, 2018 11:27 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 482
I don't remember how I came to this conclusion, but when I looked at the zombie process a while ago, I thought it could have been tied into a cron job that runs every 10 minutes and causes this in the maillog:
Code:
Mar 23 00:00:01 linhes postfix/postfix-script[29226]: error: unknown command: ''
Mar 23 00:00:01 linhes postfix/postfix-script[29227]: fatal: usage: postfix start (or stop, reload, abort, flush, check, status, set-permissions, upgrade-configuration)
Mar 23 00:10:01 linhes postfix/postfix-script[30199]: error: unknown command: ''
Mar 23 00:10:01 linhes postfix/postfix-script[30200]: fatal: usage: postfix start (or stop, reload, abort, flush, check, status, set-permissions, upgrade-configuration)
Mar 23 00:20:02 linhes postfix/postfix-script[31185]: error: unknown command: ''
Mar 23 00:20:02 linhes postfix/postfix-script[31186]: fatal: usage: postfix start (or stop, reload, abort, flush, check, status, set-permissions, upgrade-configuration)


Oh right, it seemed like it could be tied to this post:
http://forum.linhes.org/viewtopic.php?f=21&t=24131
Again, something that has been around since long before 8.5.1


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu