View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Wed May 30, 2018 12:26 pm 
Offline
Joined: Tue Apr 18, 2006 3:10 pm
Posts: 24
Location: Finland SW
Hi,

I noticed that automatic system backup has not worked for a long time.
The last successful backup is dated 25.12.2017.
I remember that I did an upgrade R8.1 to R8.5 around the same time.

Mytht_mtc log shows the following error:
Code:
May 29 00:07:04 hartsutv myth_mtc:
May 29 00:07:04 hartsutv myth_mtc: 2018-05-29 00:07
May 29 00:07:04 hartsutv myth_mtc: Checking system idle...
May 29 00:07:04 hartsutv myth_mtc:     Checking if the schema is locked...
May 29 00:07:04 hartsutv myth_mtc:         The schema is NOT locked.
May 29 00:07:04 hartsutv myth_mtc:     Checking if programs are in use...
May 29 00:07:04 hartsutv myth_mtc:         Programs are NOT in use.
May 29 00:07:04 hartsutv myth_mtc:     Checking jobqueue for active jobs...
May 29 00:07:04 hartsutv myth_mtc:         No jobs are active.
May 29 00:07:04 hartsutv myth_mtc:     Checking if mythfilldatabase is running...
May 29 00:07:04 hartsutv myth_mtc:         mythfilldatabase is NOT running.
May 29 00:07:04 hartsutv myth_mtc:     Checking if mythtv-setup is running...
May 29 00:07:04 hartsutv myth_mtc:         mythtv-setup is NOT running.
May 29 00:07:04 hartsutv myth_mtc:     Checking for recordings in the next 15 minutes...
May 29 00:07:04 hartsutv myth_mtc: Traceback (most recent call last):
May 29 00:07:04 hartsutv myth_mtc:   File "/usr/LH/bin/idle.py", line 371, in <module>
May 29 00:07:04 hartsutv myth_mtc:     idle=main()
May 29 00:07:04 hartsutv myth_mtc:   File "/usr/LH/bin/idle.py", line 353, in main
May 29 00:07:04 hartsutv myth_mtc:     if (mfd_check(cmdargs) and mythtvsetup_check(cmdargs) and upcoming_check(cmdargs,mythBE)):
May 29 00:07:04 hartsutv myth_mtc:   File "/usr/LH/bin/idle.py", line 148, in upcoming_check
May 29 00:07:04 hartsutv myth_mtc:     show=str(i)
May 29 00:07:04 hartsutv myth_mtc: UnicodeEncodeError: 'ascii' codec can't encode characters in position 13-14: ordinal not in range(128)
May 29 00:07:04 hartsutv myth_mtc:
May 29 00:07:04 hartsutv myth_mtc: 2018-05-29 00:07 Waiting 10 minutes before trying again.

The same text is repeated every ten minutes.

Manual backup done through the Service Menu --> LinHES Backup works fine.
Any thoughts what could be problem ?

LinHES R8.5.1


Top
 Profile  
 
PostPosted: Wed May 30, 2018 2:26 pm 
Offline
Joined: Sun Nov 13, 2005 5:56 pm
Posts: 92
I had this problem. I had to do two things. 1) go through the backup script(s) to make sure the backup destination exists and someplace you (half) expected. Emend as required (filesystem or script). 2) Make sure permissions are set as needed.

Can't remember specifics like the script name(s) except that they are chained (one calls another and so on) and they are located in /usr/LH/bin. If you change the destination to something custom, you're on your own when the system gets updated. That's the fun of opensource. :wink:

-s-


Top
 Profile  
 
PostPosted: Wed May 30, 2018 7:26 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1119
Location: SC
idle.py is what is showing the error. Can you run idle.py from a xterm and post see if the output is the same?


Top
 Profile  
 
PostPosted: Thu May 31, 2018 9:33 am 
Offline
Joined: Tue Apr 18, 2006 3:10 pm
Posts: 24
Location: Finland SW
Idle.py from a xterm is showing similar error too.

Code:
mythtv@hartsutv ~]$ idle.py
Checking system idle...
    Checking if the schema is locked...
        The schema is NOT locked.
    Checking if programs are in use...
        Programs are NOT in use.
    Checking jobqueue for active jobs...
        No jobs are active.
    Checking if mythfilldatabase is running...
        mythfilldatabase is NOT running.
    Checking if mythtv-setup is running...
        mythtv-setup is NOT running.
    Checking for recordings in the next 15 minutes...
Traceback (most recent call last):
  File "/usr/LH/bin/idle.py", line 371, in <module>
    idle=main()
  File "/usr/LH/bin/idle.py", line 353, in main
    if (mfd_check(cmdargs) and mythtvsetup_check(cmdargs) and upcoming_check(cmdargs,mythBE)):
  File "/usr/LH/bin/idle.py", line 148, in upcoming_check
    show=str(i)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 13-14: ordinal not in range(128)


Top
 Profile  
 
PostPosted: Thu May 31, 2018 11:41 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1119
Location: SC
Try editing /usr/LH/bin/idle.py and comment out line 148 & 149:
Code:
#        show=str(i)
#        show=show.strip()


Save and run idle.py again.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu