View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 13 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: NFS problems?
PostPosted: Wed Jun 13, 2018 7:47 pm 
Offline
Joined: Thu Feb 02, 2006 11:55 am
Posts: 20
I'm running R8.5.1 seem to be having some trouble with NFS, which is disabled in the LinHES Settings. The mythtv_sm-notify.log is huge, with

Code:
Jun 13 21:29:46 mythtv sm-notify[25055]: Version 1.2.9 starting
Jun 13 21:29:46 mythtv sm-notify[25055]: Already notifying clients; Exiting!


constantly repeating every second. Likewise mythtv_kernel.log keeps repeating

Code:
Jun 13 21:31:07 mythtv kernel: [75540.825709] traps: rpc.statd[30811] general protection ip:7f6b4ca09400 sp:7fff86eca648 error:0
Jun 13 21:31:07 mythtv kernel: [75540.825716]  in libpthread-2.23.so[7f6b4c9f7000+18000]
Jun 13 21:31:08 mythtv kernel: [75541.974279] traps: rpc.statd[30888] general protection ip:7fd28cd9a400 sp:7ffe51e86748 error:0
Jun 13 21:31:08 mythtv kernel: [75541.974282]  in libpthread-2.23.so[7fd28cd88000+18000]


MythTV runs okay, but I'd like to stop the logs ballooning out. Any tips on how I'd go about troubleshooting this?


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Wed Jun 13, 2018 8:22 pm 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 86
I’ve had the same issue on my intel master backend.
I’ve not found any troubleshooting help, but haven’t gone into a major search to see what is going on since I simply shut down the processes.
Code:
[mythtv@mbe ~]$ su
[root@mbe mythtv]# sv stop nfs-common
[root@mbe mythtv]# sv stop nfsd

I’ve not seen any issues, but I only use one front end at a time, so if you are using multiple frontends for live tv or playback you might see some issues.
Let us know if you fix it, would love to not have to remember to shut the processes down to minimize the log size.
Regards.


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Thu Jun 14, 2018 10:46 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
How often are the sm-notify messages appearing in the log?

Please post:
Code:
ps aux | grep nfs
ps aux | grep rpc


It looks like systemconfig.py doesn't remove the nfs-common and rpcbind services when disabling NFS. I am not 100% sure why but I think that is related to NFS integration with FE only boxes.

Try removing the services and see if that helps:
Code:
sudo remove_service.sh nfs-common
sudo remove_service.sh rpcbind


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Thu Jun 14, 2018 6:41 pm 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 86
Remove them from the master backend only, or all systems?

Thanks!


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Thu Jun 14, 2018 6:50 pm 
Offline
Joined: Thu Feb 02, 2006 11:55 am
Posts: 20
Thank you both.

The sm-notify messages are about 1 every second:

Code:
Jun 13 00:00:00 mythtv sm-notify[2119]: Version 1.2.9 starting
Jun 13 00:00:00 mythtv sm-notify[2119]: Already notifying clients; Exiting!
Jun 13 00:00:01 mythtv sm-notify[2252]: Version 1.2.9 starting
Jun 13 00:00:01 mythtv sm-notify[2252]: Already notifying clients; Exiting!
Jun 13 00:00:02 mythtv sm-notify[2385]: Version 1.2.9 starting
Jun 13 00:00:02 mythtv sm-notify[2385]: Already notifying clients; Exiting!
Jun 13 00:00:03 mythtv sm-notify[2501]: Version 1.2.9 starting
Jun 13 00:00:03 mythtv sm-notify[2501]: Already notifying clients; Exiting!
Jun 13 00:00:04 mythtv sm-notify[2609]: Version 1.2.9 starting
Jun 13 00:00:04 mythtv sm-notify[2609]: Already notifying clients; Exiting!
Jun 13 00:00:05 mythtv sm-notify[2724]: Version 1.2.9 starting
Jun 13 00:00:05 mythtv sm-notify[2724]: Already notifying clients; Exiting!
Jun 13 00:00:06 mythtv sm-notify[2832]: Version 1.2.9 starting
Jun 13 00:00:06 mythtv sm-notify[2832]: Already notifying clients; Exiting!
Jun 13 00:00:07 mythtv sm-notify[2940]: Version 1.2.9 starting
Jun 13 00:00:07 mythtv sm-notify[2940]: Already notifying clients; Exiting!
Jun 13 00:00:08 mythtv sm-notify[3054]: Version 1.2.9 starting
Jun 13 00:00:08 mythtv sm-notify[3054]: Already notifying clients; Exiting!
Jun 13 00:00:09 mythtv sm-notify[3162]: Version 1.2.9 starting
Jun 13 00:00:09 mythtv sm-notify[3162]: Already notifying clients; Exiting!
Jun 13 00:00:10 mythtv sm-notify[3271]: Version 1.2.9 starting
Jun 13 00:00:10 mythtv sm-notify[3271]: Already notifying clients; Exiting!


ps outputs after a fresh reboot:

Code:
[root@mythtv ~]# ps aux | grep nfs
root        80  0.0  0.0      0     0 ?        S<   20:30   0:00 [nfsiod]
root       916  0.0  0.0   4056  1136 ?        Ss   20:31   0:00 runsv nfs-common
root     23248  0.0  0.0  12576  2200 pts/1    S+   20:35   0:00 grep nfs


Code:
[root@mythtv ~]# ps aux | grep rpc
root        74  0.0  0.0      0     0 ?        S<   20:30   0:00 [rpciod]
root       927  0.0  0.0   4056   664 ?        Ss   20:31   0:00 runsv rpcbind
root       958  0.0  0.0  17004  2004 ?        S    20:31   0:00 /usr/bin/rpcbind -d
root     26561  0.0  0.0  12576  2188 pts/1    S+   20:36   0:00 grep rpc


Removing the services seems have done the trick - thanks again! This is on my combined FE/BE system. Don't know how I managed to get into this state, I was using NFS to share with a Kodi FE in another room at one point but haven't been for a while.


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Thu Jun 14, 2018 8:31 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
NFS is on by default. For some reason we don't stop these services as well when it is disabled. Not exactly sure why or if it was just an oversight. Odd part is I don't see the log behavior when testing on a VM. Do you have any FE only boxes that connect to the combined MBE?


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Fri Jun 15, 2018 4:42 am 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 86
If JerryF doesn’t and you need something tested, let me know I’ve got 3 stand-alone FEs connecting to a combo MBE/FE.


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Fri Jun 15, 2018 6:58 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
bgrant3406 wrote:
If JerryF doesn’t and you need something tested, let me know I’ve got 3 stand-alone FEs connecting to a combo MBE/FE.
To be clear you have disabled NFS in settings and get the large log files too? Or is NFS enabled and you still get the large log files?


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Fri Jun 15, 2018 5:18 pm 
Offline
Joined: Thu Feb 02, 2006 11:55 am
Posts: 20
brfransen wrote:
Do you have any FE only boxes that connect to the combined MBE?

Nope, no MythTV FE only, just the combined MBE. I do have a Kodi frontend in another room running the MythTV addon though:
https://kodi.wiki/view/Add-on:MythTV_PVR_Client


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Fri Jun 15, 2018 8:37 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
LinHES FE only would be the only ones that might be affected without those 2 services.


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Sat Jun 16, 2018 7:15 am 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 86
brfransen wrote:
bgrant3406 wrote:
If JerryF doesn’t and you need something tested, let me know I’ve got 3 stand-alone FEs connecting to a combo MBE/FE.
To be clear you have disabled NFS in settings and get the large log files too? Or is NFS enabled and you still get the large log files?


So I went back and double checked, NFS was enabled in LinHES settings on the MBE and was off on the 3 SBE/FE systems.

Turned it off on the MBE, rebooted the system and was getting the general protection faults until I stopped nfs-common.

What else would you like me to check?


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Sat Jun 16, 2018 8:03 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
The GPF was from rpc? Did you just stop nfs-common or rpcbind as well?


Top
 Profile  
 
 Post subject: Re: NFS problems?
PostPosted: Sat Jun 16, 2018 10:21 am 
Offline
Joined: Tue Jul 01, 2014 6:49 am
Posts: 86
Here is what I was seeing:
Code:
[  140.590684] traps: rpc.statd[11198] general protection ip:7fd394a26400 sp:7ffc7fe4b468 error:0
[  140.590687]  in libpthread-2.23.so[7fd394a14000+18000]
[  141.675323] traps: rpc.statd[11273] general protection ip:7f1b8d5b2400 sp:7ffd9ca0fc78 error:0
[  141.675326]  in libpthread-2.23.so[7f1b8d5a0000+18000]


All I stopped was nfs-common (nfsd didn’t start once I turned that off in settings), I didn’t touch rpcbind.

Let me know if you need me to check anything else.

And as always, thanks for all you do!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu