View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 6 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: Turn "Frontend" back on
PostPosted: Sat Mar 04, 2017 12:53 pm 
Offline
Joined: Sat Mar 04, 2017 12:03 pm
Posts: 3
Hello All,
New to LinHES (and arch) but not MYTH...Just movde from Mythbuntu after 8yrs or so. my apoligies if this is the wrong place in the forum.

Anyway, after base install and moving all of my recordings and schedulings to my new backend (dont you hate that move :-) ) my last task was a review/cleanup/optimize. with that i unchecked "frontend" from LinHES tools screen (i beleive... AKA the "hostype" screen). im used to this just removing the mythfrontend stuff from the box...VERY surprised when it made it completely headless. So now im trying to turn it back on. so far i have tried:
--VNC'ing to the box and running "mythinstall -s hostype" on the vncsvr cli. it opens the window to make the change but after i click finish to save (or run the script) the header box with time and date at the bottom of the screen flashes keeps flashing and if you open the cli window you just see four messages over and over again until you ctrl-z it
"unlocking input devices"
"resuming idle timer"
"locking input devices"
"suspending idle timer "
same thing goes with the other mythinstall -s <options>. also, if i open it again, the check in the box persists but i guess it didnt run the script because the interface isnt up on the backend.

--while VNC'd into the box and trying to use sudo it asks for password but doesnt take the one i use for everything else
[sudo] password for vncsvc

--cant ssh into the box either. when prompting for username and password ive tried all combinations of mythtv, <black>, the username i used during install, and a few others. nothing seemed to work.

most annoying thing is i rebooted and now the box will shutdown after a couple mins by itself.

any help greatly appreciated


Top
 Profile  
 
PostPosted: Sat Mar 04, 2017 8:10 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
As you found mythfrontend and frontend are 2 very different things. The Run Frontend setting's help text does state that X won't run with this setting disabled.

From VNC you would need to "su mythtv -c mythinstall -s hostype" but you would need to know what password you set the user mythtv to on install. If you don't know or didn't set those passwords the easiest solution is to do an Upgrade install which will only format sda1 and install a new system. Your db, /home and other storage won't be touched.


Top
 Profile  
 
PostPosted: Sun Mar 05, 2017 10:27 am 
Offline
Joined: Sat Mar 04, 2017 12:03 pm
Posts: 3
Thanks for the [consise] reply!!

Yeah, i thojght i set the password but I guess i didnt (actually had to go through the install a few times).

So a little more advice if you dont mind...(upgrade install recovery) since i have all of my myth directories on my nas...thats not going to change the thought of the upgrade install, right? The idea is that I run the upgrade and all settings are saved or i guess persist is a better way to look at it... I just set the pw and make sure that the check is in the frontend box, correct? Also, would i have to do anything post install? Like a db restore or anything like that. My biggest issue is i had just manually moved all my scheduled recordings over one by one deleting each from my old backend as i set them up on the new or i dont have the list to work from anymore.

Thanks for your time!!


Top
 Profile  
 
PostPosted: Sun Mar 05, 2017 2:07 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
Sorry, after thinking more about the problem a Upgrade isn't going to fix it because it keeps your same user creds and you don't know them. But I think there is an easier solution. Normally it is not wise to edit /etc/systemconfig but this is one of the exceptions. From VNC open a term and edit /etc/systemconfig and change RunFrontend to 1. Then run sudo systemconfig.py -m hostype. That should get the frontend working again. It would be a good idea to then open an xterm in the frontend and change your mythtv user password.


Top
 Profile  
 
PostPosted: Sun Mar 05, 2017 3:22 pm 
Offline
Joined: Sat Mar 04, 2017 12:03 pm
Posts: 3
Good call worked perfect. Got to admit though...when i saw the sudo command i was a bit skeptical. And on the passwd...yeah, first thing i did. Kinda wish i had to to a password in for install or when i was turning the frontend off.

Thanks again for your time!!


Top
 Profile  
 
PostPosted: Sun Mar 05, 2017 5:18 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 988
Location: SC
One more thing you should do is make sure in Host settings Run Frontend is checked. The DB is actually where those settings are stored and that is why editing /etc/systemconfig directly is a usually a bad idea so you want to get them back in sync.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu