LinHES Forums

[SOLVED] r6.0.3 upgrade problem
Page 1 of 1

Author:  welner [ Sun Jun 13, 2010 2:15 pm ]
Post subject:  [SOLVED] r6.0.3 upgrade problem

i have just upgraded a working dragon 2 system from 6.0.2 to 6.0.3

no major modifications have been made to this dragon system. i am still using the stock nvidea 6200 le card

everything seemed to go very well, but upon reboot as the frontend was starting up things seemed to go bad.

upon further inspection, everything seems to be running, however.

upon startup, i hit the f2 key to monitor all of the services starting up, xinit appears to startup, i see the screen flash, and an nvidia screen flash by, and then the yellow 'linhes' screen. the myth theme screen, however does not appear.

i can see the xinit and frontend processes running, and am able to stop/start the frontend without errors. i am also able to launch an xterm successfully.

fluxbox.log shows:

[root@mythtv frontend]# cat /var/log/fluxbox.log
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.forcePseudoTransparency

many more 'setting default value' statements are shown.

googling around for the "extension "Generic Event Extension" ", i see that it may be an innocuous error. i am not sure if i had this error previously, and just never noticed.

i am curious if the x/y coordinates and offsets i had previously applied may be no longer valid, possibly placing the mythtv screen off screen. i noted those values, in case they were needed at some later point in time, as they were somewhat tedious to generate. they are 1218,685 and 31,17.

any suggestions are greatly appreciated


Author:  Too Many Secrets [ Sun Jun 13, 2010 6:00 pm ]
Post subject: 

Just some random thoughts that came to mind. have you checked the output of cat /var/log/Xorg.0.log for errors? This has often led me to solutions.

might also try NOT using the xorg.conf file. It sounds odd, but xorg will run default and probed values if it doesn't find a xorg.conf file. Maybe backup with mv /etc/X11/xorg.conf /etc/X11/xorg.BAK and then reboot and look at cat /var/log/Xorg.0.log again? Maybe with the default and probed values you will get a frontend that is visible, if not optimized. Then you can lock it in later...

You should also be able to check dif of your xorg.conf backup and the current one running.

Author:  welner [ Sun Jun 13, 2010 7:10 pm ]
Post subject: 

thanks for the suggestions, however, the X server appears to be running just fine. i am able to kick off an xterm without issue via the alt-x keyboard command. it is, however, apparently displaying larger than usual.

the Xorg log file showed an error loading the module 'type1'. i commented that out to remove the error. not sure if it is really needed.

moving the xorg.conf file out of the way just produced more errors in the log and did not regenerate the conf file.

the log file shows that it is properly communicating with the tv and picking a resolution shown as valid via edid

Author:  welner [ Sun Jun 13, 2010 7:41 pm ]
Post subject:  SOLVED" r6.0.3 upgrade problem

it turned out to be



. /etc/unclutter.cfg

i removed the unclutter package some time ago because it messed up the mouse cursor when running firefox. the cursor would disappear in the bowser, making browsing rather problematic.

i commented out the sourcing of the unclutter.cfg and things are now working

Author:  Martin1802 [ Wed Jun 16, 2010 3:29 am ]
Post subject: 


do you know about the shortcut in (main)mythmenu? There is a shortcut Strg-Alt-u to unhide / hide mouse cursor ... it will help to unhide cursor in other program windows and xterm ...

Author:  welner [ Wed Jun 16, 2010 10:37 am ]
Post subject: 

yes, i am aware of the toggle. the utility seemed to offer no use to me, so i uninstalled it. at that time (initial 6.0 release). there was no dependency on the existence of the config file for startup of fluxobx, so i never encountered this issue. if the linhes script will continue to have this dependency, i imagine i'll have to add the package back. just seems that there should be an if clause to check for the existence of the config file in the start script.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group