View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Mar 03, 2011 8:38 pm 
Joined: Sun Oct 30, 2005 7:07 pm
Posts: 72
When I upgraded to R6.04, the digital optical audio via the SPDIF output of my sound card stopped working. I had no sound. My hardware is a dragon v. 1.0, with the Chaintech AV710 sound card.

I ran into the same problem with R6.02, and worked through a solution in this thread.

Well, I got digital audio working again in R6.04 (MythTV 0.24) also. Here is how I did it...

After some digging and a pointer from slowtolearn in this link, I learned that there were major changes to the audio subsystem in MythTV 0.24. So, following the "Special Notices & Instructions" here, I rescanned my audio devices using the button at the top of the audio settings page under Service Menu -> MythTv Config -> Setup -> General (fourth screen). This alone did not fix audio, but it was the first step.

Another step was to visit the Service Menu -> LinHES Config -> Audio Settings. Here I chose ALSA driver and type Digital. The Selection dialog showed my sound card: "AV710 [Chaintech AV-710](hw:0,1)". I loaded the ALSA driver. Then I exited. I am not sure if this was necessary or not, but if you do it, it makes sense to do it before you finalize your audio settings under the General section.

Last, I played again with the settings on the new audio configuration page, under Service Menu -> MythTV Config -> Setup -> General (fourth screen). The new page is an improvement, after you get used to it. The problem for me was that the device reported for my hardware did not work for me when I selected it. After scanning for devices, the entry form for "Audio output device" displayed
"ALSA:front:CARD=AV710,DEV=0". Great, it found my exact hardware, I thought. However, no combination of settings worked for me as long as I used that device. I tried various things in vain for over an hour. If anyone figured out how to get the "ALSA:front:CARD=AV710,DEV=0" device to work, please post a follow-up!

Finally, I remembered that I had fixed this in R6.02, and I found the thread referenced above. I had used /dev/adsp as the Audio output device and gotten it to work. However, I had been hesitant to try that with the new Myth 0.24 audio setup because when I selected /dev/adsp, the description at the bottom would report "OSS device Device supports up to 2.0". I thought this was something I would not want to use - I wanted 5.1 sound support, right?

Well, here is what finally worked for me:

1) re-used working asound.conf from previous installation of Myth
2) In General (screen 4) -> Audio System I set:
Audio output device: /dev/adsp
Digital Audio Capabilities: Dolby Digital (checked) DTS (checked)
Speaker Configuration: 5.1
Upconvert to 5.1 (checked)
Upmix quality: Good
Advanced Audio Config (checked)
Separate digital output device: ALSA:iec958:{ AES0 0x01 }

NOTE: my use of "AES0 0x01" for the Digital output device is specific to my system. The "0x01" maps to my card's digital output of hw:0,1. Make sure you use to find the value to use for your sound card. Also, I had to edit this value, as it was pre-populated with 0x02 to start.

3) General (screen 5) -> Audio Mixer
Use internal volume controls (unchecked)

That's it. I hope other find this helpful. If you have something else that also works with R6.04, please feel free to post it here, along with your hardware information.



Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu