View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 11 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: Webmin error on R7.2
PostPosted: Fri May 11, 2012 10:43 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 976
Location: Lexington, Ky
I installed webmin 1.570-1 on my new install from the R7.2 ISO and am getting the following errors.

Code:
[02/May/2012:00:07:46 -0400] miniserv.pl started
[02/May/2012:00:07:46 -0400] Perl module Authen::PAM needed for PAM is not insta
lled : Can't locate Authen/PAM.pm in @INC (@INC contains: /opt/webmin /usr/lib/p
erl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/
perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /usr/lib/p
erl5/site_perl/5.10.1 /usr/share/perl5/site_perl/5.10.1 /usr/lib/perl5/current /
usr/lib/perl5/site_perl/current .) at (eval 17) line 1.
BEGIN failed--compilation aborted at (eval 17) line 1.

Use of uninitialized value $mode in chop at /opt/webmin/webmin/webmin-lib.pl lin
e 1601.
[02/May/2012:00:14:45 -0400] miniserv.pl started
[02/May/2012:00:14:45 -0400] Perl module Authen::PAM needed for PAM is not insta
lled : Can't locate Authen/PAM.pm in @INC (@INC contains: /opt/webmin /usr/lib/p
erl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/
perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /usr/lib/p
erl5/site_perl/5.10.1 /usr/share/perl5/site_perl/5.10.1 /usr/lib/perl5/current /
usr/lib/perl5/site_perl/current .) at (eval 17) line 1.
BEGIN failed--compilation aborted at (eval 17) line 1.

Use of uninitialized value $mode in chop at /opt/webmin/webmin/webmin-lib.pl lin
e 1601.
Use of uninitialized value $mode in chop at /opt/webmin/webmin/webmin-lib.pl lin
e 1601.

I checked and pam 1.1.3-1 is installed.


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Fri Jun 29, 2012 2:45 pm 
Offline
Joined: Thu Jan 13, 2005 8:59 am
Posts: 36
Location: The Netherlands
It has been some time, but maybe it's of some use to others:

I got the same error, except for
Code:
Use of uninitialized value $mode in chop at /opt/webmin/webmin/webmin-lib.pl lin
e 1601.
Use of uninitialized value $mode in chop at /opt/webmin/webmin/webmin-lib.pl lin
e 1601.

And eventually found this in an other thread (many thanks to brfransen):
LinHES doesn't use the sysv init rc.d to start services. LH uses runit for starting services. Reinstall webmin using pacman:
(you don't need to do this, it here just for completeness)
Code:
    sudo pacman -S webmin

Enable the webmin service:
Code:
    sudo add_service.sh webmin

Start webmin:
Code:
    sudo sv start webmin

Then it states:
Code:
ok: run: webmin: (pid 1939) 19s

And it works, well... now I only need to allow myself remote access (again) 8)


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 1:04 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1295
Location: Orlando FL
thanks

_________________
My System


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 1:14 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 976
Location: Lexington, Ky
I assume that webmin should then be removed from:

Code:
/etc/rc.d/webmin

Before running
Code:
sudo add_service.sh webmin


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 1:28 pm 
Offline
Joined: Thu Jan 13, 2005 8:59 am
Posts: 36
Location: The Netherlands
That's not necessary.
It's still in
Code:
/etc/rc.d
on my system.
Other modules I use are there too (samba, cups).


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 2:56 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Thats correct the dir /etc/rc.d is ignored by linhes so no need to remove/add files.


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 3:16 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
May i ask what do you guys use webmin for?


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 4:34 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 976
Location: Lexington, Ky
Mostly for backups and system status.


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Thu Nov 01, 2012 9:35 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1295
Location: Orlando FL
it's by far the easiest way to mount a hard drive in LinHES. Also it has a Java file manager which is useful since LinHES doesn't have a file manager.

_________________
My System


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Fri Nov 02, 2012 4:31 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Probably shouldn't ask..but why do you need a file manager? I mean whats the use case


Top
 Profile  
 
 Post subject: Re: Webmin error on R7.2
PostPosted: Fri Nov 02, 2012 8:42 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1295
Location: Orlando FL
It comes in handy sometimes. For example recently I had an application decide that it was going to spew whatever files in downloaded into my root drive instead of in my /myth/video/ drive like I told it to. In trying to move the files using the command line I screwed something up and they ended up in 3 places on my root drive. when I did a mythbackup I had a savedfiles file that was 12 GB I used the file manager to find the offending files and move them to their home.

_________________
My System


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu