View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Nov 25, 2011 3:30 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
After upgrading to 7.1 monitorix fails on startup.

I tried doing an upgrade and install of the monitorix package.
pacman -Su monitorix
It checked the package, confirmed it was up todate and then reinstalled it. But when I try to start it I get the following messages.
Code:
[root@mythtv etc]# /etc/rc.d/monitorix start
:: Starting Monitorix                                                    [BUSY]
:: Stopping Cron Daemon                                                  [DONE]
:: Starting Cron Daemon                                                  [FAIL]
                                                                         [DONE]

Any suggestions? Now sure why I am getting the BUSY status. It's not running.


Last edited by tscholl on Tue May 22, 2012 12:29 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 4:18 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Look in the logs /var/log/monitorix

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 5:51 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
Looked for a monitorix log in /var/log but none exist there. Also did a
Code:
find . -name monitorix.log

Didn't find any logs anywhere for monitorix


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 6:00 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Mine doesn't have the .log extension...

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 6:24 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
Nothing monitorix at all in /var/log

All the other monitorix are either directorys, crontab, or scripts


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 6:40 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
K... it's been a while since I made that PKGBUILD and frankly, I haven't touched it since then. My best advice is to take the one I maintain in the AUR and adapt it to the setup LH uses.

https://aur.archlinux.org/packages.php?ID=33911

EDIT: wait a sec, looks like the PKG is in the official linhes repo?

http://knoppmyth.net/phpBB2/viewtopic.p ... c&start=30

EDIT2: ack, it's a pretty old version, maybe you're better off talking my original suggestion.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 25, 2011 7:03 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
Ok so grab the new package and them follow your original thread
"HOWTO: Setup Monitorix on R6 (rrdtool system monitor)" ?

That's the thread that I used to do my original install. can edit and use the PKGBUILD file in your original tarball?


Top
 Profile  
 
PostPosted: Wed Feb 29, 2012 5:42 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Wow, REALLY late reply. Missed your post. No, the howto I wrote is out-of-date. Any package on LH should be build/managed by pacman. Perhaps one of the dev's can update the LH monitorix PKGBUILD.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
PostPosted: Thu Mar 01, 2012 1:43 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
https://wiki.archlinux.org/index.php/Monitorix

_________________
TVBox
LinHES R8.6.1


Top
 Profile  
 
PostPosted: Thu Mar 01, 2012 3:20 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
TVBox wrote:
https://wiki.archlinux.org/index.php/Monitorix


That won't help LH users a whole lot since LH uses a different init system for daemons. I am also unfamiliar with which paths LH uses for serving up http (been too long).

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 
PostPosted: Tue May 22, 2012 12:28 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
See Updated instructions at the bottom of this post

Ok I had some free time to play around with this and this is what I found.
The monitorix package installs in directory /srv/http/monitorix

Linhes is expecting to find monitorix at /data/srv/httpd/htdocs/monitorix , monitorix.cgi at
/data/srv/httpd/htdocs/cgi-bin , and data at /data/srv/httpd/htdocs/monitorix/imgs

I copied the contents of /srv/http/monitorix to /data/srv/httpd/htdocs/monitorix
the contents of /srv/http/cgi-bin to /data/srv/httpd/htdocs/cgi-bin

Then created a link to imgs at /data/srv/httpd/htdocs/monitorix to /srv/http/monitorix/imgs

Code:
 cd /data/srv/httpd/htdocs/monitorix
 ln -s /srv/http/monitorix/imgs imgs

If you removed montorix from startup you just need to run
/etc/rc.d/monitorix start
And you should be good to go.

Revised instructions:

tscholl wrote:
Updated instructions
Code:
copy /srv/http/cgi-bin/monitorix.cgi   to   /data/srv/httpd/htdocs/cgi-bin/

cd /data/srv/httpd/htdocs/

ln -s /srv/http/monitorix  monitorix

That's it!



Tim


Last edited by tscholl on Fri Jun 01, 2012 5:57 pm, edited 3 times in total.


Top
 Profile  
 
PostPosted: Mon May 28, 2012 12:49 pm 
Offline
Joined: Mon Mar 20, 2006 11:39 am
Posts: 32
This was great help, thank you tscholl! I was able to get this to work also, with a minor correction:

The latter copy should be /srv/http/cgi-bin (not /srv/http/monitorix/cgi-bin) to /data/srv/httpd/htdocs/cgi-bin


Top
 Profile  
 
PostPosted: Mon May 28, 2012 3:12 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
Glad it worked for you as well. I updated my post to reflect your findings.

I also made one additional change in regards to the index.html

It does gets updated now and then and when it does the copy at /data/srv/httpd/htdocs/monitorix/index.html is out of sync.

To eliminate that problem I deleted the index.html from /data/srv/httpd/htdocs/monitorix and created a link back to /srv/http/monitorix/index.html

Code:
cd /data/srv/httpd/htdocs/monitorix/
rm index.html
ln -s /srv/http/monitorix/index.html index.html

It would really probably be a lot cleaner just to link /data/srv/httpd/htdocs/monitorix to /srv/http/monitorix/ and that would eliminate the need to do the index.html link.


Top
 Profile  
 
PostPosted: Wed May 30, 2012 9:19 am 
Offline
Joined: Mon Mar 20, 2006 11:39 am
Posts: 32
All things happen @ (too) late hours 8)


Top
 Profile  
 
PostPosted: Fri Jun 01, 2012 10:58 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 980
Location: Lexington, Ky
Updated instructions
Code:
copy /srv/http/cgi-bin/monitorix.cgi   to   /data/srv/httpd/htdocs/cgi-bin/

cd /data/srv/httpd/htdocs/

ln -s /srv/http/monitorix  monitorix

That's it!


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu