View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 13 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: R8 Samba - Resolved
PostPosted: Sun May 12, 2013 11:41 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
I noticed that samba was not running on my new R8 box and discovered that it wasn't installed. I installed it using pacman than
tried

/etc/rc.d/samba start
:: Starting Samba Server [FAIL]

I did the configuration in LinHES setup for the work group name. What am I missing


Last edited by tscholl on Mon Jul 08, 2013 5:34 pm, edited 4 times in total.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Sun May 12, 2013 2:35 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 680
Double check

as root edit

Code:
/etc/samba/smb.conf


make sure your workgroup name is correct

then run

Code:
testparm /etc/samba/smb.conf


It will give some insight as to the problem

Samba works fine for me on R8


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Sun May 12, 2013 5:04 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Thanks for the insight. I looked for /etc/samba and it didn't exist. Thus the error.

I copied the /etc/samba directory and contents from my old drive ( thank goodness I still had it) .

Then ran
Code:
testparm /etc/samba/smb.conf


And it ran /etc/rc.d/samba start and it started.

Then ran

add_service.sh smbd

Not sure why the /etc/samba/smb.conf was not created by the workgroup setup screens, but copying the samba directory did the trick. Thanks for pointing me in the right direction.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Sun May 12, 2013 6:12 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 680
No problem

to make it start automatically courtesy of Jams

as root


Code:
add_service.sh smbd
add_service.sh nmbd



if you need to restart the service then use courtesty of brfransen

Code:
sudo sv restart smbd


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 9:49 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Just wanted to update this thread with the lesson's learned. R8 does not install samba by default. (the dev' might want to look into that).

During the upgrading my second box I installed samba from pacman and then ran the LinHes File Share from the menu.
It went through the screens and after going through the install screens it exited and configure "/etc/samba/smb.conf " correctly.

After thinking about this for awhile I figured out that on my first upgrade/install I ran the " LinHes File Share" program before I discovered that samba was not installed. So the " LinHes File Share" program didn't have the files need to create the "/etc/samba/smb.conf " Thus the problem I encountered.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 9:55 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
* Samba will not be installed by default
* The file share screen should install samba before it does the configure. I have run that process many many times and never had it fail. Do you by chance have the systemconfig.log from your first attempt?


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 10:04 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
jams,

Checked but do not have a ./tmp/systemconfig.log from the first install. Sorry.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 10:26 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Drats that would have been helpful.

As a test can you disable windows fileshareing with the service menu, see if it removes samba and if it doesn't remove it. Then enable it again and see if it works?

Be sure to backup your config if you decide to try this test.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 10:53 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Here is the log from the remove.

and the log for the reinstall ishere.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 11:33 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Those look normal to me.
Are things working as expected after the enable/disable?

If not then /tmp/systemconfig_debug.log would be useful for the enable.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 12:49 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Yea they looked pretty good to me. Everything runs fine after the reinstall.

I did notice something a little strange. After the remove I ran:
Code:
 pacman -Q |grep samba

and had nothing returned.

Then I run the reinstall and log says:
Code:
    Activating windows file sharing
    Checking samba for install
 -> samba is already installed, will not install
    Writing smb.conf.media
    Writing smb.conf.home
    Adding service nmbd
    Adding service smbd
    Restarting service nmbd
    Restarting service smbd
__End of fileshare configuration
   

Then after the reinstalled I ran : pacman -Q |grep samba again it it returns:
Code:
 pacman -Q |grep samba
 samba 3.6.6-1

So the installer says it's installed. But goes ahead and installs it, which is what you want. Maybe I looks for /etc/samba which I did not remove. Perhaps I should have.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 12:59 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
I bet if you look farther up in the log it will say it's not installed and installs it.
For various reasons that module runs things twice.


Top
 Profile  
 
 Post subject: Re: R8 Samba
PostPosted: Tue May 28, 2013 1:13 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Yep, I see it now.

Code:
    Checking samba for install
    Installing samba
    Writing smb.conf.media
    Writing smb.conf.home
    Adding service nmbd
    Adding service smbd
    Restarting service nmbd
    Restarting service smbd
__End of fileshare configuration


Thanks for the update ... I'm still having "issues" with the main menu any logs I can look at for that?


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu