View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 14 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Nov 01, 2013 10:51 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 68
i have a dragon 2 system that has been upgraded over the years. i still have the same motherboard, but hard drives have been added, along with a faster cpu and additional memory.

after reviewing forum posts on r8, i decided to give r8 a try. following the advice on the linhes wiki, i purchased a new drive, a crucial 64gb ssd drive for the install. as advised, i disconnected all drives other than the new destination drive.

i have been running r7.4 using the same ssd drive model with success

after an apparently successful installation via cd, the box would not boot, indicating that no boot devices were found

i am able to boot off of the r8 cd install disk and use that to boot the newly installed ssd drive

i have checked bios settings and verified that the bios sees the disk

i have duplicated this issue using an older traditional 500gb hard drive

i have not found any similar issues in this forum. has anyone encountered such an issue previously?

_________________
DH87MC i7-4770 8GB ram Xonar Essence ST LinHes 8.1


Last edited by welner on Sat Nov 02, 2013 8:44 am, edited 1 time in total.


Top
 Profile  
 
PostPosted: Sat Nov 02, 2013 8:43 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 68
it appears that the trick was to use fdisk to add the 'bootable' flag

_________________
DH87MC i7-4770 8GB ram Xonar Essence ST LinHes 8.1


Top
 Profile  
 
PostPosted: Fri Nov 08, 2013 3:24 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Thanks for the update.
Do you know which R8 iso was used?
the last one switched the way the partition was done on install, so that may have been the cause.


Top
 Profile  
 
PostPosted: Sat Nov 16, 2013 8:28 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 68
i downloaded via the "latest" link. the timestamp i have on the iso file is 10/18 at 5:33pm eastern

_________________
DH87MC i7-4770 8GB ram Xonar Essence ST LinHes 8.1


Top
 Profile  
 
PostPosted: Mon Nov 18, 2013 5:37 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Thx..thats would have been after the partitioning code was adjusted.


Top
 Profile  
 
PostPosted: Mon Dec 30, 2013 7:47 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
which partition did you set the boot flag on?


Top
 Profile  
 
PostPosted: Tue Dec 31, 2013 5:39 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 68
partition 1:

[root@mythtv ~]# fdisk -l /dev/sda

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 64.0 GB, 64023257088 bytes, 125045424 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 * 1 125045423 62522711+ ee GPT

_________________
DH87MC i7-4770 8GB ram Xonar Essence ST LinHes 8.1


Top
 Profile  
 
PostPosted: Tue Dec 31, 2013 8:09 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
Thanks, I will get that fixed shortly.
I don't have hardware that shows the problem, so wanted to confirm before making any changes.


Top
 Profile  
 
PostPosted: Wed Jan 01, 2014 9:14 am 
Offline
Joined: Wed Jan 01, 2014 9:08 am
Posts: 3
i tried to install LINHES 8.0 and 8.1 on 3 computers and it only worked on 1.

It didnt work on ASUS EEEBOX 1033 with a SSD drive and also on a relatively new ACER computer.

The cd install the program, but LINHES dont boot after installation.


Top
 Profile  
 
PostPosted: Wed Jan 01, 2014 10:08 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 68
using the installer disk, there is an option to boot from (not install) the disk that you had just performed the installation on

using this method, i was able to boot from the disk and see that the bootable flag was not set

can you confirm that after the install you are able to boot from the disk, and if so, run fdisk to see if the bootable flag is set or not?

doing so would help confirm that you are seeing the same issue that i encountered

_________________
DH87MC i7-4770 8GB ram Xonar Essence ST LinHes 8.1


Top
 Profile  
 
PostPosted: Sun Jan 12, 2014 6:57 pm 
Offline
Joined: Wed Jan 01, 2014 9:08 am
Posts: 3
I think all my problems are in link with UEFI bios. I had to update the bios (ver 0608) of the asus eb-1033 (windows 7 computer) to see the menu you was talking about. Prior to the update i had only the choice to boot the cd in UEFI mode (in this mode no option to boot from a existing installation) Now im able to boot in legacy mode (iso linux 4.05) and i now see the menu giving the option to boot a existing installation. I'm able to boot the ssd using the cd. I dont understand how you see the boot flag with fdisk command in the terminal. I say it not compatible with gpt.

I also have same problems with a ACER Aspire XC600 (oem with windows 8). They seem to have a bios for linux but im not able to boot freedos. (maybe i will have to reinstall windows to try the update). On this computer the linhes 8 version of october 2013 have the same symptoms as the asus (i have to boot the hard disk with the cd). When i try to install the 8.1 version january 2014, the kernel and installtion menu load but i get a black screen just after i click ok (at the end of the page where we see the www and irc links for help.).

I dont know if i will loose the windows bios key if i try to uptdate with the linux version of bios.

Mythbuntu was working on both the asus and acer prior to the linhes installation. I got no trouble to install linhes on an hp slim line pc with no UEFI bios.


Top
 Profile  
 
PostPosted: Mon Jan 13, 2014 8:42 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
There is a 8.1.1 iso on the website that might fix this problem.
I don't have a machine afflicted by this, so I was not able to test it.


Top
 Profile  
 
PostPosted: Mon Jan 13, 2014 4:28 pm 
Offline
Joined: Wed Jan 01, 2014 9:08 am
Posts: 3
Tried 8.1.1 but same problem. Can I check boot flag with fdisk if its gpt ?


Top
 Profile  
 
PostPosted: Tue Jan 03, 2017 4:59 pm 
Offline
Joined: Wed Jan 10, 2007 10:59 am
Posts: 25
So I realize this is a couple years old, but having an ancient dragon system myself that was sitting for the past 5 years and having decided to give it a whirl again, I too ran into this hang after a fresh install (Rev 8.4.2). After searching the web for a few days, I decided the root cause was the 10 year old motherboard using only BIOS and none of the fancier EFI/UEFI stuff of the modern day. So I think the linhes installer stuff does try to work around it, but somewhere along the way (as noted previously), the boot flag for the hard drive was never set active and thus, without a boot cd (or USB stick), the system thinks there's no OS installed.

Digging some more on this webpage: http://www.rodsbooks.com/gdisk/bios.html (and within that whole site), I decided that all of the tricks listed on this post didn't quite work anymore as fdisk was adjusting boot flags on the GPT partition things and not the legacy protective MBR thing (and yes, I'm rather linux newbian, hence the original dragon system setup and my best guesses of what's going on).

The big problem with trying current versions of fdisk to adjust the boot flag is that it tries to recognize the GPT partitions and adjust them. It doesn't even show a "Boot" column as seen in one of Welner's posts above (running fdisk -l /dev/sda).

I saw this occur with the linhes install disk (getting to a command prompt, etc) and other linux boot cds. I did finally notice this option from the rodsbooks website:

Quote:
Recent versions of parted enable you to type disk_toggle pmbr_boot on GPT disks to toggle the MBR boot flag on and off. (It will be on when you type print and the Disk Flags line reads pmbr_boot.) Do not attempt to set the "boot flag" on any GPT partition in parted or GParted; this will adjust the GPT partition, not the protective MBR.

Using the Ultimate Boot CD (Rev 5.3.6), I was able to find a command prompt and version of parted that allowed me to flip the MBR flag instead of the GPT flags and thus, could get the system to boot by itself. Mostly just annotating what I found here in case someone else stumbled upon it (or even me again).


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu