View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Jun 27, 2016 1:31 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1197
Location: Orlando FL
I tried upgrading through the service menu and it didn't show me that I had errors.
When I tried pacman -Syu from the command line I get an error about a package dependency from LinHES scripts to a package that I can't seem to remove.
Any Suggestions?
Everything is currently working just fine.
Code:
[mythtv@gimli ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: linhes-scripts: installing mkvtoolnix-cli (9.1.0-3) breaks dependency 'mkvtoolnix'

Code:
[mythtv@gimli ~]$ sudo pacman -Ss mkvtool
extra/mkvtoolnix-cli 9.1.0-3 [installed: 7.4.0-1]
    Set of tools to create, edit and inspect Matroska files
extra/mkvtoolnix-gui 9.1.0-3 [installed]
    Set of tools to create, edit and inspect Matroska files

Code:
[mythtv@gimli ~]$ sudo pacman -R mkvtoolnix-cli
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: LinHES-system: removing mkvtoolnix-cli breaks dependency 'mkvtoolnix-cli'
:: linhes-scripts: removing mkvtoolnix-cli breaks dependency 'mkvtoolnix'
:: mkvtoolnix-gui: removing mkvtoolnix-cli breaks dependency 'mkvtoolnix-cli'


Code:
[mythtv@gimli ~]$ locate mkvtoolnix
/data/storage/WDCWD5000AAKX-60U6AA0_WD-WMC2E7066366/pacman/pkg/mkvtoolnix-cli-7.4.0-1-x86_64.pkg.tar.xz
/data/storage/WDCWD5000AAKX-60U6AA0_WD-WMC2E7066366/pacman/pkg/mkvtoolnix-gtk-7.4.0-1-x86_64.pkg.tar.xz
/data/storage/disk0/pacman/pkg/mkvtoolnix-cli-7.4.0-1-x86_64.pkg.tar.xz
/data/storage/disk0/pacman/pkg/mkvtoolnix-gtk-7.4.0-1-x86_64.pkg.tar.xz
/home/mythtv/.config/mkvtoolnix
/home/mythtv/.config/mkvtoolnix/config
/home/mythtv/.config/mkvtoolnix/jobs
/home/mythtv/.config/mkvtoolnix/jobs/1.mmg
/home/mythtv/.config/mkvtoolnix/jobs/2.mmg
/home/mythtv/.config/mkvtoolnix/jobs/3.mmg
/home/mythtv/.config/mkvtoolnix/jobs/4.mmg
/home/mythtv/.config/mkvtoolnix/jobs/5.mmg
/home/mythtv/.config/mkvtoolnix/jobs/6.mmg
/home/mythtv/.config/mkvtoolnix/jobs/7.mmg
/home/mythtv/.config/mkvtoolnix/jobs/8.mmg
/usr/share/locale/ca/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/cs/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/de/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/es/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/eu/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/fr/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/it/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/ja/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/lt/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/nl/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/pl/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/pt/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/pt_BR/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/ru/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/tr/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/uk/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/zh_CN/LC_MESSAGES/mkvtoolnix.mo
/usr/share/locale/zh_TW/LC_MESSAGES/mkvtoolnix.mo
/usr/share/mime/packages/mkvtoolnix.xml
[mythtv@gimli ~]$

_________________
My System


Top
 Profile  
 
PostPosted: Tue Jun 28, 2016 7:19 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1001
Location: SC
Remove linhes-scripts. That is an old pkg that hasn't been updated since before R8. It is still in the repo but really should be removed. You would have installed it manually, what script did you need? If the script you need still works it can be moved to another package.


Top
 Profile  
 
PostPosted: Tue Jun 28, 2016 8:55 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1197
Location: Orlando FL
I have no idea why I have LinHES scripts installed. :o I really need to keep better notes.

_________________
My System


Top
 Profile  
 
PostPosted: Tue Jun 28, 2016 9:12 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1197
Location: Orlando FL
OK so doing some digging it looks like LinHES scripts was a tool to upgrade from 6.x to 7.x so that's when it got installed.

Removing just LinHES scripts allowed everything to upgrade!!!!
A teeny tiny bug appeared since the flag for "LinHES upgrades available in the service section" had been set in the GUI it was still there after the upgrade. I did a "check for updates" and nothing was available.

Thanks Brfransen for once again saving my bacon.

_________________
My System


Top
 Profile  
 
PostPosted: Wed Jun 29, 2016 6:21 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1001
Location: SC
R8.0 required a clean install and linhes-scripts would have to have been manually installed after that. It was part of the default install in R6 & 7.

The update notification can get out of sync if you do pacman from the command line. Selecting Cancel Updates should remove the update notification.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu