LinHES Forums

Failed to Extract Static Mount
Page 1 of 1

Author:  jlp_engineer [ Thu Aug 10, 2017 3:20 pm ]
Post subject:  Failed to Extract Static Mount

I have just pulled the rip cord on Mythbuntu, as development on it seems to have stopped, and the last released version was barely usable.

I have decided to give LinHES a try again. Much has changed I see, and for the better. I am glad I decided to give it another try. But I am sorry to say my initial installs have not gone well, at all. I keep getting the following error, and the installation just stops:

"Failed to extract static mount from /tmp/mount2.28.2.tar.xz" :shock:

The installation stops there and goes no further. My system is a 1U server of 2006 vintage, with an LSI MegaRAID SAS controller, where I have a RAID 0 disk (72 Gig) set as my boot drive, and a 3 disk RAID 0 array (3 x 2 Gig) for recording and video storage.

Initially, I thought my issues were due to a DNS hostname selection, but later found out that the setup only allows the selection of the first two NIC's in the system, and mine has four. So I shifted my Ethernet cable to ETH0, and solved that issue, but this other one has me stumped. There is nothing about this error in the forums or online anywhere. Could it have something to do with my selection of disk or sizes for the various partitions? I increased the OS to 10G, and doubled the database partition, and increased the Home partition to 50G.

Thanks for any suggestions.

Author:  brfransen [ Thu Aug 10, 2017 5:29 pm ]
Post subject:  Re: Failed to Extract Static Mount

After it fails open an xterm and confirm that /tmp/mount2.28.2.tar.xz exists. Also the ouput of df and tar -xvf /tmp/mount2.28.2.tar.xz -C /tmp/

Author:  jlp_engineer [ Fri Aug 11, 2017 2:21 pm ]
Post subject:  Re: Failed to Extract Static Mount


Stupid question: How do I open an xterm window? All I see is the installation splash screens...

I assume it is some key combination :?: :?

Author:  brfransen [ Fri Aug 11, 2017 2:34 pm ]
Post subject:  Re: Failed to Extract Static Mount


Author:  mattbatt [ Sun Mar 04, 2018 7:51 pm ]
Post subject:  Re: Failed to Extract Static Mount

I got this error too while building a test secondary backend in virtualbox.
The file does not exist in /tmp/
ls /tmp/
mv debug.log
mv status.log
systemd-private-{a long alpha-numeric string}-mysqld.service-cikr2J

It doesn't seem to be on the network, it failed to ping my router, so I will have a hard time copy and pasting things out of the installer and into the forum.

Since it's a VM I can just pause it and come back to it for more testing if you wish.


Author:  dborn [ Sat Sep 01, 2018 10:56 am ]
Post subject:  Re: Failed to Extract Static Mount

Hi all,

First post here...

After being on Mythbuntu 10.04 for way too long, I had high hopes in finally upgrading my MythTV setup (1 combined FE/BE + 3 slave BE) by switching to LinHES but I am hitting the same brick wall as the other two posters here.

This is trying to install on a brand new unformatted SSD 120GB drive and booting from a LinHES 8.5.1 image on a 16GB USB stick. (I'm keeping my current MythTV OS disk safely on a separate, unplugged HDD during this transition).

Judging by the number of views, this appears to be a hot topic even if it is getting little attention.
I've done the tests suggested here and all I can say is that the missing file is nowhere to be found on the filesystem.

If anybody has anything to contribute, now is the time, otherwise, I will be forced to look elsewhere for a suitable MythTV upgrade path (new install). LinHES seemed to be exactly what I was looking for (a MythTV "appliance" although I wouldn't give the install job to a non-techie) but this seems like such an obvious problem.

Thanks for any help,

Author:  brfransen [ Tue Sep 04, 2018 9:19 am ]
Post subject:  Re: Failed to Extract Static Mount

It isn't as obvious or as common as you think. I have done dozens of installs and upgrades and haven't been able to reproduce the issue which makes it difficult to track down. The file is in the image but for some reason on some systems it looks like it is getting removed after boot and before the install is started. I am making some changes to the install process that will hopefully resolve it.

Author:  mattbatt [ Thu Sep 06, 2018 9:08 am ]
Post subject:  Re: Failed to Extract Static Mount

Try doing a full format of the new SSD. Use a live Linux USB and do a full format. In the past (years ago) I had an issue where an install failed with LinHES and even though I selected to format the drive it didn't actually format the drive and I kept getting the same error. On a lark I used gparted to format the drive and everything installed fine after that.

Author:  brfransen [ Tue Sep 11, 2018 10:17 am ]
Post subject:  Re: Failed to Extract Static Mount

For those that have seen this issue please try the R8.5.2 ISO and report back.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group