LinHES Forums

R8.5.1 ISO Upgrade fail (Solved)
Page 1 of 1

Author:  Checkers327 [ Thu Jul 19, 2018 2:56 pm ]
Post subject:  R8.5.1 ISO Upgrade fail (Solved)


I did an upgrade to my mythbox to 8.5.1 yesterday by booting from a dvd and selecting "upgrade".

I think I was running Linhes 8.3, I'm not completely sure.

Now when I boot the machine, the backend runs and will record on it's own, but the neither mythwelcome, nor the frontend ever comes up. It just hangs and I can't open a shell, or enter setup.

I can get to the backend through the web interface and webmin.

The last error message I get on the screen before it freezes is /usr/lib/tmpfiles.d/systemd.conf: failed to replace specifiers /var/log/journal

As a test I also did a clean install of 8.5.1 on a blank hard drive with similar results, setup never starts, it just hangs on 'Starting Primary Mythbackend'

I did install 8.4.3 on the same drive as a comparison it 8.4.3 installed and runs fine.

Is anyone else having problems with 8.5.1?


Author:  mattbatt [ Thu Jul 19, 2018 10:36 pm ]
Post subject:  Re: R8.5.1 ISO Upgrade fail

Sorry to hear you are having problems. 8.5.1 has been out for almost 8 months now so your experience seems to be less common. You said you can get to the webpage of the backend right? From there you can pull logs from the left column "system" and then "logs".
What are the components in your machine some other users were having trouble with older graphics cards?

Author:  Checkers327 [ Fri Jul 20, 2018 2:13 pm ]
Post subject:  Re: R8.5.1 ISO Upgrade fail

I have and Asus motherboard with AMD Phenom(tm) II X6 1090T Processor on it and 8 gigs of ram.

The video card is an Nvidia Quadro FX 370 with 512 megs of ram. It does Vdpau great.
I also have an 8400GS around here somewhere, but I think the two cards are comparable.

The hard drives are a 2 terabyte Seagate and a 500 gig western digital.

The Xorg.log showed this:
[ 1201.991] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 1201.991] (EE) NVIDIA: system's kernel log for additional error messages and
[ 1201.991] (EE) NVIDIA: consult the NVIDIA README for details.
[ 1201.991] (EE) No devices detected.
[ 1201.991] (EE)
Fatal server error:
[ 1201.991] (EE) no screens found(EE)
[ 1201.991] (EE)
Please consult the The X.Org Foundation support at for help.

This was also in the kernel.log about 50 times:
64.775978] nvidia: disagrees about version of symbol module_layout


Author:  nbdwt73 [ Fri Jul 20, 2018 6:12 pm ]
Post subject:  Re: R8.5.1 ISO Upgrade fail

I had some very strange issues with 8.5.1 when installed from downloaded to a DVD (confirmed the download and image were good but to be sure I did it 3 times all with the same result). My logs contained entries that implied something wrong with my nvidia card (same as yours) which was not correct since it worked fine with an image that was upgraded from 8.4.X (instead of a direct install of 8.5.1) using different upgrade methods.

To find a solution I tried several things some of which worked. The first one was to install the last 8.4.X release and upgrade from there using pacman. Tested that more than once and all worked fine... I found another strange solution... After the install from the DVD try a pacman -Syu then a restart. That worked for me too. I didn't have time to dig further given work schedule...

Author:  knappster [ Sat Jul 21, 2018 7:53 am ]
Post subject:  Re: R8.5.1 ISO Upgrade fail

Do you know which version of the nvidia driver is installed? It looks like your card is supported by the 304 and 340 drivers, but not the current 390. If the wrong driver got installed during the upgrade somehow, that could be why it is not initializing. Your log suggests viewing the kernel log for more information. Have you found anything helpful there?

If you find that the 390 nvidia driver is installed, you can downgrade to the 340 series as follows:
sudo VGACARDTYPE="nvidia-340xx"

or the 304 series as follows:
sudo VGACARDTYPE="nvidia-304xx"

If you can't get a shell window, you can try to ssh in from another machine or try to get to a different runlevel mode, for example by pressing ctrl+alt+F1 or ctrl+alt+F2 from your keyboard and it should take you to a command prompt without any graphical interface.

Author:  Checkers327 [ Sun Jul 22, 2018 1:34 pm ]
Post subject:  Re: R8.5.1 ISO Upgrade fail (Solved)

This did it: "After the install from the DVD try a pacman -Syu then a restart. "

Thanks nbdwt73! and also knappster and mattbatt.

I couldn't open a shell on the frontend since it was frozen but I was able to run the pacman module inside Webmin and upgrade the system.


Author:  mattbatt [ Tue Jul 24, 2018 11:24 pm ]
Post subject:  Re: R8.5.1 ISO Upgrade fail (Solved)

There are lots of ways to fix Linux because it still breaks a lot.... Yay? :lol:

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group