View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Oct 22, 2018 12:11 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Just upgraded to 8.5.2 the upgrade went flawlessly!

However I was using an usb2 pvr which no longer works. It did work in 8.5.1 but I believe that it's no longer supported in the latest release. Is there anyway to get it to work? The device is recognized in dmesg but says " pvrusb2-context Tainted" It looks like the latest kernel no longer supports the device. But I'm not sure.

Code:
[    7.585157] pvrusb2: Hardware description: WinTV PVR USB2 Model 29xxx
[    7.585938] usbcore: registered new interface driver pvrusb2
[    7.585941] pvrusb2: V4L in-tree version:Hauppauge WinTV-PVR-USB2 MPEG2 Encoder/Tuner
[    7.585942] pvrusb2: Debug mask is 31 (0x1f)
[    7.707916] pvrusb2: Device microcontroller firmware (re)loaded; it should now reset and reconnect.
[    7.722621] pvrusb2: Device being rendered inoperable
[    9.731015] pvrusb2: Hardware description: WinTV PVR USB2 Model 29xxx
[    9.733023] pvrusb2: Binding ir_video to i2c address 0x18.
[    9.854921] saa7115 6-0021: saa7115 found @ 0x42 (pvrusb2_a)
[   10.006298] pvrusb2: Attached sub-driver saa7115
[   10.025527] msp3400 6-0040: MSP3445G-B8 found @ 0x80 (pvrusb2_a)
[   10.025656] pvrusb2: Attached sub-driver msp3400
[   10.062063] pvrusb2: Attached sub-driver tuner
[   10.072043] pvrusb2: Attached sub-driver tuner
[   10.109616] Modules linked in: msp3400 saa7115 snd_hda_codec_hdmi mousedev lgdt330x nvidia(PO) cx88_dvb cx88_vp3054_i2c videobuf2_dvb ir_rc5_decoder ir_lirc_codec lirc_dev rc_hauppauge tuner_simple tuner_types tda9887 tda8290 tuner snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss cx88_alsa pvrusb2 cx8800 cx8802 snd_hda_codec_realtek cx88xx kvm_amd tveeprom cx2341x rc_core dvb_core psmouse kvm videobuf2_dma_sg videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common videodev snd_hda_codec_generic r8169 i2c_algo_bit media ch341 usbserial irqbypass evdev input_leds led_class mac_hid k10temp drm snd_hda_intel mii sp5100_tco snd_hda_codec fjes shpchp i2c_piix4 snd_hda_core snd_hwdep snd_pcm acpi_cpufreq snd_timer snd tpm_tis tpm_tis_core tpm soundcore button
[   10.143991] CPU: 0 PID: 278 Comm: pvrusb2-context Tainted: P           O    4.9.109-1-ARCH #1
[   10.224621]  [<ffffffffa06ef058>] pvr2_eeprom_analyze+0x68/0x1e0 [pvrusb2]
[   10.229386]  [<ffffffffa06f604c>] pvr2_hdw_initialize+0xb6c/0xf70 [pvrusb2]
[   10.248311]  [<ffffffffa06fc5d0>] ? pvr2_context_destroy+0xd0/0xd0 [pvrusb2]
[   10.253006]  [<ffffffffa06fc668>] pvr2_context_thread_func+0x98/0x300 [pvrusb2]

Thanks.


Top
 Profile  
 
PostPosted: Tue Oct 23, 2018 9:36 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1119
Location: SC
Do you see any of the messages mentioned in this bug: https://bugzilla.kernel.org/show_bug.cgi?id=198675

Where you fully updated in R8.5.1 to the 4.9.73 kernel?

Does lsusb show the device? I am guessing the /dev/video* nodes are not being created?


Top
 Profile  
 
PostPosted: Wed Oct 24, 2018 12:26 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 931
Location: Lexington, Ky
Didn't see anything related to the bug report.
lsusb returns
Code:
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 2040:2900 Hauppauge
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

And you are correct that /dev/video* is not being created.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu