View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Dec 13, 2020 11:27 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 97
My wife has been complaining that if someone is watching something on the myth server/client tv, the video playback on the pi mythclient on the second floor is unwatchable. I really did not believe her, but looking into the issue today, it definitely is occuring.

Setup
Myth Server/Client
Myth Server/Client to Switch
Switch to Router #1
Router #1 is bridged via WIFI AC1200 connection to Router #2
Router #2 to PI Raspbian running MythFrontend

    *Playing recording on the first and second floor at the same time, the second floor pi client is unwatchable, while the first floor plays without issue.

    *There are no issues streaming to the pi client when the server/client machine is not playing a recoding locally.

    *The are no issues with the mythtv server/client playing a recording and streaming another recording to a laptop over a N300 wifi via the mythweb interface.

Not exactly sure where and how to debug this. Both File and Network IO are capable of multiple HD streams at the same time. The Server can support recording 3 shows at the same time while also playing back a forth.

Thoughts are towards the Client/Server mboard ethernet interface is not able to support 2 file IO streams, and UPD streams & handle PI callbacks.


Top
 Profile  
 
PostPosted: Mon Dec 14, 2020 7:45 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 114
That sounds like a sticky issue to resolve.

I would look for additional information to help diagnosing the root cause:

check the /var/log/$DATE logs and look for interesting messages
run "top" just before and during the issue on both boxes
run the command 'free' to check memory usage
run netstat or ifconfig to look for dropped packets or other network issues
move the pi to the same network to see if the issue persists.

_________________
DH87MC i7-4770 16GB ram Xonar Essence ST geforce 710 LinHes 8.6


Top
 Profile  
 
PostPosted: Tue Dec 15, 2020 3:24 am 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 97
I checked logs yesterday and nothing stuck out. I just got another data point today, looks like this is a switch or router issues when two clients are streaming.

Internet Stream to 1st floor TV
Internet to modem
modem to router #1
router#1 to 1st floor switch
1st floor switch to laptop
latop to tv

HDHOMERUN to 2nd floor TV
HDHOMERUN to 1st floor switch
1st floor switch to router#1
router#1 wifi bridged to router#2
router#2 to pi
pi to tv

The 2nd floor tv is unwatchable when steaming internet to the 1st floor tv. Since the switch can handle 3 streams from the HDHOMERUN to the myth server without hitting the router at all, the issue is pointing to the router, dd-wrt firmware, or configuration as the issue. Next test will probably perform some speed tests on one systems while streaming on another one. My guess is that some is wrong with the UDP processing.


Top
 Profile  
 
PostPosted: Thu Dec 17, 2020 12:39 pm 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 578
If you have a spare micro SD card, you could try libreelec on the pi with the pvr.mythtv plugin. It's been ages since I tried mythtfrontend on a pi (mythtv-light I presume?) but it seemed that kodi was much better with buffering than mythtv. If you still have problems it will at least confirm that it is not an OS / mythtv configuration issue on the pi.


Top
 Profile  
 
PostPosted: Thu Dec 17, 2020 3:17 pm 
Offline
Joined: Wed Jan 04, 2006 10:20 am
Posts: 383
Location: South New Jersey, USA
Could you temporarily relocate the upstairs TV down to the first floor for testing and connect directly to the 1st floor switch? Does your pi have an ethernet port that you could try?

_________________
LINHES 8.6.1 BE/FE - MSI K9N6SGM-V with AMD A64 X2 4600+, 4GB Ram. 1.5TB WD. HDHR Prime. Nvidia GT210. MCE remote.
FrontEnd - Dell Vostro 400 3.0GHz Core2Duo NVidia GeForce210. MCE Remote


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu