LinHES Forums

oss won't use Nvidia nForce2 sound
Page 1 of 1

Author:  graysky [ Sat Nov 28, 2009 6:26 am ]
Post subject:  oss won't use Nvidia nForce2 sound

I have an A7N8X deluxe with an onboard Nvidia nForce2 sound. ALSA doesn't work with the board under R6 (it worked fine under R5.5 though??) while playing back PVR-250 files. It does work with avi and mkv files via mplayer. Anyway, my solution under R6 has been to use OSS which I tried, but it doesn't work :(

I first tried from the service menu, but the I couldn't see debug info from there so I went to the shell and tested it.

# ossdetect -v
Detected Nvidia nForce2
USB support available in the system, adding USB driver
Detected Generic USB audio/MIDI device (BETA)

Looks like it's there, but when I go to use it:

# osstest
Sound subsystem and version: OSS 4.1 (b 1051/200902180218) (0x00040100)
Platform: Linux/i686 2.6.28-LinHES #1 SMP PREEMPT Mon Aug 17 05:38:57 UTC 2009

NOTICE! You don't have any audio devices available.
        It looks like your audio hardware was not recognized
        by OSS. Please contact 4Front technologies for help
        ( Don't forget to
        include your soundon.log file to the support request.

Link to flyspray task: ... ask_id=585

Author:  graysky [ Sat Nov 28, 2009 7:21 am ]
Post subject: 

I ended-up getting frustrated with this, shut it off and tried again. Upon rebooting, everything worked! I can't explain it. I always thought that the only time Linux needs a reboot was on a kernel update.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group