View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Wed Nov 16, 2011 3:06 am 
Offline
Joined: Wed Nov 16, 2011 2:14 am
Posts: 4
I have a Creative Labs Audigy eX sound card with livedrive breakout box. While the sound output works fine, I am not able to get the remote control (RM-900B) to work.

I'm running R7, 7.00.03.

Here's what I've tried:
adding the line
Code:
options snd-emu10k1 enable_ir=1

to my /etc/modprobe.d/alsa-base.conf

Executing
Code:
echo -en "\xf0\x00\x20\x21\x61\x00\x00\x00\x7f\x00\xf7" > /dev/snd/midiC0D1

as suggested on http://alsa.opensrc.org/Emu10k1 then trying again


According to the other guides I've read, at this point cat /dev/snd/midiC0D1 should print some garbage on the screen when a remote button is pressed. It does not.

irw gives no output, irrecord exits saying something to the effect of cannot find gap


Attempting to configure LIRC manually, by creating a /etc/runit/lirc.sh as suggested on the Wiki
My /etc/runit/lirc.sh is: (It seems to work fine.)
Code:
lircd -n -H livedrive_midi -d /dev/snd/midiC0D1 /home/mythtv/remote/lircd.conf.livedrive


After a sv start lircd, the output is
Quote:
Nov 16 02:30:00 silvermyth lircd: lircd(livedrive_midi) ready, using /var/run/lirc/lircd
Nov 16 02:30:01 silvermyth lircd: accepted new client on /var/run/lirc/lircd


What do I need to do to get the remote working? Is there a message in one of the logs I should be looking for? If any additional information is needed, I'll be happy to dig it up for you.

Thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Nov 17, 2011 10:49 am 
Offline
Joined: Wed Nov 16, 2011 2:14 am
Posts: 4
I'm still getting nothing out of a cat /dev/snd/midiC0D1

The LiveDrive has a red LED, apparently that is supposed to blink when the remote sends a command. It remains steady. (The remote lights up when pointed at a camera, so I suspect it is good.)

I'm working on the idea that it's an ALSA issue. I've run the update check to make sure I've got the latest everything, but I've had no luck. I'm going to try moving the card over to another machine and see if that does anything different.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 20, 2011 8:10 pm 
Offline
Joined: Wed Nov 16, 2011 2:14 am
Posts: 4
No luck moving the card to another machine. For people finding this thread with the same problem, maybe this will help...

When the enable_ir option is passed to the snd_emu10k1 module (in /etc/modprobe.d/alsa-base.conf), the file at /sys/modules/snd_emu10k1/enable_ir) changes from N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N to Y,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N (note first letter.)

This seems to confirm that the configuration is being read and set. (modprobe -c seems to read from the configuration file, but does not reflect the actual value.)

Stopping the snd_emu10k1 driver (modprobe -r snd_emu10k1) and then starting it with the verbose option (modprobe -v snd_emu10k1 produces this output (the last line confirms the settings are being passed):
Code:
insmod /lib/modules/2.6.39-LinHES/kernel/sound/core/snd-hwdep.ko.gz
insmod /lib/modules/2.6.39-LinHES/kernel/sound/synth/snd-util-mem.ko.gz
insmod /lib/modules/2.6.39-LinHES/kernel/sound/ac97_bus.ko.gz
insmod /lib/modules/2.6.39-LinHES/kernel/sound/pci/ac97/snd-ac97-codec.ko.gz
insmod /lib/modules/2.6.39-LinHES/kernel/sound/core/snd-rawmidi.ko.gz
insmod /lib/modules/2.6.39-LinHES/kernel/sound/pci/emu10k1/snd-emu10k1.ko.gz enable_ir=1 extin="0x3fc3" extout="0x1fc3"


The Live!Drive box needs power. The Daughter card (that the LiveDrive plugs in to) has a port to connect a floppy drive power connector on the card. After plugging in power and booting the machine, a red LED turned on on the Live!Drive optical out port. It stays on and does not turn off. I'm guessing this is the LED that's supposed to blink when the remote control is used.

One ubuntu user reported issues with the LIRC linedrive_midi driver and GCC 4.5.2 (At this moment, my box is showing GCC 4.5.1, which might be related.) http://ubuntuforums.org/showpost.php?p= ... ostcount=4

I know the remote is working because I pointed it at my cell phone camera and pushed a button. The IR LED lights up immediately. I know the IR receiver in the LiveDrive works as well, as I was able to measure a voltage difference on the output pin when a remote button was pressed. (I only tested the IR receiver, I was not able to track where the output pin went.)


Top
 Profile  
 
 Post subject: Re:
PostPosted: Sun Sep 08, 2013 10:05 am 
Offline
Joined: Sun Sep 08, 2013 2:50 am
Posts: 1
Puckdropper wrote:
I'm still getting nothing out of a cat /dev/snd/midiC0D1

The LiveDrive has a red
led lighting, apparently that is supposed to blink when the remote sends a command. It remains steady. (The remote lights up when pointed at a camera, so I suspect it is good.)

I'm working on the idea that it's an ALSA issue. I've run the update check to make sure I've got the latest everything, but I've had no luck. I'm going to try moving the card over to another machine and see if that does anything different.

Hello friend sorry for old thread reply but were you able to solve the issue? I am facing similar problem so please help me..


Top
 Profile  
 
PostPosted: Sat Sep 28, 2013 4:03 am 
Offline
Joined: Wed Nov 16, 2011 2:14 am
Posts: 4
I gave up and purchased a different USB remote control product.

If you do find a solution, I'd appreciate a note letting me know what it is.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu