View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Jan 07, 2013 7:18 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1319
Location: Orlando FL
I have a Pinnacle PCTV PCI card that has an V4L tuner (analog Cable) and a DVB tuner (ATSC/QAM). I recently started starting using the V4L side again and it has been giving me no end of headaches I forgot how much of a pain it was to set up these analog cards.
Here is my current problem. Alsa seems to flip around which order it want's to boot my Mohterboard audio, HDMI audio, and the audio capture device on this card causing me to have several recordings with no audio. I tried locking it into /dev/dsp2 by changing the index number to 2 instead of -2 in /etc/modprobe.d/alsa-base.conf it isn't working.
I know there is a way to do this somewhere I did it before I can't find the forum posting from several years ago when I got help before.
Thanks

_________________
My System


Top
 Profile  
 
PostPosted: Tue Jan 08, 2013 4:30 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 988
Location: Lexington, Ky
Had a lot of problems with video card swapping myself. In my case the solution is to create a udev rule. Not sure exactly how to apply that to your audio cards but may give you some ideas. Check out this link about using udev

http://linhes.org/projects/linhes/wiki/ ... using_udev

It might get you going in the right direction.

Tim


Top
 Profile  
 
PostPosted: Sun Jan 13, 2013 10:42 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1319
Location: Orlando FL
I saw this bugfix from Jams for R8 http://linhes.org/projects/linhes/repos ... 86d0709660 Does anybody know if this is what I need to do to fix my problem? Thanks.

_________________
My System


Top
 Profile  
 
PostPosted: Mon Jan 14, 2013 9:13 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1185
Location: SC
Yes autocard.py will generate udev rules for some of the cards in R8 LH systems. But I am not sure if it does analog audio.

Use the guide tscholl linked to understand the process.

Here are my rules for my 950Q:
Code:
# Create a symlink /dev/dvb/adapter-950Q pointing to digital side of 950Q
SUBSYSTEM=="dvb", ATTRS{manufacturer}=="Hauppauge", ATTRS{product}=="WinTV HVR-950", ATTRS{serial}=="4032666454", PROGRAM="/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter-950Q/%%s $${K#*.}'", SYMLINK+="%c"

# Create a symlink /dev/video-950Q pointing to analog video of 950Q
KERNEL=="video[0-9]*", SUBSYSTEM=="video4linux", ATTRS{manufacturer}=="Hauppauge", ATTRS{product}=="WinTV HVR-950", ATTRS{serial}=="4032666454", SYMLINK+="video-950Q"

# Create a symlink /dev/dsp-950Q pointing to analog audio of 950Q
KERNEL=="dsp[0-9]*", SUBSYSTEM=="sound", ATTRS{manufacturer}=="Hauppauge", ATTRS{product}=="WinTV HVR-950", ATTRS{serial}=="4032666454", SYMLINK+="dsp-950Q"

# Create a symlink /dev/vbi-950Q pointing to analog vbi of 950Q
KERNEL=="vbi[0-9]*", SUBSYSTEM=="video4linux", ATTRS{manufacturer}=="Hauppauge", ATTRS{product}=="WinTV HVR-950", ATTRS{serial}=="4032666454", SYMLINK+="vbi-950Q"


Top
 Profile  
 
PostPosted: Mon Jan 14, 2013 8:15 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1319
Location: Orlando FL
cool thanks

_________________
My System


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu