View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 11 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Feb 22, 2014 6:04 am 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
I have an already running LinHES 6.03 wife is using a lot.
I am now trying to make a new system with LinHES R8.1.1, Asus F1A55-V, 8GB RAM, 80GB HDU (just for testing purpose).
I think the Arch USB driver might have some configuration problem because of:
- USB memories when plugged in are mounted as read only and even reformatted show the previous content.
- A USB WiFi dongle is properly recognized but it does not connect to modem (WPA2).

The same Mobo is running perfectly with Windows 7 and Ubuntu 12.04.

Here is a useful part of lspci:
01:05.0 Multimedia video controller: Conexant Systems, Inc.
CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:05.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI
Video and Audio Decoder [Audio Port] (rev 05)
01:05.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI
Video and Audio Decoder [MPEG Port] (rev 05)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB
Host Controller

This is lsusb:
Bus 002 Device 002: ID 129b:1667 CyberTAN Technology 802.11bg
Bus 004 Device 003: ID 05dc:a761 Lexar Media, Inc.
Bus 006 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 007 Device 002: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The WiFi dongle config in dmesg appears as:
[ 11.707982] zd1211rw 2-1:1.0: firmware version 4725
[ 11.763749] zd1211rw 2-1:1.0: zd1211b chip 129b:1667 v4810 high 00-21-04 AL2230S_RF pa0 ---N-
[ 11.768749] cfg80211: Calling CRDA for country: DE
[ 11.773211] cfg80211: Regulatory domain changed to country: DE
[ 11.773219] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 11.773224] cfg80211: (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 11.773229] cfg80211: (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 11.773233] cfg80211: (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 11.773236] cfg80211: (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[ 11.829710] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Any clue?

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03


Last edited by dfdario on Mon Feb 24, 2014 1:39 pm, edited 2 times in total.


Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 11:02 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 677
On the Asus site there is firmware

F1A55-V BIOS 0902
1.Improve system stability.
2.Enhance compatibility with some USB devices.

http://www.asus.com/Motherboards/F1A55V/#support

Upgrade the firmware and then test again


Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 11:34 am 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
Thanks RacerX for the quick answer.
I already updated the Bios to the latest version available r.1005.
There must be something tricky I am not realizing yet.
Trying to install LinHES 6.03 or even 7.4 the system got stuck.
The 6.03 due to some ATI compatibility issue, while 7.4 I am not investigated further.
LinHES 8.1.1 works pretty well but the WiFi and USB.
I would have Hauppauge remote issue as well and furthermore wine installable would be appreciated but for that I have to wait for v.8.2.

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03


Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 12:20 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 677
Could you post

lspci -v


Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 1:59 pm 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
See attachment.


Attachments
lspci.tar.gz [167 Bytes]
Downloaded 123 times

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03
Top
 Profile  
 
PostPosted: Sat Feb 22, 2014 10:51 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1196
Location: Orlando FL
I had great success upgrading with the virtual machine technique described here. viewtopic.php?f=24&t=23938&p=138291&hilit=virtual+machine#p138291

_________________
My System


Top
 Profile  
 
PostPosted: Sun Feb 23, 2014 6:56 am 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
I tryed on another windows 7 Intel machine with virtualbox and no issues.
Unfortunately if I try to install LinHES on the current F1A55 PC and Ubuntu 12.04 I have UUID and ro problems at boot I don't want investigate further.

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03


Top
 Profile  
 
PostPosted: Sun Feb 23, 2014 12:52 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 677
I think the issue leans more toward the usb controller ASM1042. It's not very well supported in Linux but it works fine in Windows . Rather than trying a different box, why not test a usb card and see if that works better...


Top
 Profile  
 
PostPosted: Sun Feb 23, 2014 1:21 pm 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
Here attached some hints.
Particular interest is in dmesg_tail.txt where ther is an error happened in mythinstall when WiFi dongle has been enabled.

Even disabling ASM1042 from BIOS the result is the same

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf
reports that the resourse is busy


Attachments
lists.tar.gz [110 KiB]
Downloaded 105 times

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03
Top
 Profile  
 
PostPosted: Mon Feb 24, 2014 1:36 pm 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
The solution was to exec:
sudo wpa_supplicant -B -i wlan0 -c /etc/net/ifaces/wlan0/wpa_supplicant.conf
then
sudo dhcpcd wlan0

The problem now is how to make the above executet by default from the system everytime I config the network from UI
Is there anyone can tell me how to do this?

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03


Top
 Profile  
 
PostPosted: Fri Mar 07, 2014 6:32 am 
Offline
Joined: Tue May 11, 2010 2:51 am
Posts: 31
Location: Turin - Italy
Solution for WLAN0:
In /etc/net/ create executable script named netup-pre with the following content
Code:
#!/bin/sh
pkill wpa_supplicant
pkill dhcpcd
ifconfig wlan0 down
ifconfig wlan0 up
wpa_supplicant -B -Dwext -iwlan0 -c/etc/net/ifaces/wlan0/wpa_supplicant.conf
dhcpcd wlan0


To solve USB plugged devices are seen as read only just run:
sudo pacman -S ntfs-3g

_________________
MBE - ASUS M2NPLUS PRO | RAM 4GB | HD 1TB | 4xHVR-1300 | LinHES 6.03
FE -D945GLF2 | RAM 2GB | HD 250GB | LinHES 6.03


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu