View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 9 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Apr 13, 2014 12:07 am 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
I built up a new system hoping to use wifi rather than ethernet cables (just to reduce the number of cables to apease the wife).
I am using a Tp-Link TL-WN881ND PCIe card which is supposed to be fully Linux compatible as it uses the Atheros chip set. The Kernel driver is ath9k. I did install Mythbuntu and it recognised and was able to use the card so I know the card is good.(but I prefer Linhes to Mythbuntu)
I set LINHES up using eth0 as the wifi wouldn't connect. If I start the machine with eth0 off and wlan0 on the frontend can't find the backend but I think if I change the IP to 127.0.0.1 that might fix that as I am running a combined fronted/backend configuration.
If I follow the ArchLinux wifi manual setup https://wiki.archlinux.org/index.php/Wi ... nual_setup I can see the network SSID and I get channel and everything appears to be authenticated using WPA. Wpa_supplicant.conf has the SSID and password . When I disconnected the ethernet cable I couldn't get a ping through to the internet.
So I started thinking it shouldn't be this hard. This reminds me of the handstands we had to do 10+ years ago to get hardware recognised and useable. So I started looking for a network manager and pacman couldn't find netctl, nicd, connman or network manager. So either I am using the wrong name or the devs have blocked these programs from the repository.
Anyone got an easy way to setup a wifi card?

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Sun Apr 13, 2014 10:16 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 389
Location: Fargo, ND, USA
The only reason I ask this is because it happens so often and I could not determine it by reading your post. Did you try connecting to your wifi by using the LinHES Network settings menu?

If your system dos not reboot properly you are suppose to be able to access the LinHES Network settings menu threw a xterm menu by using the command: "mythinstall -s network"

TVBox

_________________
TVBox
LinHES R8.4


Top
 Profile  
 
PostPosted: Mon Apr 14, 2014 12:44 am 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
I had used the network setup and like I said unless ethernet is plugged in she doesn't work.
If the ethernet cable is unplugged then the system doesn't start because it can't find the backend (because the wifi isn't working). running myth install -s network brings up the Network setting page but still no wifi.

TVBox wrote:
The only reason I ask this is because it happens so often


If this happens so often then it's not quite a simple or obvious as it might be?

I will have little chance over the next week to explore this anymore but should I find anything I shall post my findings as I can find precious little to help me so far.

Eddy

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Mon Apr 14, 2014 7:19 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 993
Location: SC
After running the mythinstall network module either from the menus or command line check the /tmp/systemconfig_debug.log.


Top
 Profile  
 
PostPosted: Sat May 24, 2014 10:21 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
brfransen wrote:
After running the mythinstall network module either from the menus or command line check the /tmp/systemconfig_debug.log.


There is no systemconfig_debug.log in the tmp folder
Code:
root@mythtv tmp]# ls
a.log  appletrailer.xml  be_check.log  cron.4zqW0f  cron.gOT5Zy  cron.KDAFo9  oprhan.result  remotes.log  scan_report  tvdb_api_1000
[root@mythtv tmp]#

I did however make a little progress. I wrote my own wpa_supplicant.conf file and started it
Code:
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Then with the ethernet cable disconnected i can ping to the outside world and my router shows in connected to the wireless network. However I can not get Apple Trailers or Radio streams but that maybe due to the wireless service not starting automatically??

One thing I did notice was the wpa_supplicant.conf location is different in LinHes compared to the Arch-Linux wiki, I did try it in /etc and also /etc/wpasupplicant but that made no difference.
A system reboot kills the connection and it doesn't restart without the wpa_supplicant command. So how do I make LinHes start the wireless service automatically?

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Mon Jun 02, 2014 11:44 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
I have the wlan set as default and active. I also have eth0 not set as active otherwise and this causes a "waiting to connect to backend" message. If I set eth0 as active then the system boots normally. Then I have to shutdown eth0 and start spa_supplicant.
With eth0 off (as set) and I turn wpa_supplicant on from the terminal then the wifi works normally. Then I have to restart the backend (alt 3) to get the backend to connect.


I'm not sure why but the systemconfig_debug.log wasn't there last time but this time: (I have cutout the pass phrases)

This for eth0 set to off in Linhes\Network settings, then I turn wpa_supplicant on from a terminal (alt x) and then restart the backend (alt 3).

I just can't get it to start without the above steps
Code:
[root@mythtv tmp]# more -f systemconfig_debug.log
06-03 15:59 - root - DEBUG - ______START OF DEBUG______
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 192.168.0.14 as default ip
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - INFO - ____Start of network____
06-03 15:59 - root - INFO -     Setting up the network
06-03 15:59 - root - INFO -     Checking nss-mdns for install
06-03 15:59 - root - DEBUG -     grep -q nss-mdns /etc/blacklist.package
06-03 15:59 - root - DEBUG -     (256, '')
06-03 15:59 - root - DEBUG -     Checking if nss-mdnsis installed
06-03 15:59 - root - DEBUG -     pacman -Q nss-mdns
06-03 15:59 - root - DEBUG -     (0, 'nss-mdns 0.10-5')
06-03 15:59 - root - INFO -     nss-mdns is already installed, will not install
06-03 15:59 - root - INFO -     Checking avahi for install
06-03 15:59 - root - DEBUG -     grep -q avahi /etc/blacklist.package
06-03 15:59 - root - DEBUG -     (256, '')
06-03 15:59 - root - DEBUG -     Checking if avahiis installed
06-03 15:59 - root - DEBUG -     pacman -Q avahi
06-03 15:59 - root - DEBUG -     (0, 'avahi 0.6.31-3')
06-03 15:59 - root - INFO -     avahi is already installed, will not install
06-03 15:59 - root - INFO -     Adding mdns4 to nsswitch.conf
06-03 15:59 - root - DEBUG -     sed -i "s/hosts:.*$/hosts: files mdns4_minimal dns mdns4/" /etc/nsswitch.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     _Start of hostname_change_check
06-03 15:59 - root - DEBUG -     Old hostname: mythtv
06-03 15:59 - root - DEBUG -     New hostname: mythtv
06-03 15:59 - root - DEBUG -     old and new hostnames matched, leaving things along
06-03 15:59 - root - DEBUG -   __End of hostname_change_check
06-03 15:59 - root - DEBUG -    _Start of setup_hostname
06-03 15:59 - root - INFO -     Setting the hostname to mythtv
06-03 15:59 - root - DEBUG -      echo mythtv > /etc/hostname
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     cat /etc/hosts | grep -v 127.0.0.1 | grep -v mythtv > /tmp/hosts
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     not using dhcp
06-03 15:59 - root - DEBUG -      echo 127.0.0.1 localhost  > /etc/hosts
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -      echo 192.168.0.14 mythtv  >> /etc/hosts
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     cat /tmp/hosts >> /etc/hosts
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     _Start of find_active
06-03 15:59 - root - DEBUG -     Removing /etc/resolv.conf
06-03 15:59 - root - DEBUG -      echo search lan > /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -      echo search local >> /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -      echo nameserver 127.0.0.1 >> /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     HostActiveeth0 is not defined
06-03 15:59 - root - INFO -     Disabling eth0
06-03 15:59 - root - DEBUG -     sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' /etc/net/ifaces/eth0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' /etc/net/ifaces/eth0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     /sbin/ifconfig eth0 down
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     ip address flush eth0
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     HostActiveeth1 is not defined
06-03 15:59 - root - INFO -     Disabling eth1
06-03 15:59 - root - DEBUG -     sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' /etc/net/ifaces/eth1/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/eth1/options: No such file or directory")
06-03 15:59 - root - DEBUG -     sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' /etc/net/ifaces/eth1/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/eth1/options: No such file or directory")
06-03 15:59 - root - DEBUG -     /sbin/ifconfig eth1 down
06-03 15:59 - root - DEBUG -     (65280, 'eth1: ERROR while getting interface flags: No such device')
06-03 15:59 - root - DEBUG -     ip address flush eth1
06-03 15:59 - root - DEBUG -     (256, 'Device "eth1" does not exist.')
06-03 15:59 - root - DEBUG -      /sbin/ifconfig wlan0
06-03 15:59 - root - DEBUG -     (0, 'wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500  metric 1\n        inet 192.168.0.14  netmask 255.255.255.0  broadcast 192.168.0.255\n        inet6 fe80::c24a:ff:fe51:93ce  prefixlen 64  scopeid 0x20<link>\n        ether c0:4a:00:51:93:ce  txqueuelen 1000  (Ethernet)\n        RX packets 133  bytes 14705 (14.3 KiB)\n        RX errors 0  dropped 0  overruns 0  frame 0\n        TX packets 104  bytes 18815 (18.3 KiB)\n        TX errors 0  dropped 0 overruns
0  carrier 0  collisions 0\n')
06-03 15:59 - root - DEBUG -     _Start of setup_interface for wlan0
06-03 15:59 - root - DEBUG -      HostUseEncryption:WPA
06-03 15:59 - root - DEBUG -      Hostip:192.168.0.14
06-03 15:59 - root - DEBUG -      HostMTU:False
06-03 15:59 - root - DEBUG -      HostDNS:208.67.222.222
06-03 15:59 - root - DEBUG -      Hostnetmask:/24    255.255.255.0
06-03 15:59 - root - DEBUG -      HostUSEDHCP:1
06-03 15:59 - root - DEBUG -      HOST_iswireless:1
06-03 15:59 - root - DEBUG -      HostESSID:Orb
06-03 15:59 - root - DEBUG -      HostActive:1
06-03 15:59 - root - DEBUG -      HostGW:192.168.0.1
06-03 15:59 - root - INFO -     wlan0 wireless: 1
06-03 15:59 - root - DEBUG -    Could not create /etc/net/ifaces
06-03 15:59 - root - INFO -     Activating wlan0
06-03 15:59 - root - DEBUG -     sed -i -e 's/^ONBOOT=.*$/ONBOOT=yes/g' /etc/net/ifaces/wlan0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     sed -i -e 's/^DISABLED=.*$/DISABLED=no/g' /etc/net/ifaces/wlan0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - INFO -     Enabling wireless extensions
06-03 15:59 - root - DEBUG -      sed -i -e 's/^CONFIG_WIRELESS=.*$/CONFIG_WIRLESS=yes/g'  /etc/net/ifaces/wlan0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - INFO -     wlan0 will use wpa for encryption
06-03 15:59 - root - DEBUG -     writing out wpa_supplicant.conf file
06-03 15:59 - root - DEBUG -
#This file was automaticly generated, any changes may be lost
ctrl_interface=/var/run/wpa_supplicant
network={
    ssid="Orb"
    # Preshared key as an ASCII passphrase
 scan_ssid=1
    key_mgmt=WPA-EAP WPA-PSK NONE
    pairwise=CCMP TKIP
    proto=WPA RSN
}
06-03 15:59 - root - INFO -     Using static ip address of 192.168.0.14
06-03 15:59 - root - DEBUG -      sed -i -e 's/^BOOTPROTO=.*$/BOOTPROTO=static/g' /etc/net/ifaces/wlan0/options
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     echo "default via 192.168.0.1" > /etc/net/ifaces/wlan0/ipv4route
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     echo "192.168.0.14/24" > /etc/net/ifaces/wlan0/ipv4address
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - INFO -     Adding 208.67.222.222 for DNS
06-03 15:59 - root - DEBUG -     grep -q local /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     grep -q 208.67.222.222 /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (256, '')
06-03 15:59 - root - DEBUG -      echo "nameserver 208.67.222.222" >> /etc/resolv.conf
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - INFO -     Using default mtu value
06-03 15:59 - root - DEBUG -     sed -i '/^mtu.*$/d' /etc/net/ifaces/wlan0/iplink
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/wlan0/iplink: No such file or directory")
06-03 15:59 - root - DEBUG -     HostActivewlan1 is not defined
06-03 15:59 - root - INFO -     Disabling wlan1
06-03 15:59 - root - DEBUG -     sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' /etc/net/ifaces/wlan1/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/wlan1/options: No such file or directory")
06-03 15:59 - root - DEBUG -     sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' /etc/net/ifaces/wlan1/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/wlan1/options: No such file or directory")
06-03 15:59 - root - DEBUG -     /sbin/ifconfig wlan1 down
06-03 15:59 - root - DEBUG -     (65280, 'wlan1: ERROR while getting interface flags: No such device')
06-03 15:59 - root - DEBUG -     ip address flush wlan1
06-03 15:59 - root - DEBUG -     (256, 'Device "wlan1" does not exist.')
06-03 15:59 - root - DEBUG -     HostActiveath0 is not defined
06-03 15:59 - root - INFO -     Disabling ath0
06-03 15:59 - root - DEBUG -     sed -i -e 's/^ONBOOT=.*$/ONBOOT=no/g' /etc/net/ifaces/ath0/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/ath0/options: No such file or directory")
06-03 15:59 - root - DEBUG -     sed -i -e 's/^DISABLED=.*$/DISABLED=yes/g' /etc/net/ifaces/ath0/options
06-03 15:59 - root - DEBUG -     (512, "sed: can't read /etc/net/ifaces/ath0/options: No such file or directory")
06-03 15:59 - root - DEBUG -     /sbin/ifconfig ath0 down
06-03 15:59 - root - DEBUG -     (65280, 'ath0: ERROR while getting interface flags: No such device')
06-03 15:59 - root - DEBUG -     ip address flush ath0
06-03 15:59 - root - DEBUG -     (256, 'Device "ath0" does not exist.')
06-03 15:59 - root - DEBUG -     Start of VNC/NETBOOT check
06-03 15:59 - root - INFO -     Restarting network
06-03 15:59 - root - DEBUG -     /etc/net/scripts/network.init reload
06-03 15:59 - root - DEBUG -     (0, 'Computing interface groups: .. 2 interfaces to process\nStopping group 4/deplog (0 interfaces)\nStopping group 3/indeplog (0 interfaces)\nStopping group 2/hostedphys (0 interfaces)\nProcessing /etc/net/vlantab: empty.\nStopping group 1/realphys (1 interfaces)\n\tStopping wlan0: ...OK\nStopping group 0/virtual (1 interfaces)\n\tStopping lo: .OK\nStarting group 0/virtual (1 interfaces)\n\tStarting lo: ....OK\nStarting group 1/realphys (1 interfaces)\n\tStarting wlan0
 ......OK\nProcessing /etc/net/vlantab: empty.\nStarting group 2/hostedphys (0 interfaces)\nStarting group 3/indeplog (0 interfaces)\nStarting group 4/deplog (0 interfaces)')
06-03 15:59 - root - DEBUG -     /etc/net/scripts/network.init restart
06-03 15:59 - root - DEBUG -     (0, 'Computing interface groups: .. 2 interfaces found\nProcessing /etc/net/vlantab: empty.\nStopping group 1/realphys (1 interfaces)\n\tStopping wlan0: ...OK\nStopping group 0/virtual (1 interfaces)\n\tStopping lo: .OK\nComputing interface groups: .. 2 interfaces found\nStarting group 0/virtual (1 interfaces)\n\tStarting lo: ....OK\nStarting group 1/realphys (1 interfaces)\n\tStarting wlan0: ......OK\nProcessing /etc/net/vlantab: empty.')
06-03 15:59 - root - INFO - __End of network

06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 192.168.0.14 as default ip
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     Using 1 as dhcp value for wlan0
06-03 15:59 - root - DEBUG -     echo Xcursor.size: 48 > /home/mythtv/.Xdefaults
06-03 15:59 - root - DEBUG -     (0, '')
06-03 15:59 - root - DEBUG -     /usr/MythVantage/bin/xconfig.sh
06-03 15:59 - root - DEBUG -     (0, 'Detected Intel as the video card type\nInstalling Intel driver\n  Checking for xf86-video-intel in cache or online\nRunning plymouth_config')
06-03 15:59 - root - INFO - ______Start of hostype config_____
06-03 15:59 - root - DEBUG - ______Start of services______
06-03 15:59 - root - DEBUG - __End services
06-03 15:59 - root - INFO - Master backend system being configured
06-03 15:59 - root - INFO - Not changing ntp configuration
06-03 15:59 - root - INFO -     Trying to link /usr/LH/bin/myth_status.sh ->  /etc/profile.d/z_myth_status.sh
06-03 15:59 - root - INFO -     /etc/profile.d/z_myth_status.sh is present, skipping...
06-03 15:59 - root - DEBUG -     Removing /etc/rsyslog.d/client.conf
06-03 15:59 - root - DEBUG - *     Could not remove /etc/rsyslog.d/client.conf
06-03 15:59 - root - INFO - ____Enabling rsyslog network____
06-03 15:59 - root - INFO -     Restarting service rsyslog

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Tue Jun 03, 2014 8:56 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1196
Location: Orlando FL
can you disable the wired nic in bios making the WiFi nic eth0?

_________________
My System


Top
 Profile  
 
PostPosted: Sat Jun 07, 2014 8:09 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
mattbatt wrote:
can you disable the wired nic in bios making the WiFi nic eth0?


No option for turning the nic off :( ….. Thanks for the thought.

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Sun Jun 08, 2014 7:04 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 884
Location: Lexington, Ky
If your Motherboad is a ASUS P7H55-M Pro

In the BIOS Menu under | Advanced Settings | Onboard Devices

There is the option to enable or disable the Onboard LAN port.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu