View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 14 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Feb 04, 2016 9:52 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
I am getting the following error 2 to 5 times a week on my backend/frontend system:

Code:
2016-02-04T19:32:14.310187-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:1280 (Init) TV: Created TvPlayWindow.
2016-02-04T19:32:14.311723-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:2225 (HandleStateChange) TV: Attempting to change from None to WatchingPreRecorded
2016-02-04T19:32:14.513451-06:00 mythfrontend[17837]: N CoreContext audioplayer.cpp:164 (ReinitAudio) AudioPlayer: Enabling Audio
2016-02-04T19:32:14.613778-06:00 mythfrontend[17837]: I CoreContext avformatdecoder.cpp:2141 (ScanStreams) AFD: codec AC3 has 6 channels
2016-02-04T19:32:14.615015-06:00 mythfrontend[17837]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0x32855e0, id(AC3) type(Audio)
2016-02-04T19:32:14.616227-06:00 mythfrontend[17837]: I CoreContext avformatdecoder.cpp:2141 (ScanStreams) AFD: codec AC3 has 2 channels
2016-02-04T19:32:14.617609-06:00 mythfrontend[17837]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0x16a60e0, id(AC3) type(Audio)
2016-02-04T19:32:14.618034-06:00 mythfrontend[17837]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0xdf20be0, id(MPEG2VIDEO) type(Video)
2016-02-04T19:32:14.618468-06:00 mythfrontend[17837]: I CoreContext audio/audiooutputbase.cpp:792 (Reconfigure) AOBase: Opening audio device 'hdmi:CARD=NVidia,DEV=1' ch 2(6) sr 48000 sf signed 32 bit reenc 0
2016-02-04T19:32:14.813618-06:00 mythfrontend[17837]: I CoreContext mythpainter_ogl.cpp:62 (ClearCache) Clearing OpenGL painter cache.
2016-02-04T19:32:15.013889-06:00 mythfrontend[17837]: I CoreContext mythrender_vdpau.cpp:1717 (CreatePresentationSurfaces) VDPAU: Created 2 output surfaces.
2016-02-04T19:32:15.014196-06:00 mythfrontend[17837]: I CoreContext mythrender_vdpau.cpp:424 (Create) VDPAU: Created VDPAU render device 1920x1080
2016-02-04T19:32:15.314461-06:00 mythfrontend[17837]: N CoreContext mythplayer.cpp:526 (CheckExtraAudioDecode) Player(2): Forcing decode extra audio option on (Video method requires it).
2016-02-04T19:32:15.315214-06:00 mythfrontend[17837]: I CoreContext mythplayer.cpp:1785 (InitAVSync) Player(2): Video timing method: USleep with busy wait
2016-02-04T19:32:15.315632-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:5635 (StartPlayer) TV: Created player.
2016-02-04T19:32:15.316044-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:2485 (HandleStateChange) TV: Changing from None to WatchingPreRecorded
2016-02-04T19:32:15.316450-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:2576 (HandleStateChange) TV: Main UI disabled.
2016-02-04T19:32:15.316855-06:00 mythfrontend[17837]: I CoreContext tv_play.cpp:412 (StartTV) TV: Entering main playback loop.
2016-02-04T19:32:15.317878-06:00 mythfrontend[17837]: I CoreContext mythrender_vdpau.cpp:610 (CheckOutputSurfaces) VDPAU: Added 2 output surfaces (total 4, max 4)
2016-02-04T19:36:50.242152-06:00 mythfrontend[17837]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(2): Decoder timed out waiting for free video buffers.


Playing the same video does not reproduce the error. But the a different episode of the same tv program usually triggers the freeze. It could also just be the first show that is watched after the system has gone though an extended period of inactivity.

The line in the log that always precursor to the freeze is is always:
Code:
mythrender_vdpau.cpp:610 (CheckOutputSurfaces) VDPAU: Added 2 output surfaces (total 4, max 4)


always 4/4 surfaces

Within 5 minutes mplayer crashes and the frontend is semi unresponsive. Note that the backend seems total unaffected and in-process and future recordings are oblivious to the the frontend issues.

Performing a sv restart frontend or a pkill X brings back the frontend without issue as one would expect. However when myth front plays the next video, the video plays fine, but the mythfrontend has no sound and reports that the sound device is not available. The sound device is the HDMI output from the video card, which is a new ZOTAC GeForce GT 730 passive 1GB 64-Bit DDR3.

Xymon reports a relatively high temperature for the GPUs at the time of the freeze based my system, but these GPU temperatures are only mid range on the nvida temperature scale. The jump is from 29C to a max of 38C.

Rebooting the system corrects the sound problem, and the issue goes away from the next 24 to 72 hours.

I saw a thread that indicated some AMD boards set the minimum PCI bus to a level that starves the video cards, thus I bumped the minimum frequency up to the recommended minimum frequency in the thread. Not sure if this reduced the frequency of the issue or not.


Top
 Profile  
 
PostPosted: Sat Feb 06, 2016 11:38 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
The problem is now happening in on my shows now... :(

After a video freeze, the audio is not available became the device is still locked by the previous mythplayer.
Code:
2016-02-06T23:53:41.066799-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:1063 (TV) TV: Creating TV object
2016-02-06T23:53:41.166648-06:00 mythfrontend[7772]: N CoreContext mythmainwindow.cpp:2737 (PauseIdleTimer) Suspending idle timer
2016-02-06T23:53:41.167914-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:1280 (Init) TV: Created TvPlayWindow.
2016-02-06T23:53:41.170340-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:2225 (HandleStateChange) TV: Attempting to change from None to WatchingPreRecorded
2016-02-06T23:53:41.371833-06:00 mythfrontend[7772]: E CoreContext audio/audiooutputalsa.cpp:340 (GetOutputSettings) ALSA: snd_pcm_open("hdmi:CARD=NVidia,DEV=1"): Device or resource busy
2016-02-06T23:53:41.373414-06:00 mythfrontend[7772]: N CoreContext audioplayer.cpp:164 (ReinitAudio) AudioPlayer: Enabling Audio
2016-02-06T23:53:41.476668-06:00 mythfrontend[7772]: I CoreContext avformatdecoder.cpp:2141 (ScanStreams) AFD: codec AC3 has 2 channels
2016-02-06T23:53:41.479125-06:00 mythfrontend[7772]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0x7abfb00, id(AC3) type(Audio)
2016-02-06T23:53:41.483162-06:00 mythfrontend[7772]: I CoreContext avformatdecoder.cpp:2141 (ScanStreams) AFD: codec AC3 has 1 channels
2016-02-06T23:53:41.484022-06:00 mythfrontend[7772]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0x7accb20, id(AC3) type(Audio)
2016-02-06T23:53:41.484578-06:00 mythfrontend[7772]: I CoreContext mythrender_vdpau.cpp:1751 (CheckHardwareSupport) VDPAU: Version 1
2016-02-06T23:53:41.484957-06:00 mythfrontend[7772]: I CoreContext mythrender_vdpau.cpp:1762 (CheckHardwareSupport) VDPAU: Information NVIDIA VDPAU Driver Shared Library  355.11  Wed Aug 26 16:05:52 PDT 2015
2016-02-06T23:53:41.485311-06:00 mythfrontend[7772]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AFD: Opened codec 0x7acc0c0, id(MPEG2VIDEO) type(Video)
2016-02-06T23:53:41.485669-06:00 mythfrontend[7772]: I CoreContext audio/audiooutputbase.cpp:792 (Reconfigure) AOBase: Opening audio device 'hdmi:CARD=NVidia,DEV=1' ch 2(2) sr 48000 sf signed 16 bit reenc 0
2016-02-06T23:53:41.486037-06:00 mythfrontend[7772]: E CoreContext audio/audiooutputalsa.cpp:463 (OpenDevice) ALSA: snd_pcm_open("hdmi:CARD=NVidia,DEV=1"): Device or resource busy
2016-02-06T23:53:41.486393-06:00 mythfrontend[7772]: E CoreContext audio/audiooutput.cpp:249 (Error) AudioOutput Error: Aborting reconfigure
2016-02-06T23:53:41.486747-06:00 mythfrontend[7772]: N CoreContext audioplayer.cpp:157 (ReinitAudio) AudioPlayer: Disabling Audio, reason is: Aborting reconfigure
2016-02-06T23:53:41.585294-06:00 mythfrontend[7772]: I CoreContext mythpainter_ogl.cpp:62 (ClearCache) Clearing OpenGL painter cache.
2016-02-06T23:53:41.685664-06:00 mythfrontend[7772]: I CoreContext mythrender_vdpau.cpp:1717 (CreatePresentationSurfaces) VDPAU: Created 2 output surfaces.
2016-02-06T23:53:41.685677-06:00 mythfrontend[7772]: I CoreContext mythrender_vdpau.cpp:424 (Create) VDPAU: Created VDPAU render device 1920x1080
2016-02-06T23:53:41.785923-06:00 mythfrontend[7772]: N CoreContext mythplayer.cpp:526 (CheckExtraAudioDecode) Player(0): Forcing decode extra audio option on (Video method requires it).
2016-02-06T23:53:41.787589-06:00 mythfrontend[7772]: E CoreContext mythplayer.cpp:2395 (VideoStart) Player(0): Video sync method can't support double framerate (refresh rate too low for 2x deint)
2016-02-06T23:53:41.788072-06:00 mythfrontend[7772]: I CoreContext mythplayer.cpp:1785 (InitAVSync) Player(0): Video timing method: USleep with busy wait
2016-02-06T23:53:41.888863-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:5635 (StartPlayer) TV: Created player.
2016-02-06T23:53:41.889865-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:2485 (HandleStateChange) TV: Changing from None to WatchingPreRecorded
2016-02-06T23:53:41.891248-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:2576 (HandleStateChange) TV: Main UI disabled.
2016-02-06T23:53:41.891835-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:412 (StartTV) TV: Entering main playback loop.
2016-02-06T23:53:41.892569-06:00 mythfrontend[7772]: I CoreContext mythrender_vdpau.cpp:610 (CheckOutputSurfaces) VDPAU: Added 2 output surfaces (total 4, max 4)
2016-02-06T23:53:53.849035-06:00 mythfrontend[2306]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(7): Decoder timed out waiting for free video buffers.
2016-02-06T23:54:15.469017-06:00 mythfrontend[2306]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(7): Decoder timed out waiting for free video buffers.
2016-02-06T23:54:16.635271-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:2225 (HandleStateChange) TV: Attempting to change from WatchingPreRecorded to None
2016-02-06T23:54:16.637889-06:00 mythfrontend[7772]: W CoreContext mythpainter.cpp:36 (Teardown) MythPainter: 36 images not yet de-allocated.
2016-02-06T23:54:16.640640-06:00 mythfrontend[7772]: I CoreContext mythpainter_vdpau.cpp:108 (ClearCache) VDPAU Painter: Clearing VDPAU painter cache.
2016-02-06T23:54:16.740002-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:2485 (HandleStateChange) TV: Changing from WatchingPreRecorded to None
2016-02-06T23:54:16.740795-06:00 mythfrontend[7772]: I CoreContext tv_play.cpp:414 (StartTV) TV: Exiting main playback loop.
2016-02-06T23:54:16.741206-06:00 mythfrontend[7772]: N CoreContext mythmainwindow.cpp:2742 (PauseIdleTimer) Resuming idle timer
2016-02-06T23:54:37.191018-06:00 mythfrontend[2306]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(7): Decoder timed out waiting for free video buffers.
2016-02-06T23:54:58.911573-06:00 mythfrontend[2306]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(7): Decoder timed out waiting for free video buffers.


Player(7) is the mythplayer that had the video freeze.
Player(0) is the mythplayer launched after the freeze that does not have sound.

Player(7) is still throwing errors in while Player(0) is playing

The logs are after a freeze when the freeze was corrected via a remote sv stop frontend, sv start frontend.


Top
 Profile  
 
PostPosted: Sun Feb 07, 2016 10:10 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
This sounds an awful lot like the same problem I'm experiencing.
viewtopic.php?f=21&t=24276

Will have to check the logs next time it occurs and see what they say.


Top
 Profile  
 
PostPosted: Sun Feb 07, 2016 10:25 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
Mine just froze again. I had been watching Live TV on the same channel for about an hour or so.
Code:
2016-02-07T11:06:18.340702-05:00 mythfrontend[2336]: I CoreContext audio/audiooutputbase.cpp:792 (Reconfigure) AOBase: Opening audio device 'ladcomp' ch 2(2) sr 48000 sf 32 bit floating point reenc 0
2016-02-07T11:06:18.541702-05:00 mythfrontend[2336]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrames) Player(3): Waited 104ms for video buffers AAAAAAAAAAAAAA
2016-02-07T11:06:18.642873-05:00 mythfrontend[2336]: I CoreContext mythrender_vdpau.cpp:610 (CheckOutputSurfaces) VDPAU: Added 2 output surfaces (total 4, max 4)
2016-02-07T11:08:42.395408-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-07T11:08:42.599631-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-07T11:08:42.698556-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-07T11:08:43.399929-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-07T11:18:43.497939-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-07T11:23:42.487811-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-07T11:23:42.697297-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-07T11:23:42.697995-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-07T11:28:43.488319-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-07T11:38:42.483673-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-07T11:38:42.684941-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-07T11:38:42.785151-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-07T11:38:43.490136-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-07T11:48:43.588179-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-07T11:53:42.590503-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-07T11:53:42.791980-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-07T11:53:42.793101-05:00 mythfrontend[2336]: I CoreContext weatherSource.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-07T11:56:09.939919-05:00 mythfrontend[2336]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(3): Decoder timed out waiting for free video buffers.
2016-02-07T11:56:31.259412-05:00 mythfrontend[2336]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(3): Decoder timed out waiting for free video buffers.
2016-02-07T11:56:52.579176-05:00 mythfrontend[2336]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(3): Decoder timed out waiting for free video buffers.
2016-02-07T11:57:13.798897-05:00 mythfrontend[2336]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(3): Decoder timed out waiting for free video buffers.
2016-02-07T11:57:35.118562-05:00 mythfrontend[2336]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(3): Decoder timed out waiting for free video buffers

I don't think it's related to "VDPAU: Added 2 output surfaces" because I see those all the time in my logs without a freeze. But definitely the same problem.

I'm also pretty sure that it started two updates ago, prior to that did not see this problem. Have been using the same hardware for a year or more.


Top
 Profile  
 
PostPosted: Sun Feb 07, 2016 11:05 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
What is your video card?

The two shows that freeze seems to occur the most often in of are Ellen (wives daily recording goto) and the latest Sleepy Hollow died in two different spots on when viewing on two different days.


Top
 Profile  
 
PostPosted: Mon Feb 08, 2016 10:26 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
Video card is NVIDIA GT218 [GeForce 210]

I doubt that it's related to a particular program, mine just randomly hangs,
doesn't matter if its a recording or live tv.


Top
 Profile  
 
PostPosted: Mon Feb 08, 2016 11:18 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
I was able to get the audio back after a freeze. Somehow there is an extra mythfrontend process hanging around after reseting X or the fontend.

/usr/bin/mythfrontend -d --syslog local6

killing the oldest mythfrontend freed the ALSA HDMI device


Top
 Profile  
 
PostPosted: Tue Feb 09, 2016 12:41 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
Ok thanks. I will have to look for that. I am wondering where that is coming from?

One would think that if you restarted the frontend service It would kill the first one. Before starting another.


Top
 Profile  
 
PostPosted: Fri Feb 26, 2016 8:08 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
I was able to find that svc restart was not the way to go. I wrote a script that found the frontend pid and killed it. The normal action is to restart the frontend when it dies so that was a quick way to restart the front end.

Since then it seems to happen about once a week. I have noticed one thing that I find odd. Every time the time out occurs it's alway after it's been pulling weather data in the background. I find this very odd. But the last 3 times it's frozen. The log is identical. See below.
Code:
2016-02-26T21:03:37.934464-05:00 mythfrontend[2353]: N CoreContext mythplayer.cp
p:2135 (PrebufferEnoughFrames) Player(g): Waited 104ms for video buffers AAAAAAA
AdDdLAA
2016-02-26T21:04:23.783855-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-26T21:04:23.784577-05:00 mythfrontend[2353]: E CoreContext weatherSource
.cpp:443 (startUpdate) ENVCAN-Animated-Map recently updated, skipping.
2016-02-26T21:09:19.611330-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-26T21:09:19.909565-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-26T21:09:20.710555-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-26T21:14:23.837787-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-26T21:04:23.784577-05:00 mythfrontend[2353]: E CoreContext weatherSource
.cpp:443 (startUpdate) ENVCAN-Animated-Map recently updated, skipping.
2016-02-26T21:09:19.611330-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-26T21:09:19.909565-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-26T21:09:20.710555-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-26T21:14:23.837787-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-26T21:24:19.380693-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NWS-XML
2016-02-26T21:24:19.681266-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-18_Hour
2016-02-26T21:24:20.482810-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of NDFD-6_day
2016-02-26T21:24:23.494738-05:00 mythfrontend[2353]: I CoreContext weatherSource
.cpp:425 (startUpdate) Starting update of ENVCAN-Animated-Map
2016-02-26T21:33:00.648926-05:00 mythfrontend[2353]: E Decoder mythplayer.cpp:33
71 (DecoderGetFrame) Player(g): Decoder timed out waiting for free video buffers
.
2016-02-26T21:33:21.970906-05:00 mythfrontend[2353]: E Decoder mythplayer.cpp:33
71 (DecoderGetFrame) Player(g): Decoder timed out waiting for free video buffers

I can't see that making a difference (other than a little additional cpu usage). I'm going to disable background updates and see what happens just to see.


Top
 Profile  
 
PostPosted: Thu Mar 03, 2016 10:37 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
After crashing every other day for two weeks, it has not crashed for two week straight now. Very odd.


Top
 Profile  
 
PostPosted: Fri Mar 04, 2016 6:16 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 890
Location: Lexington, Ky
Well mine just crashed again today.
Code:
2016-03-04T11:00:27.311514-05:00 mythfrontend[30953]: I CoreContext mythrender_vdpau.cpp:1717 (CreatePresenta
tionSurfaces) VDPAU: Created 2 output surfaces.
2016-03-04T11:00:27.311847-05:00 mythfrontend[30953]: I CoreContext mythrender_vdpau.cpp:424 (Create) VDPAU:
Created VDPAU render device 1920x1080
2016-03-04T11:00:27.412255-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:526 (CheckExtraAudioDecode
) Player(7): Forcing decode extra audio option on (Video method requires it).
2016-03-04T11:00:27.413060-05:00 mythfrontend[30953]: I CoreContext avformatdecoder.cpp:2632 (OpenAVCodec) AF
D: Opened codec 0x136c940, id(MPEG2VIDEO) type(Video)
2016-03-04T11:00:27.413726-05:00 mythfrontend[30953]: I CoreContext audio/audiooutputbase.cpp:792 (Reconfigur
e) AOBase: Opening audio device 'ladcomp' ch 2(6) sr 48000 sf 32 bit floating point reenc 0
2016-03-04T11:00:27.714351-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 104ms for video buffers AAAAALAAAAAAdA
2016-03-04T11:00:27.815548-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 208ms for video buffers AAAAALAAAAAAdA
2016-03-04T11:00:27.916179-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 312ms for video buffers AAAAALAAAAAAdA
2016-03-04T11:00:28.117231-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 103ms for video buffers AAAAALAAdAAAdA
2016-03-04T11:00:28.217494-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 207ms for video buffers AAAAALAAdAAAdA
2016-03-04T11:16:58.349372-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 103ms for video buffers LAAdAAAAAADdAA
2016-03-04T11:19:30.113586-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 103ms for video buffers AAAALdAdDAAAAA
2016-03-04T11:38:28.471056-05:00 mythfrontend[30953]: N CoreContext mythplayer.cpp:2135 (PrebufferEnoughFrame
s) Player(7): Waited 104ms for video buffers AAAdAAAAAALDAd
2016-03-04T12:00:10.397865-05:00 mythfrontend[30953]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(
7): Decoder timed out waiting for free video buffers.
2016-03-04T12:00:31.718071-05:00 mythfrontend[30953]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(
7): Decoder timed out waiting for free video buffers.
2016-03-04T12:00:53.138660-05:00 mythfrontend[30953]: E Decoder mythplayer.cpp:3371 (DecoderGetFrame) Player(
7): Decoder timed out waiting for free video buffers.

As you can see from the log it starts Waiting for video buffers several times before it actually fails.
2016-03-04T11:00:27.714351-05:00 the 16 minutes, 19 minutes, 38 minutes and then at
2016-03-04T12:00:10.397865-05:00 times out an hangs.

Any ideas anyone?


Top
 Profile  
 
PostPosted: Thu Apr 28, 2016 10:53 pm 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
Here is a restart script:

Code:
#!/bin/bash
sv stop frontend
pkill /usr/bin/mythfrontend
sv start frontend


I went on a business trip and naturally the pvr broke hourly. Texting commands to the spouse from memory via a with phone both auto correct and auto casing made everything super complicated. After coming back home, I noticed the USB receiver for the keyboard, which was on an extender was knocked of the shelf and on to the ground. I re-positioned the extender back on the shelf and the hourly crashing stopped. Speculating that some lockups could be noise be received on the usb receiver. Still by far my most consistent lockup is at the 5 minutes mark in a show when the pvr has been inactive for an extended period of time. The second most common lockup is at the transition from regular programming to a commercial and vice versa.


Top
 Profile  
 
PostPosted: Fri Apr 29, 2016 12:43 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1196
Location: Orlando FL
Odd is it an RF or IR receiver ?
Was there a potential source of EM noise near the receiver?

_________________
My System


Top
 Profile  
 
PostPosted: Sat Jun 11, 2016 12:26 am 
Offline
Joined: Fri Nov 19, 2004 11:58 pm
Posts: 87
This is the occurring regularly in 8.4.1
thekingofspain wrote:
Still by far my most consistent lockup is at the 5 minutes mark in a show when the pvr has been inactive for an extended period of time.


Here is my 8.4.0 script that was rock stable unfortunately it did not work for me in 8.4.1.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu