LinHES Forums

VNC Preventing System Boot
Page 1 of 1

Author:  bbutler [ Wed Nov 28, 2018 10:42 pm ]
Post subject:  VNC Preventing System Boot

I've had my system running for several months now and it has been great. But today, I have a problem on bootup where the system is complaining:
"Can't find /home/vncsvr/.vnc/
You'll have to kill the process manually"

It continues to try to start the vncsvr, running through all the processes, then repeats this in an endless loop. I am able to ssh into the system. I've looked at logs without much luck. I can't figure out what I need to do to stop vnc from starting or even to kill the process to allow the rest of the system to boot. I've tried killing the vmc processes, but they simply respawn.

Any suggestions would be much appreciated.

Author:  welner [ Thu Nov 29, 2018 6:40 am ]
Post subject:  Re: VNC Preventing System Boot

/home/vncsvr/.vnc/ would be a text file containing the pid of a currently running vnc process. the script would read this file to find the process to kill it when instructed

since that process is no longer running, it cannot kill that process.

i would suggest ssh'ing to the box and removing that file. then reboot and see if you get further

Author:  bbutler [ Thu Nov 29, 2018 6:13 pm ]
Post subject:  Re: VNC Preventing System Boot


Thanks for the reply. I deleted the file and rebooted the machine. The same issue returned when it booted. It just keeps trying to start the vmc service and goes into a loop.

Any other thoughts?


Author:  bbutler [ Thu Nov 29, 2018 6:25 pm ]
Post subject:  Re: VNC Preventing System Boot

I also edited the /etc/systemconfig file changing:



In hopes this change would prevent the VNC service from starting, but no luck. It does the same thing on boot up. I changed it back to the original values, since it didn't help.

Author:  knappster [ Thu Nov 29, 2018 10:04 pm ]
Post subject:  Re: VNC Preventing System Boot

Do you know what the package is? I dont have a vncsvr installed and I dont see it in pacman. The only things I see are tigervnc and x11vnc and only x11vnc is installed. I also don't have a /home/vncsvr directory. Could it be /home/vncsvc instead? Have you checked what vnc packages you have installed? Maybe remove them if you aren't using them and see if that helps.

Author:  bbutler [ Mon Dec 03, 2018 9:31 pm ]
Post subject:  Re: VNC Preventing System Boot

I have TigerVNC installed, standard LinHES install from the CD. You are correct, it was /home/vncsvc

I couldn't resolve the issue from command line.

I did resolve the issue by performing an Upgrade Installation from the original CD-Rom I performed the initial install. It solved the problem with VNC and allowed the system to boot, but the system was out of sync because I performed an update to the system about a month ago.

To solve this, I performed a command line update, sudo pacman -Syu

All is well again. Thanks for your help, knappster and welner.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group