View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Jul 09, 2011 7:19 am 
Joined: Tue Nov 03, 2009 7:46 pm
Posts: 7
Location: Massachusetts, USA
I finally upgraded my R5.5 system to R6.01 yesterday. I use the storage directories feature of mythtv in order to use multiple disk for my recordings. Because of the small size of my /myth partition on my boot drive, I don't actually use it for recordings. During the upgrade my extra disks were ignored in the old /etc/fstab, so my storage directories didn't exist. This was pretty obvious and easy to fix. Once this was working, I could watch old recordings, but couldn't record anything new. Also mythweb, was not showing thumbnail images for recordings from just before my upgrade. I eventually tracked this down to the storage directories/recordings on my extra drives not being owned by the mythtv user in R6.01. It seems that the UID and GID for the mythtv user changed. It used to be 100/102 on my R5.5 system and is now 1000/1000 on my R6.01 upgrade. After using chown to fix permissions, everything started working again.

SUMMARY: Any disks that are physically/logically offline during a R5.* to R6.* upgrade should be checked for correct file/directory ownerships once they are brought back online due to UID/GID changes for the mythtv user.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu